Home > Community > Forums > Custom IC Design > spectre turbo in ocean

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 spectre turbo in ocean 

Last post Wed, Feb 10 2010 11:33 AM by jugemu1234. 6 replies.
Started by jugemu1234 10 Feb 2010 05:56 AM. Topic has 6 replies and 2024 views
Page 1 of 1 (7 items)
Sort Posts:
  • Wed, Feb 10 2010 5:56 AM

    spectre turbo in ocean Reply

    Hi,

    Ive been trying to run ocean script in turbo mode. Ive generated oceanScript.ocn first and observed following statement.

    option ( ?categ 'turboOpts
            'turboSwitch t
            'errorLevel "Do not override"
            'mtOption "Auto"
            'psrOption "Default"
    )

    I can run but it does not look fast enough. Token is eaten only one by spectre.

    Can you suggest me to turn on turbo mode in ocean?

     Thanks,

    • Post Points: 5
  • Wed, Feb 10 2010 6:16 AM

    Re: spectre turbo in ocean Reply

     \i option ( ?categ 'turboOpts
    \i      'turboSwitch t
    \i      'errorLevel "Do not override"
    \i      'mtOption "Auto"
    \i      'psrOption "Default"
    \i )
    \e *Error* eval: undefined function - ?categ

    Ive found error message above in CDS.log.

    • Post Points: 20
  • Wed, Feb 10 2010 8:00 AM

    • Ramkumar M
    • Not Ranked
    • Joined on Wed, Oct 14 2009
    • Bangalore, Karnataka
    • Posts 14
    • Points 220
    RE: spectre turbo in ocean Reply
    Hi,

    I see a gap between option and the opening bracket. Gap shouldn’t be there. Otherwise, the syntax looks fine.

    option( ?categ 'turboOpts …..


    Regards,

    Ramkumar
    • Post Points: 20
  • Wed, Feb 10 2010 8:29 AM

    Re: RE: spectre turbo in ocean Reply

    Hi Ramkumar,

    Thanks for your pointing out. It ran finally in turbo mode.

    But this is automatically generated like this by ADE...

    • Post Points: 20
  • Wed, Feb 10 2010 9:40 AM

    • Ramkumar M
    • Not Ranked
    • Joined on Wed, Oct 14 2009
    • Bangalore, Karnataka
    • Posts 14
    • Points 220
    RE: RE: spectre turbo in ocean Reply
    Which version are you using? “icms –W” should get the exact version.

    Also, check for OS patches.

    %> checkSysConf  -r

    This will list few releases like MMSIM7.1 or IC5.1 or IC6.1 etc. Pick one and enter the command like below

    %> checkSysConf IC5.1

    If it fails, you need to get the missing patches installed.

    Regards,
    Ramkumar
    • Post Points: 5
  • Wed, Feb 10 2010 11:01 AM

    • Ramkumar M
    • Not Ranked
    • Joined on Wed, Oct 14 2009
    • Bangalore, Karnataka
    • Posts 14
    • Points 220
    RE: RE: spectre turbo in ocean Reply
    Hi,

    This could probably be a code bug which could have got fixed in later versions. If you have a different IC version installed, please try with that and see if it helps resolve the issue.

    I tried in latest versions (IC5.1.41.500.6.140 and IC6.1.4.485) and don’t see this issue at my end.

    -Ramkumar
    • Post Points: 20
  • Wed, Feb 10 2010 11:33 AM

    Re: RE: RE: spectre turbo in ocean Reply

    Hi,

    Mine is sub-version IC5.10.41.500.6.132.


    And I ran checkSysConf IC5.1, then I got fail notice.

     

    • Post Points: 5
Page 1 of 1 (7 items)
Sort Posts:
Started by jugemu1234 at 10 Feb 2010 05:56 AM. Topic has 6 replies.