Home > Community > Forums > Custom IC Design > ASSURA LVS errors

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 ASSURA LVS errors 

Last post Fri, Jan 22 2010 11:33 AM by Quek. 3 replies.
Started by Dennis Faber 21 Jan 2010 05:22 PM. Topic has 3 replies and 2734 views
Page 1 of 1 (4 items)
Sort Posts:
  • Thu, Jan 21 2010 5:22 PM

    • Dennis Faber
    • Not Ranked
    • Joined on Thu, Jan 21 2010
    • Duisburg, Nrth Rhine Westfalia
    • Posts 8
    • Points 160
    ASSURA LVS errors Reply

    Hello,

    I hope you will undestand me. My English is not very well.

    My Problem:

    I have to check a layout with assura. It is an array and consists of tree components. I call them "basic cells". So I build tree types of columns of those cells and then I add them to an array. If I check the columns separetly. It works. Thereby the "basic cells" will be ckecked with ?flattenCellContents contition. If I try to verify the whole array. I get errors (device, nets) in one column and their subcell, "one of a basic cell". This column consist of two mirrored and overloop "basic cells of one type".

    I think I get the error message because the cells overlap. I assume Assura put some devices on the top of hierarchy and then can not map schmetatic and layout. So my question is, are there any rules I can put to avoid this problem?

    I have a solution that woks but I have to flatten one type of array. It take a lot of time to check the whole array.

    If you have some ideas, post otherwise correct my language skills! :-)

     Best regards, Dennis

    • Post Points: 20
  • Fri, Jan 22 2010 8:30 AM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,063
    • Points 16,185
    Re: ASSURA LVS errors Reply

    Hi Dennis

    Would you please post the specific error messages? It would be good if you can upload the cls file in the run directory. Perhaps you can try adding expandOnError cmd and see if it solves the problem. It can be found in avCompareRules of the lvs form. If you are running by batch mode, please add the following to the rsf file:

    avCompareRules(
       expandOnError( (unstableDevices t) (swap t) (reduce t) (pins t) (match t) (swapThres t) (instCount t) (skipMatchOnReduceError t) (ambiguousPinAssignment t) (parameter t) )
    ) ;avCompareRules


    Best regards
    Quek

    • Post Points: 20
  • Fri, Jan 22 2010 11:22 AM

    • Dennis Faber
    • Not Ranked
    • Joined on Thu, Jan 21 2010
    • Duisburg, Nrth Rhine Westfalia
    • Posts 8
    • Points 160
    Re: ASSURA LVS errors Reply

    Hi Quek!

    Thank you very mach for your reply and your hint! It works! Schematic and Layout match without any warrnings and errors!

    Thank you once more!

     Best regards, Dennis

    • Post Points: 20
  • Fri, Jan 22 2010 11:33 AM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,063
    • Points 16,185
    Re: ASSURA LVS errors Reply
    Hi Dennis

    This is good news. It was just a lucky guess. : )

    Best regards
    Quek
    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by Dennis Faber at 21 Jan 2010 05:22 PM. Topic has 3 replies.