Home > Community > Forums > Custom IC SKILL > How to include a subckt file and model in ADE

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 How to include a subckt file and model in ADE 

Last post Wed, Jan 6 2010 1:24 PM by Andrew Beckett. 5 replies.
Started by hanlei1975 03 Jan 2010 10:02 PM. Topic has 5 replies and 3106 views
Page 1 of 1 (6 items)
Sort Posts:
  • Sun, Jan 3 2010 10:02 PM

    • hanlei1975
    • Not Ranked
    • Joined on Fri, Dec 25 2009
    • Posts 6
    • Points 105
    How to include a subckt file and model in ADE Reply

    Dear master

    Q.1

    When I do simulation in hspiceS of ADE, I need to include model file and another subckt file, In Setup->Environment of ADE , I filled model file in  'include file" section, So how can I include the subckt file? it looks like the model file (.lib) and subckt file (.inc) can not exist both together.

    I need the generated netlist as following:

    ***include files

    .lib '/home/models/......

    .inc '/home/models/.....

    Q.2

    If there is CCCS component exist in shcematic, whatever the value of current gain of CCCS you filled in, the netlist generator creat this value always 1  ,what's the problem?

     

    Kind regards!

    Han

    • Post Points: 20
  • Sun, Jan 3 2010 11:19 PM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,066
    • Points 16,200
    Re: How to include a subckt file and model in ADE Reply
    Hi Han

    You can get the subckt file into your raw netlist as follows:
    a. Create a file that includes the following line:
    .inc /home/models/mySubcktfile.sp

    b. Add the above file to "Include File" field in "Setup->Environment"

    For the CCCS problem, the "Current gain" parameter which you see in the properties form is most likely for other simulators. Please go to "Options->Tool Filter" and enable only "hspiceS". The current gain should now be netlisted correctly.

    Best regards
    Quek
    • Post Points: 20
  • Sun, Jan 3 2010 11:50 PM

    Re: How to include a subckt file and model in ADE Reply
    Han,

    You would be far better using the hspiceD interface. In the Setup->Model Libraries form for that, you can specify a model file with a section name (in which case it uses .lib) or without (in which case it uses .include).

    The old hspiceS interface is not supported or maintained any more, whereas the hspiceD interface is - and has much better support for the simulator. It's also a much cleaner interface.

    Regards,

    Andrew
    • Post Points: 20
  • Wed, Jan 6 2010 9:52 AM

    • hanlei1975
    • Not Ranked
    • Joined on Fri, Dec 25 2009
    • Posts 6
    • Points 105
    Re: How to include a subckt file and model in ADE Reply

    Hi Quek

    thanks for your help.

    the netlist is correct now, but there is another question come from. even when I change current gain (hfgain) to 100 , it still displayed  fgain=10 in screen, while netlist is correct. does there is way to switch "fgain=10 " off ?

    • Post Points: 20
  • Wed, Jan 6 2010 12:21 PM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,066
    • Points 16,200
    Re: How to include a subckt file and model in ADE Reply

    Hi Hanlei

    cccs source is set up to display fgain for spectre and not hfgain for hspiceS. You can note this as follows:
    a. Go to cdf form for cccs cell
    b. Scroll down to "paramLabelSet". It reads : vref fgain ic

    To turn it off, you can go to cdf form, set cdf level to "user" and enter "vref ic" for paramLabelSet. But instead of turning it off, maybe you can use "vref hfgain ic".

    Maybe you can copy this cell to your own library so that you can change the base cdf info. It would be quite troublesome to use user cdf because you have to load it every time you restart Virtuoso.

    Best regards
    Quek

    • Post Points: 20
  • Wed, Jan 6 2010 1:24 PM

    Re: How to include a subckt file and model in ADE Reply

    Hanlei,

    You can also use the Edit->Component Display form to do this. By selecting one of the cccs instances, and selecting "parameter" you can alter which parameters get displayed.

    You can then save this information and use the "attach" button to attach the setup to your design library, such that it should get auto-loaded the first time you open the library in a session. This avoids you having to do all that messing around with User CDF each time (that Quek referred to). It's actually doing the same thing - altering the User CDF, but this is a supported flow for user-overrides.

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (6 items)
Sort Posts:
Started by hanlei1975 at 03 Jan 2010 10:02 PM. Topic has 5 replies.