Home > Community > Forums > Custom IC Design > problems with display settings

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 problems with display settings 

Last post Tue, Aug 4 2009 2:05 PM by AMSamirj. 4 replies.
Started by Peach99 30 Jul 2009 06:02 AM. Topic has 4 replies and 1666 views
Page 1 of 1 (5 items)
Sort Posts:
  • Thu, Jul 30 2009 6:02 AM

    • Peach99
    • Top 500 Contributor
    • Joined on Thu, Jul 30 2009
    • Posts 27
    • Points 435
    problems with display settings Reply

    Hi, I have a very important question about  the display setting of waveform (ADE). I know that I can change the colors in the display.drf - file, but my question is how I can set more different colors? I already know when I have more graphs as colors the line style changes automatically, but i want more then ten colors. And one another question is, how I can stop a simulation with a conditionally break. What I mean is, where I can enter a function or the like in the simulation settings, where I can define a break condition and how I can do this. For example I want to break a simulation if the graph reach a certain voltage value . Please help me! I don't know, how I can do this!

    Regards

    Daniel Pietsch 

    • Post Points: 35
  • Thu, Jul 30 2009 7:43 AM

    • skillUser
    • Top 10 Contributor
    • Joined on Fri, Sep 19 2008
    • Austin, TX
    • Posts 2,587
    • Points 15,915
    Re: problems with display settings Reply
    Hi Daniel,

    I'm not sure if you can set more than 10 distinct colours, to my
    knowledge this is what you get, but I am not well versed in the
    many advances in Wavescan (ViVA) vs. AWD, so it may be better
    than 10.

    For stopping the simulation, you could have a VerilogA module
    and use the debugger to put a conditional breakpoint in the
    simulation (I believe).

    However, I will let others either supply details or suggest any
    alternatives.

    Regards,
    Lawrence.
    • Post Points: 20
  • Thu, Jul 30 2009 10:50 AM

    • Peach99
    • Top 500 Contributor
    • Joined on Thu, Jul 30 2009
    • Posts 27
    • Points 435
    Re: problems with display settings Reply

    Thank you for this answere. Please can you explain this more exactly about the Veriloga. I don`t know how I can do this. And where is the Debugger.(my english is not very good)

    Best Regards

     

    Daniel Pietsch

    • Post Points: 20
  • Fri, Jul 31 2009 12:51 AM

    Re: problems with display settings Reply

    I'd be wary of depending on the VerilogA debugger, because it's been end-of-lifed.

    For VerilogA, you could write a model which monitored the node, and then invoked $stop or $finish to tell the simulator to end when that condition was reached.

    This is also something that is doable with SpectreMDL - but if you're an ADE user, that's probably not a good solution for you.

    For more information on VerilogA, look in the documentation, but also you may find A Designer's Guide to VerilogAMS useful as a place to learn more about the language.

    Regards,

    Andrew.

    • Post Points: 5
  • Tue, Aug 4 2009 2:05 PM

    • AMSamirj
    • Not Ranked
    • Joined on Thu, Sep 11 2008
    • <?xml version="1.0" encoding="utf-16"?><string>San Jose, CA</string>
    • Posts 11
    • Points 855
    Re: problems with display settings Reply
    You can place a file in your CWD called tracecolors.properties. List any Wavescan color in any order and wavescan will follow these.

    Regards,
     

    Samir Jafferali

     
    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by Peach99 at 30 Jul 2009 06:02 AM. Topic has 4 replies.