Home > Community > Forums > Custom IC Design > display packet information 'defaultPacket' not found

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 display packet information 'defaultPacket' not found 

Last post Fri, Jun 26 2009 7:35 AM by dmay. 1 replies.
Started by Malolo 25 Jun 2009 02:43 PM. Topic has 1 replies and 4128 views
Page 1 of 1 (2 items)
Sort Posts:
  • Thu, Jun 25 2009 2:43 PM

    • Malolo
    • Not Ranked
    • Joined on Thu, Jun 25 2009
    • Posts 15
    • Points 255
    display packet information 'defaultPacket' not found Reply

    Dear all,

    Sorry if i'm repeating any questions that were already solved but i did a search and could found any relating info. 

    I'm using IC 5141, during initialization, the first line in CIW window  is a warning: 

    *WARNING* The display packet information 'defaultPacket' for display was not found.  

    when trying to layout a circuit, another warning notice came with the title " undefined packets" : "there are undefined  packets found. Most likely, the display resource file (display.drf) for a library was not merged.  To merge a display.drf file, use ....................  " 

    My question is: are these two problems related? how to solve them? 

     I'm using  NCSU CDK and have  "cds.lib, .cdsinit, display.drf, .cdsplotinit" files placed in my working directory.  First 3 files are copied from  "cdssetup" folder in  ncsu-dk-1.5.1 packet and last fie was downloaded from the internet. 

     

    Really a newbie here, so any suggestions are appreciated!

     

    Malolo

    • Post Points: 20
  • Fri, Jun 26 2009 7:35 AM

    • dmay
    • Top 25 Contributor
    • Joined on Thu, Jul 17 2008
    • Allen, TX
    • Posts 396
    • Points 7,460
    Re: display packet information 'defaultPacket' not found Reply

    Yes, these two problems are related. Every layer defined in your technology file needs to have a display packed defined in a display.drf file. It could be as simple as having your display.drf in the wrong location and Cadence is not loading it by default. You can manually load your display.drf using this command:

    drLoadDrf("/path/to/display.drf")

    You can find our what packets you need by dumping your technology file. From your CIW, go to the Tools menu and then Technology File Manager. On the form that comes up, choose your technology library, Select All choices and specify a file to dump the information into. Open the dumped file and search for techDisplays. You'll find all of your layers and purposes in the first two columns and the third column will give you the expected packet name for that layer. This same packet name must also be defined in your display.drf.

    For example, in your techfile, you might see something like this:
     ;( LayerName    Purpose      Packet          Vis Sel Con2ChgLy DrgEnbl Valid )
     ;( ---------    -------      ------          --- --- --------- ------- ----- )
      ( default      drawing      defaultPacket      t nil nil t nil )

    Your display.drf will need something like the following:
    drDefinePacket(
    ;( DisplayName  PacketName           Stipple    LineStyle  Fill       Outline    [FillStyle])
     ( display      defaultPacket        circles    solid      silver     silver     outlineStipple)

    You can edit your display settings graphically. From your CIW, choose Tools->Display Resource Manager. You can choose to Edit or Merge. The Merge allows you to combine packet information from one display.drf with another. The Edit will bring up a GUI that will allow you to modify color and stipple information for each layer. Then you can use File->Save to dump out your modified display.drf.

    Derek

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by Malolo at 25 Jun 2009 02:43 PM. Topic has 1 replies.