Home > Community > Forums > Digital Implementation > How to make nanoroute understand "USEMINSPACING"

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 How to make nanoroute understand "USEMINSPACING" 

Last post Wed, Jan 10 2007 11:27 PM by archive. 4 replies.
Started by archive 10 Jan 2007 11:27 PM. Topic has 4 replies and 1719 views
Page 1 of 1 (5 items)
Sort Posts:
  • Wed, Jan 10 2007 11:27 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    How to make nanoroute understand "USEMINSPACING" Reply

    Hi,

    I am facing the following issue for quite sometime. Wonder if anyone is also facing the issue and has a solution?

    I have "USEMINSPACING OBS OFF ;" in the technolog lef. However, nanoroute places alot of wire at min spacing to "thick blockage". VerifyGeometry is able to detect these DRC, but nanoroute does not detect the violations. It is quite a pain to clean these violations post-layout.

    Anyone also face this issue? Thanks.

    Regards,
    Eng Han



    Originally posted in cdnusers.org by EngHan
    • Post Points: 0
  • Thu, Jan 11 2007 1:53 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: How to make nanoroute understand "USEMINSPACING" Reply

    Hi,
    Try the following:
    setNanoRouteMode -quiet drouteUseMinSpacingForBlockage false

    If the "thick blockage" is memory, those min_step violations you see maybe false, because LEF doesn't show the real route of the memory, and the blockage you see is not "thick". The final DRC checks are performed with GDS and not with LEF


    Originally posted in cdnusers.org by Stalker
    • Post Points: 0
  • Sun, Jan 14 2007 9:44 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: How to make nanoroute understand "USEMINSPACING" Reply

    Hi Stalker,

    Thanks for the tip. I try the setting, and it works around 95% of the time! For example, if I don't use this setting, I get 100 violations. If I use the setting, I get much less violations, about 5.

    With or without the settings, nanroute finished with 0 violations. Something else is still strange...

    Regards,
    Eng Han


    Originally posted in cdnusers.org by EngHan
    • Post Points: 0
  • Mon, Jan 15 2007 7:49 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: How to make nanoroute understand "USEMINSPACING" Reply

    It is possible that Nanoroute still did not see those 5 violationsblockages as fat blockages. In lef5.6 syntax, you can make those blockages with the spacing you want. You can check the lef reference doc. As for why Nanoute did not see the violation, one possible answer is that those are power wire with slotting and the lef is modeled it as thin blockage.

    li siang


    Originally posted in cdnusers.org by lisiang
    • Post Points: 0
  • Mon, Jan 15 2007 7:50 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: How to make nanoroute understand "USEMINSPACING" Reply

    Hi,

    I look at the remaing violations and observed that they are of the same type.

    The violation is between routed M4 with M4 pin (from the lef). The M4 pin is a power net. When this M4 pin tape to a wide M3 pin (also in the lef), spacing from the VIA34 has to obey wide metal spacig. It look like nanorouter does not understanding this while verifyGeometry detct the error.For now, I am not sure if nanoroute is correct or verifyGeometry is correct.

    Regards,
    Eng Han


    Originally posted in cdnusers.org by EngHan
    • Post Points: 0
Page 1 of 1 (5 items)
Sort Posts:
Started by archive at 10 Jan 2007 11:27 PM. Topic has 4 replies.