Home > Community > Forums > Custom IC Design > Passing an Additional Subcircuit Parameter for a Mos Model

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Passing an Additional Subcircuit Parameter for a Mos Model 

Last post Thu, May 7 2009 11:32 AM by aplumb. 3 replies.
Started by Trail Animal 07 May 2009 10:38 AM. Topic has 3 replies and 1705 views
Page 1 of 1 (4 items)
Sort Posts:
  • Thu, May 7 2009 10:38 AM

    Passing an Additional Subcircuit Parameter for a Mos Model Reply

    I thought this was a no-brainer...but after a couple of hours of frustration, I have no brain!?!?

     I'm just trying to pass an additional parameter to a mos model so I can do selective monte carlo sims.  I'm using an integer as a boolean "on/off" switch in the mmvtho & mmbeta definitions.  I've modified the model and edited the "base" cdf to use this new parameter, but I can't get the netlister to include it in the subcircuit call.  It shows up on the edit properties dialog, but it just gets ignored when netlisted!?!?  If I modify the netlist directly, it works fine, but that's too much work to do evrytime I need to re-netlist!

     I've searched the related user guides and tried various ways to define the variable (integer, string, etc..), but I'm at a loss??? 

     Any thoughts would be appreciated...

    Thanks

    -Rob

    • Post Points: 20
  • Thu, May 7 2009 10:56 AM

    • aplumb
    • Top 75 Contributor
    • Joined on Wed, Jul 16 2008
    • Ottawa, Ontario
    • Posts 80
    • Points 1,230
    Re: Passing an Additional Subcircuit Parameter for a Mos Model Reply
    First thing to do is check the Base CDF for this component and make sure you've included the parameter name in the simulator's simInfo - instParameters list. Andrew.
    • Post Points: 20
  • Thu, May 7 2009 11:24 AM

    Re: Passing an Additional Subcircuit Parameter for a Mos Model Reply

    Andrew...Genius!!!  Works perfectly now!  I only saw the terminals listed in the general CDF form under simInfo and didn't realize if I selected the edit, all the other parameters were there!?!?  I modified both the spectre and the hspiceS versions, even though I'm using spectre...I noticed that the macroArgumentStyle is hspiceS and that there isn't a spectre option!?!?

     Thanks again...

    Rob

    • Post Points: 20
  • Thu, May 7 2009 11:32 AM

    • aplumb
    • Top 75 Contributor
    • Joined on Wed, Jul 16 2008
    • Ottawa, Ontario
    • Posts 80
    • Points 1,230
    Re: Passing an Additional Subcircuit Parameter for a Mos Model Reply
    Each netlister has its own special needs, so you'll see variety between simInfo. Just wait until you get to the LVS stage and have to figure out the subtle differences between auCdl (used by Calibre) and auLvs (used by Assura). Also, start getting familiar with hspiceD - when you move on to the IC6.1.x environment you'll find all the 'S' variants of netlisters are completely gone.
    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by Trail Animal at 07 May 2009 10:38 AM. Topic has 3 replies.