Home > Community > Forums > Custom IC Design > spectre version error

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 spectre version error 

Last post Sun, Mar 15 2009 5:54 PM by Jim McMahon. 1 replies.
Started by sabertooth 15 Mar 2009 02:53 PM. Topic has 1 replies and 3199 views
Page 1 of 1 (2 items)
Sort Posts:
  • Sun, Mar 15 2009 2:53 PM

    • sabertooth
    • Not Ranked
    • Joined on Sun, Mar 15 2009
    • Posts 1
    • Points 20
    spectre version error Reply

    Hi everyone.

    My issue is as follows:

    ----------------------------------------

    1. I set up the cadence environment.

    2. Now I fire up the workbench and enter a schematic using Virtuoso composer.

    3.  I open ADE and when I run the simulation, I see the following error in CIW.

     *Error* The 'spectre' executable that you are using is an older version.
            Use MMSIM60 or later version of Spectre with this release.
            To check the spectre version, run 'spectre -W'.

     ----------------------------------------

    Here are some useful messages from CIW just before this:

    *WARNING* (icLic-3) Could not get license Analog_Design_Environment_L
    (deLicense-6) Checked out the license for ADE XL to run ADE L
    Loading awv.cxt
    Loading socket.cxt
    Loading alvs.cxt
    ERROR: can't determine installation root.
           can't create rooted path to arg0 "viva"
           using current working directory or $PATH: /usr/licensed/cadence-20060508/SOC52.sun4v/tools/bin:/usr/licensed/cadence-20060508/IFV62.sun4v/tools/bin:/usr/licensed/cadence-20060508/MMSIM62.sun4v/tools.sun4v/bin:/usr/licensed/cadence-20060508/IC610.sun4v/tools/bin:/usr/licensed/synopsys/hspice_A-2007.09/hspice/bin:/usr/licensed/synopsys/mw_A-2007.12-SP1/bin/SUN.64:/usr/licensed/synopsys/jupiterxt_Z-2007.03-SP5/bin/SUN.64:/usr/licensed/synopsys/astro_Z-2007.03-SP5/bin/SUN.64:/usr/licensed/synopsys/spiceexplorer_C-2009.03/c2009.03/sx_c2009_03/bin:/usr/licensed/synopsys/taurus_tsuprem4_A-2007.12/bin:/usr/licensed/synopsys/vcs-mx_B-2008.12/bin:/usr/licensed/synopsys/mw_A-2007.12-SP1/bin:/usr/licensed/synopsys/txs_A-2007.12-SP1/bin:/usr/licensed/synopsys/pts_Z-2007.06-SP2/bin:/usr/licensed/synopsys/taurus_medici_Z-2007.03/bin:/usr/licensed/synopsys/sentaurus_Z-2007.03/bin:/usr/licensed/synopsys/syn_B-2008.09-SP3/bin:/usr/psr.oit/solaris10/2007-2.0/bin:/usr/psr.oit/solaris10/2007-2.0/sbin:/usr/psr.oit/solaris10/2007-2.0/local/bin:/usr/psr.oit/solaris10/2007-2.0/local/sbin:/u/mshoaib/bin:/usr/licensed/bin:/usr/openwin/bin:/usr/ccs/bin:/opt/SUNWspro/bin:/usr/ucb:/usr/local/bin:/bin:/sbin:/usr/bin:/usr/sbin:.
    Loading adexl.cxt

    *Error*   Failed to launch ViVA. There is a problem with the DFII
              installation hierarchy (Exit Code = 1).
              For further assistance, contact Cadence Customer Support
              with the diagnostic information available in the log file.
    *Info*    Dumping diagnostic information ....
    /usr/licensed/cadence-20060508/IC610.sun4v/tools.sun4v/dfII/bin/checkwavescan: wavescan: not found

      ----------------------------------------

    I tried to check the path variable and even typed "Spectre -W/-V" which showed version 6.2 being in the path.

    I do not understand why is the tool trying to access the older version of spectre even though, the first occurence of the executable in ($PATH, which is written above) refers to the higher version of 6.2.

    I have the following questions:

      ----------------------------------------

    1. Is the error "cannot load ViVA" related to cadence not finding the new spectre executable ?

    2. How can I set the path within the CIW (will using SkillSetPath, not affect the other tools ?)

    3. Is there a problem with my $PATH ?

     

    Thanks in anticipation for your assistance with this !!

    - Shoaib

    • Post Points: 20
  • Sun, Mar 15 2009 5:54 PM

    • Jim McMahon
    • Top 500 Contributor
    • Joined on Fri, Feb 20 2009
    • San Jose, CT
    • Posts 21
    • Points 355
    Re: spectre version error Reply

    Hi Shoaib

     I noticed from your error message that $CDS_INST_DIR/tools/dfII/bin does not appear to be in your $PATH. Not sure how you are able to launch virtuoso without this in your $PATH.... Your cadence environment setup requires the following 2 paths:
            $CDS_INST_DIR/tools/bin
            $CDS_INST_DIR/tools/dfII/bin

    This should solve the earlier VIVA warnings and perhaps answers question #3.

    After fixing the $PATH, run "which virtuoso" and " virtuoso -W" to make sure it is picking up the correct virtuoso executable. Try the same for the spectre executable.

     - I don't know what role the viva issue this is playing in your spetre issue.

    - For question #2 above, I you trying to set the SKILL path or the unix $PATH?

    Assuming UNIX path:

     setShellEnvVar("PATH=<X>" ) ;;;where <X> = desired PATH

     

     

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by sabertooth at 15 Mar 2009 02:53 PM. Topic has 1 replies.