Home > Community > Forums > Digital Implementation > Set cell dont use

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Set cell dont use 

Last post Wed, Feb 15 2006 2:52 AM by archive. 3 replies.
Started by archive 15 Feb 2006 02:52 AM. Topic has 3 replies and 1654 views
Page 1 of 1 (4 items)
Sort Posts:
  • Wed, Feb 15 2006 2:52 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    Set cell dont use Reply

    I'm trying to forbid some cells to use in Encounter during optimize
    just like below:

    dbSetIsCellDontUse [dbGetCellByName bfx05pdv] 1
    dbSetIsCellDontUse [dbGetCellByName ivx05pdv] 1

    But during the optimisatiom FE did still use these cells.
    Also when I looked at the dontusecells list, these cells are
    defined inside.
    Do you have any suggestions?


    Originally posted in cdnusers.org by DN
    • Post Points: 0
  • Wed, Feb 15 2006 9:25 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Set cell dont use Reply

    add the following to your sdc file should do it.

    set_dont_use "bfx05pdv ivx05pdv" TRUE




    li siang


    Originally posted in cdnusers.org by lisiang
    • Post Points: 0
  • Wed, Feb 22 2006 9:44 PM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Set cell dont use Reply

    After using db command, you must use "setupfootprint" to update the cell's footprint usage prior to using optDesign.

    BTW, some commands may refresh the dontuse setting on your internal command setting. So it is safe to use sdc. If you insist on using db command, you can use it immediately before optimization command.


    Originally posted in cdnusers.org by yasonwang
    • Post Points: 0
  • Mon, Mar 6 2006 11:49 AM

    • archive
    • Top 75 Contributor
    • Joined on Fri, Jul 4 2008
    • Posts 88
    • Points 4,930
    RE: Set cell dont use Reply

    Hi,

    The reply is late, but maybe useful for reference.

    It is common to load both min and max library into Encounter. A side effect in this is that when setting "setDontUse", you have to set it for both libraries! Do something like

    setDontUse someLibbc/DELAY1 true
    setDontUse someLibwc/DELAY1 true

    Regards,
    Eng Han


    Originally posted in cdnusers.org by EngHan
    • Post Points: 0
Page 1 of 1 (4 items)
Sort Posts:
Started by archive at 15 Feb 2006 02:52 AM. Topic has 3 replies.