Home > Community > Forums > Digital Implementation > Errors in pad fillers using AMS 0.35u technology (SOCE)

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Errors in pad fillers using AMS 0.35u technology (SOCE) 

Last post Tue, Dec 2 2008 11:36 AM by Kari. 7 replies.
Started by Mooty 31 Oct 2008 11:04 PM. Topic has 7 replies and 2821 views
Page 1 of 1 (8 items)
Sort Posts:
  • Fri, Oct 31 2008 11:04 PM

    • Mooty
    • Not Ranked
    • Joined on Fri, Oct 31 2008
    • Posts 9
    • Points 165
    Errors in pad fillers using AMS 0.35u technology (SOCE) Reply

    Hi,

    I'm using SOCE for P&R and I keep getting this spacing error with the pad fillers:

    Pin of Cell IN0_5 & Blockage of Cell pfill_W_44

    Actual:     0.7     Min:     0.8    bbox = (180.000, 1768.250) (180.700, 1772.550)

     I cannot seem to resolve it.  What could be the problem?

     

    • Post Points: 20
  • Fri, Nov 7 2008 6:09 AM

    • vishnu
    • Not Ranked
    • Joined on Fri, Oct 24 2008
    • Hyderabad, Arunachal Pradesh
    • Posts 10
    • Points 240
    Re: Errors in pad fillers using AMS 0.35u technology (SOCE) Reply
    Hello Mooty, Would you be able to publish the zoomed snap shot of the violation with blockage and pin highlighted ? Thanks, Vishnu
    --Vishnu
    • Post Points: 20
  • Sun, Nov 9 2008 7:54 AM

    • Mooty
    • Not Ranked
    • Joined on Fri, Oct 31 2008
    • Posts 9
    • Points 165
    Re: Errors in pad fillers using AMS 0.35u technology (SOCE) Reply

     Hi,

     Thanks for responding!

    Attached are some of the pics detailing the errors.

     

     

    There are 2 main DRCs, one between the fillers etc. and the other is the special route to the power I/O pads.

    • Post Points: 20
  • Wed, Nov 12 2008 11:37 AM

    • Kari
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Cary, NC
    • Posts 693
    • Points 14,295
    Re: Errors in pad fillers using AMS 0.35u technology (SOCE) Reply

     Hi Mooty,

    The first picture looks like nanoRoute is trying to route some nets that are really connected by abutment of the IO cells. You should place a -skip_routing attribute on these nets:

    setAttribute -net net1 -skip_routing true

    The second picture looks like a violation between the route to the IO pin and the blockages around the IO pin. These may or may not be real violations - you'll have to run your signoff DRC to be sure. 

    I'm not sure about the other two.

    - Kari 

    • Post Points: 20
  • Tue, Nov 18 2008 4:00 AM

    • Mooty
    • Not Ranked
    • Joined on Fri, Oct 31 2008
    • Posts 9
    • Points 165
    Re: Errors in pad fillers using AMS 0.35u technology (SOCE) Reply

    Hi,

    Thanks a lot for your help.

     The first case, however, is actually the connection between the power pads and the power ring.   This connection is necessary right?

    I have another problem now.

     

     

     Apparently, there are some  DRCs between the power stripe and the cells beside it.  The error seems related to the clock as all of the errors have the clock present.


    • Post Points: 20
  • Fri, Nov 21 2008 2:41 PM

    • Kari
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Cary, NC
    • Posts 693
    • Points 14,295
    Re: Errors in pad fillers using AMS 0.35u technology (SOCE) Reply

     For the first issue, if you mean that the IO ring is connected by abutment but you are seeing violations, it could be blockages causing verify geometry to think there is an error where there really isn't. You can try turning on/off some of the ver geom settings and see if you get different results. The real test is signoff DRC. Does it show any problems in your IO ring?

    For the second issue, it's hard to tell from this picture (not everything is turned on), but it looks like you have a wide metal (the power) too close to regular routing. Maybe your clock routes are double-width? I'm not sure. Turn on signal routing and see if you can tell what the error marker is flagging. The text description should also shed some light.

    • Post Points: 20
  • Mon, Nov 24 2008 12:20 AM

    • Mooty
    • Not Ranked
    • Joined on Fri, Oct 31 2008
    • Posts 9
    • Points 165
    Re: Errors in pad fillers using AMS 0.35u technology (SOCE) Reply

     Hi,

    with regards to the second issue, 

     

    The error message is of this form:

    SPACING: Regular Via of Net Final/CLK__L7_N231 & Special Wire of Net vdd!  ( M2 )
    Bounds : ( 2746.350, 711.800 ) ( 2747.100, 712.600 )
    Actual:     0.75     Min:     0.8

    I still can't figure out how to solve this problem.  Is this a placement problem?

     

    • Post Points: 20
  • Tue, Dec 2 2008 11:36 AM

    • Kari
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Cary, NC
    • Posts 693
    • Points 14,295
    Re: Errors in pad fillers using AMS 0.35u technology (SOCE) Reply

     Mooty,

    You have a spacing violation between the m2 in the via on the C pin and the m2 bus on the left. (I think your nets are not displayed because you are in floorplan view instead of physical view.) Once you get the nets displayed, the error should be clear.

    - Kari 

    • Post Points: 5
Page 1 of 1 (8 items)
Sort Posts:
Started by Mooty at 31 Oct 2008 11:04 PM. Topic has 7 replies.