Home > Community > Forums > Custom IC SKILL > could not launch skillDev IDE

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 could not launch skillDev IDE 

Last post Mon, Apr 28 2014 11:22 AM by Noca. 6 replies.
Started by Noca 23 Apr 2014 01:48 PM. Topic has 6 replies and 524 views
Page 1 of 1 (7 items)
Sort Posts:
  • Wed, Apr 23 2014 1:48 PM

    • Noca
    • Not Ranked
    • Joined on Wed, Apr 23 2014
    • Posts 4
    • Points 65
    could not launch skillDev IDE Reply
    Hi, there.

    I'm currently using IC6.16.

    I tried to invoke skillDev IDE from the CIW window and the only message I got 
    was:
    Loading skillDev.cxt

    but nothing happened after that.

    I looked at the CDS.log and here it is

    \# Program start time UTC 2014.04.23 10:25:12.230
    \# Local time Wednesday 23 April 2014, 10:25 am
    \o Program: @(#)$CDS: virtuoso version 6.1.6-64b 05/03/2013 14:44 (sjfnl178) $
    \o Hierarchy: /usr/local/cad/cadence/ic6/ic616005/tools.lnx86/dfII/
    \o Sub version: sub-version  IC6.1.6-64b.101  (64-bit addresses)
    \# Host name (type): Jupiter.Klipsch (x86_64)
    \# Operating system: Linux 3.11.10-7-desktop #1 SMP PREEMPT Mon Feb 3 09:41:24 UTC 2014 (750023e)
    \# Linux /etc/issue: Welcome to openSUSE 13.1 "Bottle" - Kernel \r (\l).
    \# X display name (WxH): :0 (1920x1206)
    \# Available geometry: TL(0:6) BR(1919:1205)
    \# X server: The X.Org Foundation
    \# Depth of Visual (Root): 24 (24)
    \# Number of Planes Used: 24
    \# X version: 11.0 (vendor release 11403901)
    \# X resource pool: base 0x5000000, mask 0x1fffff (2097151), shift 0
    \# current id 0x0, current max 0x1ffffa (2097146)
    \# Max data seg size:     unlimited
    \# Max process size:     unlimited
    \# Initial sbrk value:        303 MB
    \# Available memory:     13,728 MB
    \# System memory:     16,089 MB
    \# Maximum memory size:     15,844 MB
    \# Max mem available:     13,786 MB
    \# Initial memory used:         58 MB
    \#        process size:        687 MB
    \# Qt version: 4.7.2
    \# Window Manager: kde
    \# User Name: nkerstram
    \o Working Directory: Jupiter.Klipsch:/home/nkerstram/projects/cadence
    \# Process Id: 5738
    \o 
    \o COPYRIGHT © 1992-2013  CADENCE DESIGN SYSTEMS INC.  ALL RIGHTS RESERVED.
    \o           © 1992-2013  UNIX SYSTEMS Laboratories INC.,
    \o                          Reproduced with permission.
    \o 
    \o This Cadence Design Systems program and online documentation are
    \o proprietary/confidential information and may be disclosed/used only
    \o as authorized in a license agreement controlling such use and disclosure.
    \o 
    \o           RESTRICTED RIGHTS NOTICE (SHORT FORM)
    \o Use/reproduction/disclosure is subject to restriction
    \o set forth at FAR 1252.227-19 or its equivalent.
    \# Available memory:         13,714 MB at UTC 2014.04.23 10:25:12.580
    \# Memory report: Maximum memory size now 13,787 MB at UTC 2014.04.23 10:25:12.580
    \o Loading geView.cxt 
    \o Loading menuBuilder.cxt 
    \o Loading schView.cxt 
    \o Loading selectSv.cxt 
    \o Loading LVS.cxt 
    \o Loading layerProc.cxt 
    \o Loading pte2.cxt 
    \o Loading xlUI.cxt 
    \o Loading auCore.cxt 
    \o Loading dcm.cxt 
    \o Loading vhdl.cxt 
    \o Loading seismic.cxt 
    \o Loading ci.cxt 
    \o Loading ams.cxt 
    \o Virtuoso Framework License (111) was checked out successfully. Total checkout time was 0.01s.
    \o Loading oasis.cxt 
    \o Loading analog.cxt 
    \o Loading asimenv.cxt 
    \o Loading spectrei.cxt 
    \# Memory report: using         160 MB, process size 813 MB at UTC 2014.04.23 10:25:13.713
    \o Loading relXpert.cxt 
    \o Loading awv.cxt 
    \o 
    \o 
    \a _ilgRunSkillIde()
    \o Loading skillDev.cxt 
    \r nil

    When I looked at the Options->License, I have license #s 111, 95115 and 95220 as 
    Checked Out Licenses and # 900 as Relevant Licenses.

    I would appreciate if someone could help me.

    Many thanks in advance.

    Best regards,

    • Post Points: 20
  • Sat, Apr 26 2014 1:09 PM

    Re: could not launch skillDev IDE Reply

    Please try doing this before trying to launch the IDE:

    sstatus(errsetTrace t)
    _stacktrace=tracelevel=tracelength=50

    and then if it fails, please post the errors you see.

    Also, after it failing, can you type "errset.errset" in the CIW and see what you get?

    Thanks,

    Andrew.

    • Post Points: 20
  • Mon, Apr 28 2014 9:42 AM

    • Noca
    • Not Ranked
    • Joined on Wed, Apr 23 2014
    • Posts 4
    • Points 65
    Re: could not launch skillDev IDE Reply
    Hi, Andrew,

    Thanks for the reply.

    Entering with

    sstatus(errsetTrace t)
    _stacktrace=tracelevel=tracelength=50

    in the CIW and then launching skillDev IDE produced the following on the CIW
    window:

    *Error* breakpt: skillDev not enabled.
    <<< Stack Trace >>>
    (... in _ilgDbgInitialize ...)
    (... in ilGetIdeSessionWindow ...)
    (... in unknown ...)
    funobj@0x159e7ef8()
    (... in _ilgRunSkillIde ...)
    _ilgRunSkillIde()

    and typing "errset.errset" in the CIW produced:

    errset.errset
    nil

    Best regards,

    • Post Points: 20
  • Mon, Apr 28 2014 9:48 AM

    Re: could not launch skillDev IDE Reply

    Ah, that means that you don't have the license (at least it's not available). I've just checked, and if I try to launch the IDE when it can't get a license, I get the same behaviour. You'd get the same thing if you tried typing installDebugger() in the CIW - it will tell you that skillDev is not enabled.

    We ought to have an error message telling you that it couldn't get a license, I agree.

    Regards,

    Andrew.

    • Post Points: 20
  • Mon, Apr 28 2014 10:01 AM

    • Noca
    • Not Ranked
    • Joined on Wed, Apr 23 2014
    • Posts 4
    • Points 65
    Re: could not launch skillDev IDE Reply
    Oh, OK.

    Thanks very much, Andrew.
     
    I'll contact our admin to see if we could get an updated license. And for sure some message would help!!

    Best regards,

    • Post Points: 20
  • Mon, Apr 28 2014 10:06 AM

    Re: could not launch skillDev IDE Reply

    I found CCR 1212069 was filed for this, and has been fixed for the IC617 release (not due until next year). It looks from the CCR as if the fix might get backported to an IC616 hotfix too, but there's no commitment for that yet.

    Regards,

    Andrew.

    • Post Points: 20
  • Mon, Apr 28 2014 11:22 AM

    • Noca
    • Not Ranked
    • Joined on Wed, Apr 23 2014
    • Posts 4
    • Points 65
    Re: could not launch skillDev IDE Reply

    Thanks, Andrew.

     

    Best regards,


    • Post Points: 5
Page 1 of 1 (7 items)
Sort Posts:
Started by Noca at 23 Apr 2014 01:48 PM. Topic has 6 replies.