Home > Community > Forums > Functional Verification > CMOS INVERTER LAYOUT DEBUG!?

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 CMOS INVERTER LAYOUT DEBUG!? 

Last post Sat, Oct 19 2013 10:40 PM by tempVar. 1 replies.
Started by tempVar 19 Oct 2013 12:44 AM. Topic has 1 replies and 3637 views
Page 1 of 1 (2 items)
Sort Posts:
  • Sat, Oct 19 2013 12:44 AM

    • tempVar
    • Not Ranked
    • Joined on Thu, Oct 10 2013
    • Posts 12
    • Points 120
    CMOS INVERTER LAYOUT DEBUG!? Reply

     Hello all. So I am in the process of simulating my layout extraction. I ran DRC which was successful.I ran LVS which returned a negative output (my schematic netlist and extracted netlist DO NOT MATCH);however, I continued with the simulation hoping to see if I can gain some info from the plots... 

     Here is my layout and the plot of the simulation of the extraction (sorry for the bad quality layout image). 

    Please help me debug this issue. What should I be looking for?

     Thank you.simulationLAYOUT

    • Post Points: 5
  • Sat, Oct 19 2013 10:40 PM

    • tempVar
    • Not Ranked
    • Joined on Thu, Oct 10 2013
    • Posts 12
    • Points 120
    Re: CMOS INVERTER LAYOUT DEBUG!? Reply

    Fixed! It is kind of obvious where the problem is! If you can tell the nmos seems to be working properly (as seen in the wave forms). It is the pmos part that seems to be messed up, it is also apperent that the pmos is simply not doing anything or in other words; not functioning... Hmmmm, what may cause such an issue? THINK ABOUT IT!!!

     Done thinking?

     I didn't have a voltage source for my pmos! : ( 

    Sorry for the premature thread, next time I will give it more thought. I have 93 views as of this writing though, I bet you guys are also working on the same assignment I am... Good luck!

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by tempVar at 19 Oct 2013 12:44 AM. Topic has 1 replies.