Home > Community > Forums > Custom IC Design > Resistor transient noise issues with spectre

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Resistor transient noise issues with spectre 

Last post Tue, Aug 27 2013 8:56 PM by Andrew Beckett. 1 replies.
Started by samini 22 Aug 2013 02:09 PM. Topic has 1 replies and 326 views
Page 1 of 1 (2 items)
Sort Posts:
  • Thu, Aug 22 2013 2:09 PM

    • samini
    • Not Ranked
    • Joined on Wed, Aug 14 2013
    • Posts 8
    • Points 160
    Resistor transient noise issues with spectre Reply

    Hi,

    I am trying to run a tranisent noise with a model based op-amp to try to speed up the simulation time.  I have a problem where despite the fact that I choose a particular resistor as not generating noise (setting "Generate Noise?" to No ) or choosing the resistor as not contributing to noise in the Noise Contribution list of transient noise, spectre still seems to account for the noise.

    I can see this issue because if I set the resistor value to zero, there is no noise.  But if I choose a very large value (10Gohms for example), I can clearly see the noise voltage being generated (again with Generate Noise clearly set to No AND/OR the resistor chosen as "off" in the Noise Contribution list).

     It's surprising because when you simulate a single resistor you can either turn off the noise but this seems to be overriden when simulated in the circuit.

     Any idea why spectre behaves like this? 

    • Post Points: 20
  • Tue, Aug 27 2013 8:56 PM

    Re: Resistor transient noise issues with spectre Reply

    I don't see this. For example, with this netlist:

    //
    v1 (n1 0) vsource dc=0
    r1 (n1 n2) resistor r=10G isnoisy=yes
    r2 (n2 0) resistor r=5k isnoisy=no

    tran tran noisefmax=1M stop=2u noiseoff=[r1]

    Then n2 is a flat 0 if I either use noiseoff=[r1] or set r1 to isnoisy=no. If I leave it as isnoisy=yes and remove the noiseoff=[r1], I get noise at the output (and if I turn on the second resistor it's much noisier, of course).

    So which MMSIM version are you using? (see the spectre subversion at the top of the output log, or type "spectre -W" in the UNIX terminal window).

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by samini at 22 Aug 2013 02:09 PM. Topic has 1 replies.