Home > Community > Forums > Custom IC Design > cdsRemsh ignores "ssh" setting .cdsenv

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 cdsRemsh ignores "ssh" setting .cdsenv 

Last post Mon, Mar 10 2014 7:10 PM by vader. 4 replies.
Started by kitmonisit 21 Aug 2013 08:38 PM. Topic has 4 replies and 935 views
Page 1 of 1 (5 items)
Sort Posts:
  • Wed, Aug 21 2013 8:38 PM

    cdsRemsh ignores "ssh" setting .cdsenv Reply

    I am setting up a Distributed Processing environment using cdsqmgr.

    I have the following lines in my ~/.cdsenv

    asimenv.distributed copyMode boolean t
    asimenv.distributed remoteShell string "ssh"
    asimenv.distributed loginShell cyclic "csh"
    

    I found a cdsRemote.scr in /usr/cadence/IC610/share/cdsssetup/cdsRemsh and followed the instructions there. Somewhere in LINE 43 of this file, I see:

    remoteSystem=rsh
    #remoteSystem=ssh    # uncomment this line to configure for generic ssh
    

    Since I do not have write privileges in /usr/cadence..., I copied cdsRemote.scr to my home ~/cdssetup/cdsRemsh because the instructions at the top of the file said so:

    The default behaviour of the cdsRemote facility can be modified by
    copying the file to a directory with a higher serach precedence
    (such as $HOME/cdssetup/cdsRemsh/cdsRemote.scr) and then modifying
    the copy.
    

    And so I modified the copy to read:

    remoteSystem=ssh
    

    Checklist

    I have done the following necessary setup:

    1. Add to my ~/.cshrc

      setenv LBS_CLUSTER_MASTER calvin
      
    2. Create a queue-config file with the following contents

      fast 2
      calvin 2
      hobbes 2
      
    3. Kill all cds... processes owned by root

      $ ps -u root | grep cds
      
    4. Run cdsqmgr as root

      $ su
      $ cdsqmgr ~/queue-config
      

    Testing

    Now, when I test using adptest, I get the following output:

    BEGIN Analog Design Environment Distributed Processing Setup Test
    
    Testing for existence of LBS_CLUSTER_MASTER variable...
        PASSED.
    
    Testing opening of Analog Design Environment Job Server...
    Launching Analog Design Environment job server...
    Analog Design Environment job server has initialized!
        PASSED.
    
    Please be patiend - the remaining portion of the test takes some time.
    
    Testing job submission to host `calvin' on queue `fast'...
    Waiting for ipc:-1 to terminate
        PASSED.
    
    Testing job submission to host `hobbes' on queue `fast'...
    connect to address 100.100.100.101 port 544: Connection refused
    Trying krb4 rsh...
    connect to address 100.100.100.101 port 544: Connection refused
    trying normal rsh (/usr/bin/rsh)
    hobbes: Connection refused
    Error (cdsWaitFor): command cdsRemshClient failed with status 1
    Waiting for ipc:0 to initialize
        PASSED.
    
    END Analog Design Environment Distributed Processing Setup Test
    
    t
    

    Checking my mail

    I check my mail on /var/spool/mail and see something like this:

    Debug: ExecCommand:
    /usr/cadence/IC610/share/cdsssetup/cdsRemsh/cdsRemote.scr shell
    hobbes ... <truncated> ...
    

    Question

    Why is the cdsqmgr still using the rsh to login to the executiong host, when I already set it to ssh in .cdsenv?

    Why is the cdsqmgr still using the default cdsRemote.scr, when I already copied a modified file in ~/cdssetup/cdsRemsh?

    • Post Points: 35
  • Tue, Aug 27 2013 9:17 AM

    Re: cdsRemsh ignores "ssh" setting .cdsenv Reply

    Don't know. Nothing obvious jumps out at me. Please contact tp so that somebody can debug this with you.

    Regards,

    Andrew.

    • Post Points: 20
  • Tue, Aug 27 2013 9:21 AM

    Re: cdsRemsh ignores "ssh" setting .cdsenv Reply
    Thank you for the advice. What is TP? How do I contact them?
    • Post Points: 20
  • Tue, Aug 27 2013 9:31 AM

    Re: cdsRemsh ignores "ssh" setting .cdsenv Reply

    Whoops, something got messed up when I posted that. I meant to say contact customer support. I think the focus of my cursor slipped as I was typing in the URL... and it ended up as "tp".

    Sorry!

    Andrew.

     

    • Post Points: 5
  • Mon, Mar 10 2014 7:10 PM

    • vader
    • Not Ranked
    • Joined on Thu, Mar 5 2009
    • San Jose, CA
    • Posts 7
    • Points 300
    Re: cdsRemsh ignores "ssh" setting .cdsenv Reply

    Hi,

     

    Can you try again after changing the permission of ~/cdssetup/cdsRemsh/cdsRemote.scr to include execution permission?

    chmod +x  ~/cdssetup/cdsRemsh/cdsRemote.scr

     

    Best regards,

    Teng-Kiat 

    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by kitmonisit at 21 Aug 2013 08:38 PM. Topic has 4 replies.