Home > Community > Forums > Digital Implementation > The 'UNITS' attribute should be set in the first lef file (technology lef)

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 The 'UNITS' attribute should be set in the first lef file (technology lef) 

Last post Sun, Jul 7 2013 11:54 PM by VKhlyupin. 1 replies.
Started by Digital84 06 Jul 2013 10:22 AM. Topic has 1 replies and 458 views
Page 1 of 1 (2 items)
Sort Posts:
  • Sat, Jul 6 2013 10:22 AM

    • Digital84
    • Not Ranked
    • Joined on Tue, Jul 2 2013
    • Posts 4
    • Points 65
    The 'UNITS' attribute should be set in the first lef file (technology lef) Reply

    Hi everyone,

     

    I'm trying to use Cadence Encounter to place and route my design in 130 nm UMC technology. I've already characterized my self-defined standard cell library using ELC. I'm sourcing the .lef file of my self-designed standard cell library after the actual technology header .lef file. I'm getting the following when running the P&R:

     

    Loading Lef file ...lef

    Loading Lef file ...lef

    **WARN: (ENCLF-246):    The 'UNITS' attribute should be set
    in the first lef file (technology lef). There is an attempt to set it
    in subsequent lef files which will be ignored.


    **ERROR: (ENCLF-111):   Layer ... is not defined

    **ERROR: (ENCLF-224):   Failed to create via ...

    **ERROR: (ENCLF-3):     Error found when processing LEF file ...lef

    **ERROR: (ENCSYT-6692): [par.tcl]: Invalid return code while executing "par.tcl"

     

    It seems to me that the .lef file of my standard cell library tries to specify the layers and vias characteristics of the technology which has already been specified in the actual technology .lef file. Or there might be some other problems with my .lef file? Please help me.

    Regards,

    Mahmoud

     

     

    • Post Points: 20
  • Sun, Jul 7 2013 11:54 PM

    • VKhlyupin
    • Not Ranked
    • Joined on Fri, Jul 5 2013
    • Posts 9
    • Points 120
    Re: The 'UNITS' attribute should be set in the first lef file (technology lef) Reply

     It seems for me that you have several problem at the turn of your LEF files.

    first - There is no lefenition of some layer that used your library LEF, in your trchnology file. Add the defenition of layer reported in  ENCLF-111 message to tech LEF to overcome this problem.

    second - Some via defenition have wrong format or input data. Probably it's connected with previous issue, bu to few information in your post to be sure.

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by Digital84 at 06 Jul 2013 10:22 AM. Topic has 1 replies.