Home > Community > Forums > Custom IC Design > Error in MMSIM when executing on 64bit machine

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Error in MMSIM when executing on 64bit machine 

Last post Thu, Sep 19 2013 2:43 PM by Andrew Beckett. 1 replies.
Started by Arslan 27 Jun 2013 02:26 AM. Topic has 1 replies and 614 views
Page 1 of 1 (2 items)
Sort Posts:
  • Thu, Jun 27 2013 2:26 AM

    • Arslan
    • Top 500 Contributor
    • Joined on Mon, Dec 10 2012
    • Posts 36
    • Points 510
    Error in MMSIM when executing on 64bit machine Reply

    Hi, I am getting following error while executing spectre simulation from a 64 bit machine.

     Can't load '/IC_TOOLS/CADENCE/MMSIM111/tools.lnx86/mdl/etc/perl/cdsPSF.so' for module cdsPSF: libelf.so.1: cannot open shared object file: No such file or directory at /IC_TOOLS/CADENCE/MMSIM111/tools.lnx86/perl/lib/5.8.8/i686-linux/DynaLoader.pm line 230. at /IC_TOOLS/CADENCE/MMSIM111/tools.lnx86/mdl/etc/perl/spectremdl.pl line 236 Compilation failed in require at /IC_TOOLS/CADENCE/MMSIM111/tools.lnx86/mdl/etc/perl/spectremdl.pl line 236. BEGIN failed--compilation aborted at /IC_TOOLS/CADENCE/MMSIM111/tools.lnx86/mdl/etc/perl/spectremdl.pl line 236.

    What should I do?

    • Post Points: 20
  • Thu, Sep 19 2013 2:43 PM

    Re: Error in MMSIM when executing on 64bit machine Reply

    Do you have these files on your machine?

    /usr/lib/libelf.so.1
    /usr/lib64/libelf.so.1

    The first is the 32-bit version, and the second the 64-bit version. Despite being on a 64-bit OS, the default is for spectre to run in 32-bit mode (you can run spectre -64 to change that, or do "setenv CDS_AUTO_64BIT spectre" before running spectre).

    These are provided by the elfutils-libelf rpm:

    UNIX> rpm -q -f /usr/lib/libelf.so.1
    elfutils-libelf-0.152-1.el6.i686
    UNIX> rpm -q -f /usr/lib64/libelf.so.1
    elfutils-libelf-0.152-1.el6.x86_64

    If you run <MMSIMinstDir>/tools/bin/checkSysConf MMSIM12.1
    (or whatever version you're using) - it should be checking for elfutils-libelf., Are you using a supported OS version?

    Kind Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by Arslan at 27 Jun 2013 02:26 AM. Topic has 1 replies.