Home > Community > Forums > Digital Implementation > Spice syntax error in ELC

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Spice syntax error in ELC 

Last post Fri, Jun 7 2013 7:02 AM by Arslan. 0 replies.
Started by Arslan 07 Jun 2013 07:02 AM. Topic has 0 replies and 438 views
Page 1 of 1 (1 items)
Sort Posts:
  • Fri, Jun 7 2013 7:02 AM

    • Arslan
    • Top 500 Contributor
    • Joined on Mon, Dec 10 2012
    • Posts 36
    • Points 510
    Spice syntax error in ELC Reply

    HI all, I am using encounter library characterizer to make .lib, I have designed an inverter as a test case and given its spice netlist to elc alongwith model file of tsmcN28. now when i laucnh elc and load database using db_open command, database is loaded. but when I type the command db_prepare -f , it first loads models, then loads models as subckts, and then loads inverter subckt. and eventually it gives following error:

     

    Expanding SUBCKT:INV_LS_UP_SPICE_TEST
    ... XM0 [PCH_18UD15_MAC]
    ... XM2 [NCH_18UD15_MAC]
    - subckt : ; is not defined
    - subckt : { is not defined
    [ERROR(db_prepare)] Cannot read the input SPICE file subckt : ; is not exist. because it has one or more syntax errors. Correct the SPICE syntax in the file and try again.

     

    I have used this model file in virtuoso to run simulations, and works fine, so there should not be the issue of wrong syntax. what should I do?

    • Post Points: 5
Page 1 of 1 (1 items)
Sort Posts:
Started by Arslan at 07 Jun 2013 07:02 AM. Topic has 0 replies.