Home > Community > Forums > PCB SKILL > autosilkUtils.il

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 autosilkUtils.il 

Last post Mon, Jun 10 2013 7:35 AM by Cadence GDD. 38 replies.
Started by Les Wong 12 Apr 2012 01:57 PM. Topic has 38 replies and 9918 views
Page 3 of 3 (39 items) < Previous 1 2 3
Sort Posts:
  • Wed, Feb 13 2013 2:14 PM

    • eDave
    • Top 10 Contributor
    • Joined on Sun, Jul 13 2008
    • Christchurch, 00-NZ
    • Posts 743
    • Points 16,110
    Re: RE: autosilkUtils.il Reply

    Hi Evan,

    See the attached 16.6 context file for version 12.11.

    Cheers,

    Dave 

    Dave Elder, Tait Communications
    • Post Points: 20
  • Mon, Feb 18 2013 10:21 AM

    Re: RE: autosilkUtils.il Reply
    Terrific! Thank you once again, Dave. Cheers!
    • Post Points: 20
  • Mon, Mar 11 2013 2:11 AM

    • ahkuih
    • Top 500 Contributor
    • Joined on Wed, Jul 23 2008
    • Posts 21
    • Points 505
    Re: RE: autosilkUtils.il Reply

    hi Dave,

         I download your skill code and unzip it into my usual skill folder which is c:\skill and then load it inside allegro PCB editor which is load"c:/skill/autosilktUtils_public.il". Then exit skill intepreter. Type silkutils but always encounter wrong command. May I know what should i do? I also followed the steps you mentioned, also fail.

    • Post Points: 20
  • Mon, Mar 11 2013 2:59 PM

    • eDave
    • Top 10 Contributor
    • Joined on Sun, Jul 13 2008
    • Christchurch, 00-NZ
    • Posts 743
    • Points 16,110
    Re: RE: autosilkUtils.il Reply

    In skill:

    loadContext("c:/skill/AutosilkUtils_public.cxt")

    axlCmdRegister("silkutils" 'ASU_start ?cmdType "interactive")

     

    Dave Elder, Tait Communications
    • Post Points: 20
  • Mon, Mar 11 2013 11:54 PM

    • ahkuih
    • Top 500 Contributor
    • Joined on Wed, Jul 23 2008
    • Posts 21
    • Points 505
    Re: RE: autosilkUtils.il Reply

    Hi Dave,

           now i am using your skill to check is there any silkscreen outside of board file, but keep running on few boards also complaining all placed component silkscreen outside of board outline. I have no idea. I just use default setting. I thought from your help file, it states that it reports red DRC if silkscreen less than 5mil but somehow now, no component silkscreen outside board outline but it happened to report all DRCs.

    • Post Points: 20
  • Tue, Mar 12 2013 2:12 PM

    • eDave
    • Top 10 Contributor
    • Joined on Sun, Jul 13 2008
    • Christchurch, 00-NZ
    • Posts 743
    • Points 16,110
    Re: RE: autosilkUtils.il Reply
    This code expects to find a continuous board outline shape drawn with lines, or a shape. If multiple outlines exist it will choose the largest one. Check that you have a good outline on the BOARD GEOMETRY/OUTLINE layer.
    Dave Elder, Tait Communications
    • Post Points: 20
  • Fri, Jun 7 2013 5:38 AM

    Re: RE: autosilkUtils.il Reply

    I'm trying tu use the silkutils skill but when I try to run the tools I get the following error message:

     Command > silkutils

    E- *Error* eval: unbound variable - ASU_defaultBdEdgeSpacing

    Select a handle or line segment

    Command >  

    • Post Points: 20
  • Sun, Jun 9 2013 6:49 PM

    • eDave
    • Top 10 Contributor
    • Joined on Sun, Jul 13 2008
    • Christchurch, 00-NZ
    • Posts 743
    • Points 16,110
    Re: RE: autosilkUtils.il Reply

    Did you miss a step in the installation process?

    Do you have the latest version? See an earlier post in this thread. 

    Dave Elder, Tait Communications
    • Post Points: 20
  • Mon, Jun 10 2013 7:35 AM

    Re: RE: autosilkUtils.il Reply

    I installed the latest version and it works. 

    Thank for your help!

    • Post Points: 5
Page 3 of 3 (39 items) < Previous 1 2 3
Sort Posts:
Started by Les Wong at 12 Apr 2012 01:57 PM. Topic has 38 replies.