Home > Community > Forums > Digital Implementation > How to optimize level shifter and isolation instances marked dont touch in Encounter

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 How to optimize level shifter and isolation instances marked dont touch in Encounter 

Last post Tue, Sep 24 2013 3:55 PM by fieldy. 2 replies.
Started by fieldy 22 Sep 2013 04:34 PM. Topic has 2 replies and 2537 views
Page 1 of 1 (3 items)
Sort Posts:
  • Sun, Sep 22 2013 4:34 PM

    • fieldy
    • Not Ranked
    • Joined on Thu, Mar 21 2013
    • Posts 6
    • Points 60
    How to optimize level shifter and isolation instances marked dont touch in Encounter Reply

    Hi All,

     

    I am implementing a Low-power design with Power switches and Isolation cells. I have a CPF file that I commit and I can see that isolation cells and level shifters are inserted into the design correctly as I intended.

    However, whenever I run optDesign, whether it be preCTS, postCTS or postRoute, Encounter seem to mark level shifters and isolation instances as don't touch instances and does not optimize them. As a result, the drive strength of the isolation instances are too small. I know that Encounter doesn't optimize clock nets but there is a ckECO option to take care of clock optimization. Is there a way to make Encounter optimize the level shifter and isolation instances and/or remove the dont touch marking on these instances?

     Below are the messages I get in the log file when I run optDesign :

    *info: Marking 12 level shifter instances dont touch

    *info: Marking 64 isolation instances dont touch 

     

    I've tried to use set_dont_touch and set_interactive_constraint_mode options to override this but haven't succeeded so far. Has anybody gotten the same problem and does anybody know how to solve this?

     

    Thanks

    Saekyu 

    • Post Points: 20
  • Mon, Sep 23 2013 7:45 AM

    • fitz
    • Top 150 Contributor
    • Joined on Wed, Aug 4 2010
    • Kanata, Ontario
    • Posts 56
    • Points 745
    Re: How to optimize level shifter and isolation instances marked dont touch in Encounter Reply

    setOptMode  -resizeShifterAndIsoInsts {true | false}
    Controls whether timing optimization resizes shifters and isolation instances. In default mode (false), shifters and isolations are considered "don't-touch" instances and are not changed during timing optimization.
    When this parameter is set to true, the shifters and isolation cells are resized for timing optimization by using optDesign.
    Note: When this parameter is set to true, all the shifters and isolation cells can be resized even if they are marked as dont_touch.
    Default: false

    • Post Points: 20
  • Tue, Sep 24 2013 3:55 PM

    • fieldy
    • Not Ranked
    • Joined on Thu, Mar 21 2013
    • Posts 6
    • Points 60
    Re: How to optimize level shifter and isolation instances marked dont touch in Encounter Reply

    Thanks so much! This was exactly what I was looking for!

    • Post Points: 5
Page 1 of 1 (3 items)
Sort Posts:
Started by fieldy at 22 Sep 2013 04:34 PM. Topic has 2 replies.