Home > Community > Forums > PCB SKILL > axlRefreshSymbol not working on symbol name

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 axlRefreshSymbol not working on symbol name 

Last post Fri, Sep 13 2013 10:09 AM by Randy R. 1 replies.
Started by pcbnagarajcid 12 Sep 2013 10:04 PM. Topic has 1 replies and 2133 views
Page 1 of 1 (2 items)
Sort Posts:
  • Thu, Sep 12 2013 10:04 PM

    • pcbnagarajcid
    • Not Ranked
    • Joined on Fri, Sep 13 2013
    • bangalore, Karnataka
    • Posts 2
    • Points 40
    axlRefreshSymbol not working on symbol name Reply

    Experts,

     Below is my code to refresh symbols when passing the symbol name they return nil.

    mysymbol_list = list( "0402" "0603")

    foreach( sym  mysymbol_list

     axlDBIgnoreFixed(t) ref_status = axlRefreshSymbol(sym )

    when(  !ref_status printf( "%s not refreshed\n" sym))

    axlDBIgnoreFixed(nil)

    )

     

     the help syntax do have the parameter to pass symbol name

    axlRefreshSymbol(t_symName/o_SymDef[g_options] )

     Please advice.

    Thanks,

    Nagaraj

    Filed under:
    • Post Points: 20
  • Fri, Sep 13 2013 10:09 AM

    • Randy R
    • Top 50 Contributor
    • Joined on Wed, Jul 16 2008
    • Dupont, WA
    • Posts 192
    • Points 3,025
    Re: axlRefreshSymbol not working on symbol name Reply

    Try changing your When statement to an Unless statement:

    unless(  ref_status printf( "%s not refreshed\n" sym))

    The returned information is a dbid or nil so using !ref_status won't work.

    Good Day, R².
    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by pcbnagarajcid at 12 Sep 2013 10:04 PM. Topic has 1 replies.