Home > Community > Forums > Custom IC SKILL > Alt bindkey modifer problems in layout session

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Alt bindkey modifer problems in layout session 

Last post Fri, Jul 19 2013 11:05 AM by psill000. 6 replies.
Started by psill000 19 Jul 2013 08:32 AM. Topic has 6 replies and 807 views
Page 1 of 1 (7 items)
Sort Posts:
  • Fri, Jul 19 2013 8:32 AM

    • psill000
    • Top 200 Contributor
    • Joined on Sat, Jun 1 2013
    • Posts 40
    • Points 755
    Alt bindkey modifer problems in layout session Reply

    Alt bindkey modifer problems in layout session:

    I have  the environment variable set to use the Alt key and the hiBindKeyModifiers show I have the key as a modifier.

     envSetVal( "ui" "enableMenuShortcuts" 'boolean nil)

    hiBindKeyModifiers()

    ("Shift" "Ctrl" "Alt" "Meta")

     Is there any other system settings or environment variables to from using the Alt bindkey?

     

    • Post Points: 20
  • Fri, Jul 19 2013 8:43 AM

    Re: Alt bindkey modifer problems in layout session Reply

    If you call  envSetVal( "ui" "enableMenuShortcuts" 'boolean nil) you get a popup as the attached picture shows. What this is telling you is that you need to actually set it via a .cdsenv file not using SKILL.

    Did you try that? Which version are you using? (type getVersion(t) in the CIW).

    Regards,

    Andrew.


    • Post Points: 20
  • Fri, Jul 19 2013 9:37 AM

    • psill000
    • Top 200 Contributor
    • Joined on Sat, Jun 1 2013
    • Posts 40
    • Points 755
    Re: Alt bindkey modifer problems in layout session Reply

     Sorry I forgot to include the version.

    "sub-version  IC6.1.5-64b.500.15 "

    I dont get the pop up as you have pictured.

    I tried setting the variable in my cdsenv and loading the variable in the CIW.

    • Post Points: 20
  • Fri, Jul 19 2013 9:46 AM

    Re: Alt bindkey modifer problems in layout session Reply

    You won't get the popup if you've already set it to nil via a .cdsenv file.

    So what's not working? I just tried doing:

    hiSetBindKey("Layout" "Alt<Key>B" "println(23456)")

    and then I hit Alt-B in the layout, and it printed the number in the CIW. I tried ISR15, and it worked fine.

    Andrew.

    • Post Points: 20
  • Fri, Jul 19 2013 10:29 AM

    • psill000
    • Top 200 Contributor
    • Joined on Sat, Jun 1 2013
    • Posts 40
    • Points 755
    Re: Alt bindkey modifer problems in layout session Reply
    The cadence session does not seem to recognize the bindkey.

    In other cadence environments I have used I did not have a problem, but something in the cadence session or system environment is preventing the Virtuoso from seeing the bindkey assignment.

    I tried dropping your bindkey example in the CIW, execute the bindkey and no print out, “2345”.

    I will have to see it is the wireless keyboard I am using not mapped correctly.
    • Post Points: 20
  • Fri, Jul 19 2013 10:38 AM

    Re: Alt bindkey modifer problems in layout session Reply

    What happens if you go into the BindKey UI (in Options->Bindkeys) and then try to add a bindkey? If you double click in the bindkey field on the right hand pane, you can hit the key combination (e.g. Alt-B) and see whether it enters the bindkey sequence or not.

    Did the accelerator keys work before you turned them off? Maybe your window manager is swallowing the Alt key bindings?

    Andrew.

    • Post Points: 20
  • Fri, Jul 19 2013 11:05 AM

    • psill000
    • Top 200 Contributor
    • Joined on Sat, Jun 1 2013
    • Posts 40
    • Points 755
    Re: Alt bindkey modifer problems in layout session Reply

    The keyboard capture does recognized the Alt accelerator but not the Meta.

    The Virtuoso still does not execute any of the bindkey definitions with the Alt.

    I will try another keyboard.

    • Post Points: 5
Page 1 of 1 (7 items)
Sort Posts:
Started by psill000 at 19 Jul 2013 08:32 AM. Topic has 6 replies.