Home > Community > Forums > Custom IC Design > ERROR (VACOMP-1008): Cannot compile ahdlcmi module library when I practice the AMSKIT615 package.

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 ERROR (VACOMP-1008): Cannot compile ahdlcmi module library when I practice the AMSKIT615 package. 

Last post Wed, May 29 2013 9:36 AM by Andrew Beckett. 5 replies.
Started by Alex Liao 22 May 2013 04:56 PM. Topic has 5 replies and 1530 views
Page 1 of 1 (6 items)
Sort Posts:
  • Wed, May 22 2013 4:56 PM

    • Alex Liao
    • Top 150 Contributor
    • Joined on Wed, May 22 2013
    • Posts 47
    • Points 775
    ERROR (VACOMP-1008): Cannot compile ahdlcmi module library when I practice the AMSKIT615 package. Reply

    I got this error when I was practicing Cadence AMS Methodology kit (05B_AnalogBlockDesignOptimization) using IC6.1.5. My OS is Unix 32-bit.

    "ERROR (ADEXL-5011): While simulating run LocalOpt.1, point 48, test freq_low, received error:

    Simulation Error:

    ------------------------------

    Simulator failed to complete the simulation.

     Error found by spectre during AHDL read-in.

    Error found by spectre during AHDL read-in.

    ERROR (VACOMP-1008): Cannot compile ahdlcmi module library. Check the log file input.ahdlSimDB/5084_dfII_zambezi_pll_vco_thermdecode_veriloga_veriloga

    .va.pll_vco_thermdecode.ahdlcmi/Linux/../ahdlcmi.out for details. If the compiler ran out of memory, use 'setenv CDS_CMI_COMPLEVEL 0', and try again. 

    If the reason for the failure was a syntax error, contact your Cadence Customer Support representative with the netlist, log files, behavioral model f

    iles, and any other information that can help identify the problem.

    ERROR (SFE-91): Error when elaborating the instance pll_vco_thermdecode. Simulation should be terminated.

    Error found by spectre during AHDL read-in.

    Error found by spectre during AHDL read-in.

    ERROR (VACOMP-2235): Internal Compiling Error: The built-in termcurs parameter is redefined in module 'pll_vco_thermdecode'.

    ERROR (VACOMP-1816): Exiting AHDL compilation.

    ERROR (SFE-91): Error when elaborating the instance pll_vco_thermdecode. Simulation should be terminated.

    Error found by spectre during AHDL read-in.

    Error found by spectre during AHDL read-in.

    ERROR (VACOMP-1008): Cannot compile ahdlcmi module library. Check the log file input.ahdlSimDB/5084_dfII_zambezi_sim_pll_vco_stim_veriloga_veriloga.va

    .pll_vco_stim.ahdlcmi/Linux/../ahdlcmi.out for details. If the compiler ran out of memory, use 'setenv CDS_CMI_COMPLEVEL 0', and try again. If the rea

    son for the failure was a syntax error, contact your Cadence Customer Support representative with the netlist, log files, behavioral model files, and 

    any other information that can help identify the problem.

    ERROR (SFE-91): Error when elaborating the instance pll_vco_stim. Simulation should be terminated.

     For details open log: /users/labnet2/fs5/tl4528/my_AMS/AMSKIT_tl4528/modules/05_AMSConstraintDrivenBlockCreate/05B_AnalogBlockDesignOptimization/DB/simulation/AMSBC/pll_vco_sim/adexl_opt/results/data/LocalOpt.1/48/freq_low/psf/spectre.out

     ------------------------------

    For more details, consult the job log file:

    /users/labnet2/fs5/tl4528/my_AMS/AMSKIT_tl4528/modules/05_AMSConstraintDrivenBlockCreate/05B_AnalogBlockDesignOptimization/DB/logs_tl4528/Job0.log" 

    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

    This is just a section of error message. Other message are all similar like this section. 

    Also this message in CIW happened when I tried to run any simulation or optimaizaiton followed by AMSKit 05B tutorial. 

    If someone could help me, I would appreiciate that.

    Thanks. 

     

     

     

    • Post Points: 20
  • Wed, May 29 2013 3:18 AM

    Re: ERROR (VACOMP-1008): Cannot compile ahdlcmi module library when I practice the AMSKIT615 package. Reply

    Which version of spectre are you using (spectre -W at the UNIX command line will tell you this)? I don't see the issue when compiling that VerilogA module in MMSIM11.1 or MMSIM12.1. Presumably if you're running on a 32-bit OS, you must be using an older MMSIM version (or maybe that's your problem?)

    Regards,

    Andrew.

    • Post Points: 20
  • Wed, May 29 2013 7:22 AM

    • Alex Liao
    • Top 150 Contributor
    • Joined on Wed, May 22 2013
    • Posts 47
    • Points 775
    Re: ERROR (VACOMP-1008): Cannot compile ahdlcmi module library when I practice the AMSKIT615 package. Reply

    Hi Andrew,

    The current sub-version is 11.1.0.366.isr7. Actually what I am using is a 32-bit OS. So  I have to install an older Multi-Mode Simulation ECAD suite to figure this out?

    Thanks,

    Alex 

    • Post Points: 20
  • Wed, May 29 2013 7:40 AM

    Re: ERROR (VACOMP-1008): Cannot compile ahdlcmi module library when I practice the AMSKIT615 package. Reply

    Alex,

    Are you sure you're running on a 32-bit OS? What do you get if you run "uname -a" or "spectre -64 -debug3264 -W"

    For all releases that require RHEL5, we only support 64 bit OS - so you really should install a 64 bit OS (unless of course you are using 32 bit hardware, which must mean that the machine is really old).

    If you try to run MMSIM11.1 on a 32 bit OS, it will not be able to compile any VerilogA models at all, because the installation does not include the 32-bit version of gcc, needed for the compilation.

    Regards,

    Andrew.

    • Post Points: 20
  • Wed, May 29 2013 9:24 AM

    • Alex Liao
    • Top 150 Contributor
    • Joined on Wed, May 22 2013
    • Posts 47
    • Points 775
    Re: ERROR (VACOMP-1008): Cannot compile ahdlcmi module library when I practice the AMSKIT615 package. Reply

    Hi Andrew,

    This is the result by typing the two command you gave me. 

     

    $ uname -a

    Linux cadlamss 2.6.18-348.4.1.el5PAE #1 SMP Fri Mar 22 05:46:19 EDT 2013 i686 i686 i386 GNU/Linux

    $ spectre -64 -debug3264 -W

    -------- 32/64 bit wrapper diagnostics -------------

    App name: spectre

    App path: /CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/spectre/bin

    OS is 32-bit capable.

    The user has selected 64-bit operation via the command line switch.

    A 64-bit version of the application exists.

    A 32-bit version of the application exists.

    Original share library path:

    LD_LIBRARY_PATH : /CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/mdl/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/mmsim/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/inca/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/spectre/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/dfII/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/lib/64bit/SuSE:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/lib/SuSE::/CMC/tools/cadence/MMSIM_07.20.109_lnx86/tools/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools/lib

    DBType UNKNOWN

    doOA: 0 doTools: 1 doQT: 0

    rm64SharedLibPath sets LD_LIBRARY_PATH=/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/mdl/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/mmsim/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/inca/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/spectre/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/lib/64bit/SuSE:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/lib/SuSE:.:/CMC/tools/cadence/MMSIM_07.20.109_lnx86/tools/lib

    ----------------------------------------------------

    PATH            : /CMC/tools/cadence/ASSURA04.12.014-615_lnx86/tools/bin:/CMC/tools/cadence/ASSURA04.12.014-615_lnx86/tools/assura/bin:/CMC/kits/local/bin:/CMC/tools/cadence/IC06.15.509_lnx86/tools/dfII/local/bin:/CMC/tools/cadence/IC06.15.509_lnx86/tools/dfII/bin:/CMC/tools/cadence/IC06.15.509_lnx86/tools/bin:/CMC/tools/cadence/EDI10.13.003_lnx86/tools/bin:/CMC/tools/cadence/PVE11.10.531_lnx86/bin:/CMC/tools/cadence/PVE11.10.531_lnx86/tools/bin:/CMC/tools/cadence/ETS10.13.003_lnx86/tools/bin:/CMC/tools/cadence/CONFRML10.10.540_lnx86/bin:/CMC/tools/cadence/CONFRML10.10.540_lnx86/tools/cfm/bin:/CMC/tools/cadence/INCISIV10.20.040_lnx86/tools/bin:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools/dfII/bin:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools/bin:/CMC/tools/cadence/IUS08.20.024_lnx86/tools/bin:/CMC/tools/cadence/IUS08.20.024_lnx86/tools/verilog/bin:/CMC/tools/cadence/IUS08.20.024_lnx86/tools/simvisdai/bin:/CMC/tools/cadence/ICC11241USR5_lnx86/tools/iccraft/bin:/CMC/tools/cadence/ICC11241USR5_lnx86/tools/bin:/CMC/tools/mentor/ixl_cal_2010.4_26.16/bin:/CMC/tools/cadence/MMSIM_07.20.109_lnx86/tools/dfII/bin:/CMC/tools/cadence/MMSIM_07.20.109_lnx86/tools/bin:/CMC/tools/cadence/ASSURA04.12.014-615_lnx86/tools/bin:/CMC/tools/cadence/ASSURA04.12.014-615_lnx86/tools/assura/bin:/CMC/kits/local/bin:/CMC/tools/cadence/IC06.15.509_lnx86/tools/dfII/local/bin:/CMC/tools/cadence/IC06.15.509_lnx86/tools/dfII/bin:/CMC/tools/cadence/IC06.15.509_lnx86/tools/bin:/CMC/tools/cadence/EDI10.13.003_lnx86/tools/bin:/CMC/tools/cadence/PVE11.10.531_lnx86/bin:/CMC/tools/cadence/PVE11.10.531_lnx86/tools/bin:/CMC/tools/cadence/ETS10.13.003_lnx86/tools/bin:/CMC/tools/cadence/CONFRML10.10.540_lnx86/bin:/CMC/tools/cadence/CONFRML10.10.540_lnx86/tools/cfm/bin:/CMC/tools/cadence/INCISIV10.20.040_lnx86/tools/bin:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools/dfII/bin:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools/bin:/CMC/tools/synopsys/syn_vD-2010.03-SP4/bin:/CMC/tools/synopsys/syn_vD-2010.03-SP4/linux/syn/bin:/CMC/tools/synopsys/syn_vD-2010.03-SP4:/CMC/tools/cadence/IUS08.20.024_lnx86/tools/bin:/CMC/tools/cadence/IUS08.20.024_lnx86/tools/verilog/bin:/CMC/tools/cadence/IUS08.20.024_lnx86/tools/simvisdai/bin:/CMC/tools/cadence/ICC11241USR5_lnx86/tools/iccraft/bin:/CMC/tools/cadence/ICC11241USR5_lnx86/tools/bin:/CMC/tools/mentor/ixl_cal_2010.4_26.16/bin:/CMC/tools/cadence/MMSIM_07.20.109_lnx86/tools/dfII/bin:/CMC/tools/cadence/MMSIM_07.20.109_lnx86/tools/bin:/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/local/bin:/bin:/usr/bin:/usr/bin:/local/bin:./:/usr/bin:/local/bin:./

    LD_LIBRARY_PATH : /CMC/tools/cadence/MMSIM11.10.366_lnx86/tools/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/mdl/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/mmsim/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/inca/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/spectre/lib:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/lib/64bit/SuSE:/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/lib/SuSE:.:/CMC/tools/cadence/MMSIM_07.20.109_lnx86/tools/lib

    CDS_AUTO_64BIT  : NULL

    Launching "/CMC/tools/cadence/MMSIM11.10.366_lnx86/tools.lnx86/spectre/bin/32bit/spectre -W"

    ----------------------------------------

    sub-version  11.1.0.366.isr7 

    I think I am using the 32-bit OS on the server side of my department. But we have 64-bit OS server side as well. So I can tell you sugget me try the same simulation on 64-bit OS. I should have no problem, right?
     
    Thanks,
    Alex 
    • Post Points: 20
  • Wed, May 29 2013 9:36 AM

    Re: ERROR (VACOMP-1008): Cannot compile ahdlcmi module library when I practice the AMSKIT615 package. Reply

    Hi Alex,

    Probably - I can't test it myself as I don't have any 32 bit machines (at least not running RHEL5 which is the minimum requirement for MMSIM11.1). In fact 64-bit RHEL5 is the minimum requirement, so I'm surprised it runs at all.

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (6 items)
Sort Posts:
Started by Alex Liao at 22 May 2013 04:56 PM. Topic has 5 replies.