Home > Community > Forums > PCB Design > Artwork Log Message(Photoplot outline rectangle not found)

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Artwork Log Message(Photoplot outline rectangle not found) 

Last post Thu, May 23 2013 11:51 AM by raul5565. 8 replies.
Started by raul5565 21 May 2013 06:13 AM. Topic has 8 replies and 1950 views
Page 1 of 1 (9 items)
Sort Posts:
  • Tue, May 21 2013 6:13 AM

    • raul5565
    • Top 500 Contributor
    • Joined on Fri, Mar 22 2013
    • Posts 17
    • Points 250
    Artwork Log Message(Photoplot outline rectangle not found) Reply

    Hello,

    I am getting the following message in my ViewLog file when I generate the Artwork files

    "Photoplot outline rectangle not found ... using drawing extents" 

    not able to understand what exactly it means.

    In my board design there is no keepout area, all components extends till the edge of a board.

    If any one has an idea about this please reply. 

     

     

    • Post Points: 20
  • Tue, May 21 2013 8:26 AM

    • oldmouldy
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Woking, Surrey
    • Posts 1,371
    • Points 23,350
    Re: Artwork Log Message(Photoplot outline rectangle not found) Reply
    It's a warning message that can be safely ignored. You can get more hassle if you do have a Photoplot Outline since that will mark the limits of Gerber generation from the design. As the message states, the Drawing Extents are being used so you have no chance of excluding any Photoplot data.
    • Post Points: 20
  • Thu, May 23 2013 12:10 AM

    • raul5565
    • Top 500 Contributor
    • Joined on Fri, Mar 22 2013
    • Posts 17
    • Points 250
    Re: Artwork Log Message(Photoplot outline rectangle not found) Reply
    Hello, thnks for this information, in one of the manual i read how to insert that Photoplot outline and i did it in the same way. but my photoplot ouline is bigger than the board outline(which i mistakenly created), which gives the Warning Message when i am creating the Artworks. i would like to change the Photoplot outline coordinates, i am not able to delete the created photoplot, or not even able to edit it, only i can move it, which is not helpful. is there any way to do it????
    • Post Points: 20
  • Thu, May 23 2013 2:19 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,163
    • Points 18,900
    Re: Artwork Log Message(Photoplot outline rectangle not found) Reply

    The photoplot outline is a shape so try Shape - Select Shape or Void then LMB the photoplot outline it will highlight, you can then LMB+Drag the corner points or vertexes to the required size but as oldmouldy says it's not necessary....

    • Post Points: 20
  • Thu, May 23 2013 2:46 AM

    • raul5565
    • Top 500 Contributor
    • Joined on Fri, Mar 22 2013
    • Posts 17
    • Points 250
    Re: Artwork Log Message(Photoplot outline rectangle not found) Reply
    yes, now i have did changed the photoplot window to my board dimensions, but still have following warning.. "Photoplot window (9400000 x 6400000) exceeds film size (2400000 x 1600000) stated in parameter file. " (9400000 x 6400000)....is my board dimension, and there is nothing with (2400000 x 1600000) dimensions. i am not sure from where its reading film size??, where is this parameter file?
    • Post Points: 20
  • Thu, May 23 2013 2:52 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,163
    • Points 18,900
    Re: Artwork Log Message(Photoplot outline rectangle not found) Reply

    Manufacture - Artwork - General Parameters tab - File size limits.

    If you have put the photoplot outline the same size as the board you will clip anything the same size or larger than the photoplot outline.

    • Post Points: 20
  • Thu, May 23 2013 3:12 AM

    • raul5565
    • Top 500 Contributor
    • Joined on Fri, Mar 22 2013
    • Posts 17
    • Points 250
    Re: Artwork Log Message(Photoplot outline rectangle not found) Reply
    thank you very much, that is fine now. i do not have anything which exceeds the board limits so it fine. i have one more question if you can answer, during creation of artwork there is something called "Undefined line width", do i need to put it for all layer? e.g if i don't enter it for my silkscreen i don't get any text when i see it in gerber viewer. and also even if i put "Undefined line width" value for my silkscreen, for some of the components it shows warning "WARNING: text composed 0 width line found at (-44.4000 6.8000) ... using undefined line width of 0.1000" is this warning can be ignored???
    • Post Points: 20
  • Thu, May 23 2013 3:22 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,163
    • Points 18,900
    Re: Artwork Log Message(Photoplot outline rectangle not found) Reply

    Not necessarily but it depends..... If you have lines or text that are zero width when you create gerber data they will not be created because zero width lines are not outputted. The ideal scenerio is that you define a line width for lines and a photo widht for text but the underfined line width is a safe guard that will change anything that is of a zero line width to the value you specify in this parameter setting. This setting is on a film by film basis so you can set different values for different films if you wish. The key really is do you need the item visible in the gerber ? yes then add either an actual thickness or an undefined line width. This warning just tells you it's found a zero width line and will use the undefined line width setting. It can be noted but ignored.

    • Post Points: 20
  • Thu, May 23 2013 11:51 AM

    • raul5565
    • Top 500 Contributor
    • Joined on Fri, Mar 22 2013
    • Posts 17
    • Points 250
    Re: Artwork Log Message(Photoplot outline rectangle not found) Reply
    thank you, its all looking good now....
    • Post Points: 5
Page 1 of 1 (9 items)
Sort Posts:
Started by raul5565 at 21 May 2013 06:13 AM. Topic has 8 replies.