Home > Community > Forums > Custom IC SKILL > cdsvias problems

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 cdsvias problems 

Last post Thu, Apr 25 2013 9:17 AM by Andrew Beckett. 8 replies.
Started by fuelectronics 24 Apr 2013 08:17 AM. Topic has 8 replies and 1012 views
Page 1 of 1 (9 items)
Sort Posts:
  • Wed, Apr 24 2013 8:17 AM

    cdsvias problems Reply

     Dear all,

    I try to creat the vias in my own PDK,  so i goes to technology file manger to creat cdsvias. 

    After that i return back to  Virtuoso layout editting, to press "O", it shows   NO CONTACTS/VIAS defined in constraint group.

    I check the "Help", I should go to window>>contraint group manger for my vias defination, but i did not find this option in there. 

    Do you have any idea to sovle this problem, let me get the required VIAS in the contraint group.  

     

     

    Filed under: ,
    • Post Points: 35
  • Wed, Apr 24 2013 8:55 AM

    • berndfi
    • Top 100 Contributor
    • Joined on Tue, Sep 11 2012
    • Neubiberg, Bavaria
    • Posts 66
    • Points 1,250
    Re: cdsvias problems Reply

     Maybe a stupid question, but have you loaded the modified techfile back into the techlibray?

    • Post Points: 20
  • Wed, Apr 24 2013 9:00 AM

    Re: cdsvias problems Reply

     I load it, it does not work. They are not defined in my cotraint group.

     

    • Post Points: 5
  • Wed, Apr 24 2013 9:01 AM

    • skillUser
    • Top 10 Contributor
    • Joined on Fri, Sep 19 2008
    • Austin, TX
    • Posts 2,567
    • Points 15,575
    Re: cdsvias problems Reply

    Have you put these vias in the validVias section of the interconnect section of the constraint group (virtuosoDefaultSetup I think, though you may need to add them to other CG's also).

    Regards,

    Lawrence.

    • Post Points: 20
  • Wed, Apr 24 2013 9:15 AM

    Re: cdsvias problems Reply

     no, thanks. 

    Do you know how to do it ?

    • Post Points: 5
  • Thu, Apr 25 2013 5:14 AM

    Re: cdsvias problems Reply

     Thanks for your reply, i try to give the inputs as you mentioned above. 

    It does not help, the same problem still exsits. Another solution will be welcomed.

     Thanks 

    • Post Points: 20
  • Thu, Apr 25 2013 5:20 AM

    Re: cdsvias problems Reply

    I think the chances of being able to help you are small without seeing what you've actually done.

    Maybe customer support would be your best bet?

    Regards,

    Andrew.

    • Post Points: 20
  • Thu, Apr 25 2013 9:10 AM

    Re: cdsvias problems Reply

    Sorry to ask so detailed questions, it is really helpful to know how to build a PDK for a beginner.  

    I have solved the last problem by accepting the suggestion. I can see the vias option when i press "o" in the editor. But I try to put the vias into the layout editor, they are not visable (or empty).

    I check the other technology PDK, it always has a "via" view in the library. For example, named M1_M2 with "via" view.

    I donot have such cells in my library, I try to produce them by creating CDSvia in the technology file manger, but they are in the view of "layout" 

    Did I miss some tech layer rules in there ? 

    • Post Points: 20
  • Thu, Apr 25 2013 9:17 AM

    Re: cdsvias problems Reply

    The problem is that you're not providing enough detail, so it's very hard to know what's wrong.

    That's why I suggested customer support, as that way Cadence support can take a look at your data.

    Kindest Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (9 items)
Sort Posts:
Started by fuelectronics at 24 Apr 2013 08:17 AM. Topic has 8 replies.