Home > Community > Forums > Custom IC Design > Use expression from one test as design variable in another test

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Use expression from one test as design variable in another test 

Last post Mon, Mar 11 2013 3:35 AM by Andrew Beckett. 2 replies.
Started by franzi 08 Mar 2013 07:09 AM. Topic has 2 replies and 732 views
Page 1 of 1 (3 items)
Sort Posts:
  • Fri, Mar 8 2013 7:09 AM

    • franzi
    • Not Ranked
    • Joined on Fri, Mar 8 2013
    • Posts 2
    • Points 25
    Use expression from one test as design variable in another test Reply

    Hi,

    I've been working on this issue for quite a while now and can't make it work:

    I have testA that generates a calibration value which i use in testB as an input design variable. I dragged and dropped the expression from the outputs setup window to the desired design variable in the data view, so calcVal is used. I've tried everything that is in the "Known Problems" sheet and could even remotly be related to this issue (using another variable that contains the expression as value for the actual calibration variable, using VAR("..."), recreating the corner etc). I always get the message: ERROR (SFE-1996): "input.scs" 8: parameter `calib0': Unknown parameter name `nil' found in expression. The tests work fine if I replace the expression in the design variable by an arbitrary value.

    What else can I do? Any ideas?

    I'm using GXL and IC6.1.5.

    Thanks

    Franzi

    • Post Points: 5
  • Mon, Mar 11 2013 1:07 AM

    • franzi
    • Not Ranked
    • Joined on Fri, Mar 8 2013
    • Posts 2
    • Points 25
    Re: Use expression from one test as design variable in another test Reply
    I found the problem. I had to set "Spec" of the outputs that I want to reuse to "info". I had it empty before.
    • Post Points: 20
  • Mon, Mar 11 2013 3:35 AM

    Re: Use expression from one test as design variable in another test Reply

     I've never had to set it to "info" to use this, so that sounds rather strange to me. I suggest you contact customer support; maybe there's a bug in the particular scenario you're using this in?

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (3 items)
Sort Posts:
Started by franzi at 08 Mar 2013 07:09 AM. Topic has 2 replies.