Home > Community > Forums > Digital Implementation > Prevent OptDesign in between paths

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Prevent OptDesign in between paths 

Last post Thu, Apr 11 2013 12:02 PM by skmhs PD. 6 replies.
Started by dinac123 04 Mar 2013 09:15 AM. Topic has 6 replies and 854 views
Page 1 of 1 (7 items)
Sort Posts:
  • Mon, Mar 4 2013 9:15 AM

    • dinac123
    • Not Ranked
    • Joined on Mon, Mar 4 2013
    • Posts 8
    • Points 130
    Prevent OptDesign in between paths Reply

    I am trying to prevent Optimization between a path. 

    set_dont_touch, works only for the complete net, but not between a begin pin to a End Pin.

    Is there any other option to achieve this type ofcontraints?

    Thank You 

    Filed under:
    • Post Points: 35
  • Mon, Mar 4 2013 9:23 PM

    • ajay01
    • Top 500 Contributor
    • Joined on Tue, Feb 12 2013
    • ahemdabad, Gujarat
    • Posts 32
    • Points 415
    Re: Prevent OptDesign in between paths Reply

     Hi dinac123,

    use below command:

    set_false_path -from beginpin -to endpin

     

    • Post Points: 20
  • Tue, Mar 5 2013 3:53 AM

    • dinac123
    • Not Ranked
    • Joined on Mon, Mar 4 2013
    • Posts 8
    • Points 130
    Re: Prevent OptDesign in between paths Reply

    That will not work. set_false_path is only to ignore paths for the timing engine and would still add optimization buffer in the path.

    I think there is no option availabe to do this. For now only trick, I found is to add Fence. [ running with setOptMode -honorFence true , prevent

    addtion of buffer under this region, and hence force encounter to buffer after/outer ] 

    • Post Points: 20
  • Tue, Mar 5 2013 3:58 AM

    • ajay01
    • Top 500 Contributor
    • Joined on Tue, Feb 12 2013
    • ahemdabad, Gujarat
    • Posts 32
    • Points 415
    Re: Prevent OptDesign in between paths Reply
    fence will work for a module or group not for path..........
    • Post Points: 5
  • Wed, Apr 10 2013 4:26 PM

    • skmhs PD
    • Not Ranked
    • Joined on Mon, Aug 20 2012
    • Posts 3
    • Points 30
    Re: Prevent OptDesign in between paths Reply
    you'd need to develop a Tcl script to obtain all net names along the path then set_dont_touch.
    • Post Points: 20
  • Thu, Apr 11 2013 6:13 AM

    • dinac123
    • Not Ranked
    • Joined on Mon, Mar 4 2013
    • Posts 8
    • Points 130
    Re: Prevent OptDesign in between paths Reply

    yes, set_dont_touch would work for the nets.

    In my case, for example U1/a is connect with N1 to U2/a, U3/a,U4/a.

    I want no optimization buffers only for the path U1/a to U3/a  

    • Post Points: 20
  • Thu, Apr 11 2013 12:02 PM

    • skmhs PD
    • Not Ranked
    • Joined on Mon, Aug 20 2012
    • Posts 3
    • Points 30
    Re: Prevent OptDesign in between paths Reply
    That doesn't quite make sense. Are you talking about setup or hold opt? And what's the reason behind this requirement?
    • Post Points: 5
Page 1 of 1 (7 items)
Sort Posts:
Started by dinac123 at 04 Mar 2013 09:15 AM. Topic has 6 replies.