Home > Community > Forums > Custom IC Design > Question of Monte Carlo simulation of Virtuoso 6.1.5

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Question of Monte Carlo simulation of Virtuoso 6.1.5 

Last post Wed, Apr 10 2013 4:12 PM by Andrew Beckett. 16 replies.
Started by bhl3302 24 Feb 2013 11:15 PM. Topic has 16 replies and 2970 views
Page 1 of 2 (17 items) 1 2 Next >
Sort Posts:
  • Sun, Feb 24 2013 11:15 PM

    • bhl3302
    • Not Ranked
    • Joined on Mon, Feb 25 2013
    • Posts 13
    • Points 215
    Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    Hi All, I am trying to use monte carlo simulation for a bandgap voltage reference. When I followed the procedure in this forrum and other tutorial, and click "run" for "monte carlo sampling", it looks like nothing was executed. I post my setup and hope anybody can advise about it.

    1. I have a cellview named "monte_carlo". In ADE L, the simulation output is "\net55" and it runs well over temperature -50C to 125C (DC simulation in sweeping the temperature). I selected and set "tt" to allmodels.scs, and select "design.scs". After running sussceesully, I saved this state as "temp".

    2. I open ADE XL->"create new view"->"open in 'new window'"

    3. Create test and load the state "temp".

    Now the setup looks like this [Since I cannot insert an imagine from my computer here, I created a same thread in another place. The setup file picture is shown in http://www.edaboard.com/thread281229.html#post1203445. Please kindly go to this post to see the picture, sorry for the inconvenience]

     

    When I click "run", it never showed any progress. For example, I set number of points to 100, then it always show 0/100. 

     

    1.Could anybody advise how can I make simulation run? My target is to achieve some statistic distribution of output reference voltage.

    2.Do I need to load more scs file here? like process.scs?

     

    Thank you very much! 

    • Post Points: 20
  • Mon, Feb 25 2013 1:44 AM

    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    I can't see the picture as it requires me to login on edaboard.com - and I don't particularly want to register as I have enough fora to monitor already! You can upload pictures here - go to the Options tab when replying and then you can add a picture as an attachment.

    When the simulation starts, you should get a little "terminal" icon in the  Run Summary assistant - hit the right mouse button over this terminal and take a look in the Job log file and see if that gives any clues.

    Otherwise you would probably be best logging this as a new case via Cadence Online Support.

    Kind Regards,

    Andrew.

     

    • Post Points: 35
  • Mon, Feb 25 2013 7:31 AM

    • bhl3302
    • Not Ranked
    • Joined on Mon, Feb 25 2013
    • Posts 13
    • Points 215
    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply
    Hi Andrew, thank you very much for your advise! I attached the picture here, could you advise about it?
    • Post Points: 5
  • Mon, Feb 25 2013 7:45 AM

    • bhl3302
    • Not Ranked
    • Joined on Mon, Feb 25 2013
    • Posts 13
    • Points 215
    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply
    Hi Andrew, I also tried your suggestion " little "terminal" icon in the  Run Summary assistant - hit the right mouse button over this terminal and take a look in the Job log file and see if that gives any clues". However, this Run Summary assistant terminal did not show anything when I did the right click. It seems like it is not activated at all.
    • Post Points: 20
  • Mon, Feb 25 2013 9:45 AM

    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    Nothing jumps out at me. There's some debug flags you could set, but the best thing is to report this to customer support so that we can help you debug it (the debug flags are private so I don't want to reveal them in a public forum).

    I can't really see why it would work for normal "single run sweeps and corners" and not "monte carlo" if the Job Options are the same.

    Regards,

    Andrew.

    • Post Points: 20
  • Mon, Feb 25 2013 6:09 PM

    • bhl3302
    • Not Ranked
    • Joined on Mon, Feb 25 2013
    • Posts 13
    • Points 215
    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    Hi Andrew, actuallay singe run is also not working, not just monte carlo.I am trying to get host ID now. At the mean time,I used "ADE XL help" to find this information

    -------

    Virtuoso Analog Design Environment XL Known Problems and Solutions

     

    CCR 674267: Running a parameter sweep with Monte Carlo is not supported

    Description: If any global variable or parameter is being swept, users cannot run Monte Carlo analysis. The variable/parameter has to be disabled.

    Solution: Use the Corners UI to setup the conditions under which the results of Monte Carlo need to be evaluated. 

    -----------

    1. Do you think this is the root cause of my issue? Since I want to sweep temperature and run monte carlo to see the variation of output voltage? 

    2. If that is the case, could you advise how I can make corner UI run this test?

    Thank you very much! 

    • Post Points: 20
  • Mon, Feb 25 2013 9:20 PM

    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    I doubt that's it, because it tells you before the run even starts if you've got a parameter or variable sweep with monte carlo. Also, it wouldn't explain why single run doesn't work because a parameter/variable sweep there is valid.

    You can add a sweep in a corner - bring up the corners UI and add the variable you want to sweep, and set the value to start:step:stop (you can sweep in more complex ways). To be honest, the easiest is just to  bring up the Corners UI (in the Corners section of the Data assistant, click on the pale grey line "Click to add corner" and then hit the Help button on the Corners Setup form.

    Regards,

    Andrew.

    • Post Points: 20
  • Sun, Apr 7 2013 8:17 PM

    • bhl3302
    • Not Ranked
    • Joined on Mon, Feb 25 2013
    • Posts 13
    • Points 215
    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    Hi Andrew, the previous issue for monte carlo is caused by the IC6.1.5 itself. Now we have fixed it and make it run. However, I still got the problem in making the historgram.As you can see from the following pictures, I set my simulation, and define my output as net055. But after my monte carlo simulation, there is no option for me to choose. The only thing I got is "Y axis". Could you teach me how can I probe the distribution of my output data?

     


    • Post Points: 20
  • Sun, Apr 7 2013 10:37 PM

    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    You can't plot a histogram of a signal. You can only plot histograms of things that result in a scalar (i.e. single valued) result from each individual simulation run (i.e. each point in the monte carlo). If you think about this, this makes sense - how would it plot a histogram from a collection of waveforms?

    So you need to have an expression as the output, maybe measuring the value of net55 at a particular time, or doing some calculation that will give you a scalar value.

    Regards,

    Andrew.

    • Post Points: 20
  • Sun, Apr 7 2013 10:45 PM

    • bhl3302
    • Not Ranked
    • Joined on Mon, Feb 25 2013
    • Posts 13
    • Points 215
    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    Hi Andrew, thank you for your advise. This net055 is the output of a bandgap voltage reference, so generally it is almost a DC. If I want to see what is the variation of it, like you said, I want to see in a specific temperature, the transient output at 1s, how can I set up for monte carlo simulation? Could you advise?

    • Post Points: 20
  • Sun, Apr 7 2013 11:10 PM

    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    Use this expression as an output (assuming you're running a 1 second transient simulation or longer):

    value(VT("/net055" 1))

    Not sure how you're varying temperature (presumably via corners). If so, then you'll get a histogram of this measurement at each temperature corner.

    Regards,

    Andrew.

    • Post Points: 20
  • Sun, Apr 7 2013 11:50 PM

    • bhl3302
    • Not Ranked
    • Joined on Mon, Feb 25 2013
    • Posts 13
    • Points 215
    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    Hi Andrew, I followed your advise but still got some proble. Here,in 27 Deg C, I want to run value(VT("/net055" 1)). And I set transient simulation time from 0s to 10s.

    When I finished running, it shows “finished with errors”. However, in CDS.LOG, it only shows 7 warnings. But I did get nothing here. Is there anyting wrong?


    • Post Points: 20
  • Mon, Apr 8 2013 12:00 AM

    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    First run with single run sweeps and corners and make sure your expression works.

    You may need also to do a Right Mouse button click over the little terminal icon in the Run assistant to look at the log file to see if there are any errors. Which subversion are you using? (Help->About in the CIW).

    Regards,

    Andrew,

    • Post Points: 20
  • Mon, Apr 8 2013 12:11 AM

    • bhl3302
    • Not Ranked
    • Joined on Mon, Feb 25 2013
    • Posts 13
    • Points 215
    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply
    Hi Andrew, I did the single run and got the error again. However, I did not find the one you mentioned regarding run assistant. Could you tell me where is it.
    And the subversion is IC 6.1.5.500.16.2.
     

    • Post Points: 20
  • Mon, Apr 8 2013 2:36 AM

    Re: Question of Monte Carlo simulation of Virtuoso 6.1.5 Reply

    In your post http://www.cadence.com/Community/forums/p/25155/1322416.aspx#1322416 , in the bottom left corner there is a "Run Summary" assistant. Just below the checkbox that says "Nominal Corner" there is a little icon that appears for each parallel run - if you do right mouse button over this, you'll get a log file.

    Andrew.

    • Post Points: 20
Page 1 of 2 (17 items) 1 2 Next >
Sort Posts:
Started by bhl3302 at 24 Feb 2013 11:15 PM. Topic has 16 replies.