Home > Community > Forums > PCB Design > DXF import in Allegro (argh!)

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 DXF import in Allegro (argh!) 

Last post Tue, Feb 26 2013 8:47 AM by N i z e. 10 replies.
Started by N i z e 24 Feb 2013 08:53 AM. Topic has 10 replies and 3800 views
Page 1 of 1 (11 items)
Sort Posts:
  • Sun, Feb 24 2013 8:53 AM

    • N i z e
    • Top 500 Contributor
    • Joined on Fri, Oct 28 2011
    • Aabyhoej, Copenhagen
    • Posts 28
    • Points 410
    DXF import in Allegro (argh!) Reply

    I'm desparately trying to import a vector based logo into a Orcad PCB 16.2. However, this for some reason suddenly seem impossible:

    If I try to import DXF I never seem to be able to "view selected layers" (and thus never import anything). The dialogue does however show me DXF layer names (for instance the Cadence sample dxf has names similart to Allegro layers). Tried over 10 different versions exported to different AutoCad versions - but the format did not seem to matter. From what I read in this forrum and elsewhere Autocad version 2004 or 14 seem to be the better bets (can't find anything useful in the Cadence documentation). Out of desperation I've also tried with an ouline that I've positively imported and used for another board. Same results all over the line:

    From an open .dra file I get:
    Opening existing drawing...
       E- *Error* fprintf/sprintf: format spec. incompatible with data - "Format is 'dxf2a -$ %s -u %s -v %s -a %d %s %s %%s %s', argument #1 is nil"

    From an open .brd the dxf2a.log reads:
      ERROR: Invalid program arguments.
      Terminating program.

    Any hints on what I'm (or Allegro is) messing up here? I'm on the virge of trying a reinstall - but that'll probably just be complete waste of time...(!?)

    Thanks and best regards,

     Anders

     PS: Seemingly it's impossible to scale anything in Allegro 16.2.?

    • Post Points: 35
  • Sun, Feb 24 2013 9:25 AM

    • N i z e
    • Top 500 Contributor
    • Joined on Fri, Oct 28 2011
    • Aabyhoej, Copenhagen
    • Posts 28
    • Points 410
    Re: DXF import in Allegro (argh!) Reply

    I've just tried opening the old board - here the outline opens fine. A downloaded dxf likewise. One of my own dxf files show nothing but does not fail the view layers command - the rest fails. But at least there's "life"!

    A new, clean board (created with the wizard) does not import any dxfs... So I guess I'm looking for a setting somewhere to change from default?

    • Post Points: 20
  • Mon, Feb 25 2013 1:35 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,246
    • Points 20,290
    Re: DXF import in Allegro (argh!) Reply

    For a logo you might be better using the Logomaker skill program that was written by Dave Elder (and if you search this forum you will find a post about it all). As regards the scaling of a logo the answer is Yes. There's an App (another skill file) that will do this. It's free you just need to go and get it. http://www.orcadmarketplace.com/undefined/ProductDetails/tabid/93/ProductID/48/Default.aspx 

    • Post Points: 20
  • Mon, Feb 25 2013 1:44 PM

    • N i z e
    • Top 500 Contributor
    • Joined on Fri, Oct 28 2011
    • Aabyhoej, Copenhagen
    • Posts 28
    • Points 410
    Re: DXF import in Allegro (argh!) Reply

     Steve,

    Thanks for the link! But as I've read it, it takes bitmap files? I'm not sure I'm happy relying on such a conversion for critical stuff like outlines, holes etc... So I'm still hoping someone out there has a clue for the DXF import. With the very limited CAD capabilities of Allegro it's a pretty crucial feature IMHO...

    I also seems a rather strange 'long way around' for the vector based logos - but right now I'll try anything. Hope there's a version for my old 16.2 as well - the linked ones states "16.5 & above".

    • Post Points: 5
  • Mon, Feb 25 2013 1:55 PM

    • fxffxf
    • Top 25 Contributor
    • Joined on Thu, Jul 17 2008
    • ., AK
    • Posts 298
    • Points 4,735
    Re: DXF import in Allegro (argh!) Reply

    since it is 16.2,you can try...

        - make sure the symbol type of the dra is a package, mech or format (avoid shape and format symbol types)

        - or import the dxf into a brd and then use import/export sub-design to get the data into a dra.

        - or use 16.5 or 16.6

     

    • Post Points: 5
  • Mon, Feb 25 2013 2:06 PM

    • mcatramb91
    • Top 75 Contributor
    • Joined on Thu, Jan 3 2013
    • Chelmsford, MA
    • Posts 101
    • Points 5,010
    Re: DXF import in Allegro (argh!) Answer Reply

    Do you happen to have spaces in the folder path where the DXF file is located or spaces in the actually DXF File name?  If so, change them to underscores or remove them and see if the problem goes away.

    I can't say that I have seen this before but maybe this will help.

    Regards,
    Mike Catrambone

    • Post Points: 20
  • Mon, Feb 25 2013 5:42 PM

    • N i z e
    • Top 500 Contributor
    • Joined on Fri, Oct 28 2011
    • Aabyhoej, Copenhagen
    • Posts 28
    • Points 410
    Re: DXF import in Allegro (argh!) Reply

    fxffxf,

    Thanks for your comments! I am working with packages in the dra.'s so check on that! Seems the problems are general - disregarding if I'm working in .dra or .brd files. I'd love to upgrade to a new version - especially to get it back into support. But unfortunately this is way out of my budget. Sad to waste so much time on stupid problems - but when liquidity is hurting time is actually not quite money :-O

    Mike,

    I'm afraid I have to confirm that the spaces ARE equal to problems! After removing them the different board files at least show similar behaviour. This is a great step forward, probably something I should have expected (do remember problems like that, now that I see it again!).  Thanks a lot for the hint! :-D

     

    I'm back to looking at the dxfs (that's great!). Any recommendations for the dxf versions to use, commands to be avoided (I notice the dxfs are readable text) or freeware (or cheap) programs to clean them up? (I'm not aware of the AutoDesk pricing - but I think it's probably not something I'd like to pay for "a utility for Allegro" ;-)

    Cheers, Anders

    • Post Points: 20
  • Mon, Feb 25 2013 8:58 PM

    • N i z e
    • Top 500 Contributor
    • Joined on Fri, Oct 28 2011
    • Aabyhoej, Copenhagen
    • Posts 28
    • Points 410
    Re: DXF import in Allegro (argh!) Reply

    Update: I've messed around with three freeware CAD programs - they all can import the original dxfs. But they don't make any significant difference for Allegro. Haven't compared files - but commonly it seems they generate splines (that Allegro does not support).

    Right now I'm having some succes with exporting dxfs from Corel Draw (!) in Autocad R2.5 format. Seems a requirement to keep all objects unfilled. Importing to board_geometry/silkscreen_top everything ends up in shapes. That's basically OK, except right now I can't figure out how to change a shape to a void?! Think of an "O" as an outer and an inner contour: The inner one should be a shape void, right? But this is not an option with the shape/change command (that returns "W- (SPMHGE-482): Change shape type not allowed for non etch shapes." anyways). Puzzels me completely right now - and I can see it's also on my old "unsolved stuff" list. Perhaps I'm on the wrong path??? Not that importing to an etch layer (where everything gets to be clines) makes it any better ;-)

    • Post Points: 20
  • Tue, Feb 26 2013 2:11 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,246
    • Points 20,290
    Re: DXF import in Allegro (argh!) Answer Reply

    Sorry about the logomaker - your first post mentioned logos so I assumed you needed a company logo and not board outlines etc. When you import dxf you could try bringing in everything to a dummy layer (like Board geometry assembly notes / details) then to get a shape to be a voided shape try Shape - Compose Shape, select the layer etc in the options then window the inner contour, this creates a filled shape, then window select everything (inner and outer contour and you should get a voided 'o' shape. (Well this works in 16.6....)

    • Post Points: 20
  • Tue, Feb 26 2013 5:29 AM

    • mcatramb91
    • Top 75 Contributor
    • Joined on Thu, Jan 3 2013
    • Chelmsford, MA
    • Posts 101
    • Points 5,010
    Re: DXF import in Allegro (argh!) Reply

    My standard process was to output the DXF file at the lowest possible version (Version 12.0) to improve my chances of getting any DXF file to import.  Not saying that higher versions won't import but going down to a lower version strips out any of the newer features in AutoCAD that I really don't care about anyway and I have seen Allegro complain about during import.

    I would also open up the DXF file in AutoCAD or some viewer and explode grouped elements and Blocks to their individual elements.  Again I really didn't care most of the time about any grouping but just wanted to raw data to come in and I can take it from there from inside of Allegro  I have used AutoCAD to flatten out the DXF files most of the time but another tool that has been useful was Cadopia (http://www.cadopia.com/) which gave me the ability to load DXF and DWG files to explode or downrev the DXF file to a lower version.  I want to say that it was part of the Cadence standard install some time ago but I just can't remember which version.

    Here is a previous thread on DXF translation.  http://www.cadence.com/Community/forums/p/19502/1278044.aspx#1278044

    Good luck,
    Mike Catrambone

    • Post Points: 5
  • Tue, Feb 26 2013 8:47 AM

    • N i z e
    • Top 500 Contributor
    • Joined on Fri, Oct 28 2011
    • Aabyhoej, Copenhagen
    • Posts 28
    • Points 410
    Re: DXF import in Allegro (argh!) Reply

    Steve,

    No worries: I'm currently messing around with both logos and mechanics. But I generally dislike converting vectors to bitmaps when the final product is also vectors. ;-) Anyway, the main problem is that I think the application concept is new to 16.5 or 16.6 - so the app installs on windows but does not show up in my 16.2.

    As for the "compose shape" it worked like a charm. Still have trouble understanding the procedure - but I think this is the first time I've experienced Allegro seeming to know what I wanted to do! :-D

    Thanks for the support - I'd never 'gotten through this without the hints from you and Mike!

    Cheers,

     Anders

    • Post Points: 5
Page 1 of 1 (11 items)
Sort Posts:
Started by N i z e at 24 Feb 2013 08:53 AM. Topic has 10 replies.