Home > Community > Forums > Digital Implementation > Question on #LM Placement using EDI 10.1 USR3

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Question on #LM Placement using EDI 10.1 USR3 

Last post Thu, Feb 14 2013 10:53 AM by JAUB. 0 replies.
Started by JAUB 14 Feb 2013 10:53 AM. Topic has 0 replies and 599 views
Page 1 of 1 (1 items)
Sort Posts:
  • Thu, Feb 14 2013 10:53 AM

    • JAUB
    • Not Ranked
    • Joined on Thu, Mar 22 2012
    • Posts 2
    • Points 25
    Question on #LM Placement using EDI 10.1 USR3 Reply

    Running placement on a small digital block (about 37K instances -- part of a mixed signal design) using a 3LM technology that often has issues with placement densities in the 60percent rang, i.e., 55% placement density can be seen as a high density design when routing.

    Have seen good results using  "setPlaceMode -threeLayerMode true" ; however,  it does not always give me optimal results.

    Would setting "setPlaceMode -modulePlan false"  be a useful option on running on this type of technology? When I was at Cadence, I recall being told to set that variable to "true" to use the new placement engine (new at that time) but was never given a reason to turn off modulePlan.

    Someone recommended to another designer  to run 3LM placement with modulePlan turned off. Does it ever make sense to do that ? 

    The floorplan contains no fences, regions, guides, or  density screens, which "modulePlan false" does not support. Have experiemented with these various floorplan constraints, but often they are counterproductive on small blocks.

    Have implemented quite a few 3LM designs in this technology so I am running the typical 3LM high density settings  (in various combnations): congEffort high, doCongOptt true, -clkGateAware true, threeLayerMode, scan reordering, etc.  Ran tricks like congRepair which has been useful for quite a few year now.

    Just not sure if turning off modulePlan is worth the effort or time. Any recommendations on when to turn it off ?

     

    Thank You and Regards,

     Jeff Aubert 

     

     

    • Post Points: 5
Page 1 of 1 (1 items)
Sort Posts:
Started by JAUB at 14 Feb 2013 10:53 AM. Topic has 0 replies.