Home > Community > Forums > PCB Design > Netlist import removes placed components

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Netlist import removes placed components 

Last post Fri, Feb 1 2013 5:21 AM by TH Designs. 3 replies.
Started by TH Designs 30 Jan 2013 08:00 PM. Topic has 3 replies and 688 views
Page 1 of 1 (4 items)
Sort Posts:
  • Wed, Jan 30 2013 8:00 PM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Netlist import removes placed components Reply

    I have a schematic that has had several parts changed on it. The footprints remain the same, but either the symbol has changed or a part value has changed. Whenever I import the new "logic" the many of the components are "un-placed". There is no reason for them to be removed as the ref des has not changed nor has the footprint.

    I just imported a new logic file and 95 parts were removed.

    How do I prevent this from happening?

    Frustrated..........

     Tom

    • Post Points: 20
  • Thu, Jan 31 2013 2:12 AM

    • oldmouldy
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Woking, Surrey
    • Posts 1,382
    • Points 23,525
    Re: Netlist import removes placed components Reply
    From what you describe, the "device type" will have changed, PCB Editor usually has "Place Changed Component" set to "always" and should survive changes like this Check the log file after import to see if that has anything of interest in it. IF the parts really do have the same Refdes and Footprint values, you can use a placement list, before importing the logic, File>Export>Placement to generate the placement file, File>Import>Logic to update the netlist, File>Import>Placement to get the placement back BUT, I suspect that there is "something else" about the Logic Import that is causing the parts to be unplaced from the board.
    • Post Points: 35
  • Thu, Jan 31 2013 4:39 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Netlist import removes placed components Reply
    Thanks, I'll try exporting the placement first. I'll also review the schematic properties to look for anything that may have changed to prompt this. These were customer generated changes, I did not make them so something could easily have gotten missed.
    • Post Points: 5
  • Fri, Feb 1 2013 5:21 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Netlist import removes placed components Reply

    OM,

    Did what you said, worked perfectly. Thank you for the tip.

    Tom

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by TH Designs at 30 Jan 2013 08:00 PM. Topic has 3 replies.