Home > Community > Forums > Custom IC Design > Query in Naming in schematic and layout

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Query in Naming in schematic and layout 

Last post Wed, Jan 23 2013 2:10 AM by BB11. 2 replies.
Started by BB11 18 Jan 2013 05:19 AM. Topic has 2 replies and 620 views
Page 1 of 1 (3 items)
Sort Posts:
  • Fri, Jan 18 2013 5:19 AM

    • BB11
    • Not Ranked
    • Joined on Tue, Dec 18 2012
    • Lund, Sweden
    • Posts 2
    • Points 25
    Query in Naming in schematic and layout Reply

    Hello 

     

    I have a question regarding naming conventions in layout and schemtics. Suppose I use vdd! and vss! to represent in my layout for vdd and gnd. When i run a testbench simulation, i assign the local value vdd! to the master value vdd. But i still see that my ouput is not as expected. Could anyone help me with this?

    Thanks

     

    BB

    • Post Points: 20
  • Fri, Jan 18 2013 8:18 AM

    Re: Query in Naming in schematic and layout Reply

    Not enough detail I'm afraid. You didn't say what simulator you're using, which version of the tools you are using, or what you mean by "I assign the local value vdd! to the master value vdd". Or what the output is that  you're expecting or what it is actually giving, or what your circuit is. Unfortunately we're not clairvoyant, so could you provide some more details to describe precisely what you're doing, and precisely what does not work?

    Kind Regards,

    Andrew.

    • Post Points: 20
  • Wed, Jan 23 2013 2:10 AM

    • BB11
    • Not Ranked
    • Joined on Tue, Dec 18 2012
    • Lund, Sweden
    • Posts 2
    • Points 25
    Re: Query in Naming in schematic and layout Reply

    Hi Andrew

    Sorry for the lesser details. I am using spectre.I have a problem to use global power and ground in Cadence6.

    I use vdd! and vss! in my schematics. They are recognized in different hierarchy in schematic simulation, so no problem. However, they are a problem when I would like to run a testbench simulation. 
    Either I use  vdd and gnd symbols and directly connects to a block of the circuit or another way is giving pins and name them vdd! and gnd!. In either way, there will be no physical nodes to connect to a power source and ground. There is no problem with spectere simulaion, but when I try to run a testbench simulation the problem arises.

     I know there is some method where in the testbench simulation ,I edit the properties of the symbol and use netset and assign them to vdd and gnd. But when i tried this with the inverter the expected inverter output is not seen.

     Could you please tell me the steps as in how assign the local values to the global ones?

    Kind Regards

    BB

     

     

     

    • Post Points: 5
Page 1 of 1 (3 items)
Sort Posts:
Started by BB11 at 18 Jan 2013 05:19 AM. Topic has 2 replies.