Home > Community > Forums > Functional Verification > ncsim: *E,UNKMOD: unrecognized modifier for the coverage -code command (-database)

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 ncsim: *E,UNKMOD: unrecognized modifier for the coverage -code command (-database) 

Last post Thu, Jan 10 2013 12:37 AM by czh32689. 3 replies.
Started by czh32689 09 Jan 2013 10:51 PM. Topic has 3 replies and 1402 views
Page 1 of 1 (4 items)
Sort Posts:
  • Wed, Jan 9 2013 10:51 PM

    • czh32689
    • Not Ranked
    • Joined on Thu, Jan 10 2013
    • Posts 4
    • Points 65
    ncsim: *E,UNKMOD: unrecognized modifier for the coverage -code command (-database) Reply

    I encountered this error when I was trying to collect the code coverage of my design.

    The nc simulation command line contains" +ncinput+./testbench/sim/ict.tcl". And the contents of the file ict.tcl are as follows.

    coverage -setup -dut top.tb_top.my_design -testname my_design -workdir .
    coverage -code -database -local_db
    coverage -code -score all
    run

    I don't know what's the cause. The simulation tool I use is  ncverilog 09.20-s032.

    Who can help me? Thanks a lot!!!

    Filed under:
    • Post Points: 5
  • Thu, Jan 10 2013 12:14 AM

    • czh32689
    • Not Ranked
    • Joined on Thu, Jan 10 2013
    • Posts 4
    • Points 65
    Re: ncsim: *E,UNKMOD: unrecognized modifier for the coverage -code command (-database) Reply

    After I changed the simulation tool from ncverilog 09.20-s032 to "ldv 5.7", the problem was resolved.

    • Post Points: 20
  • Thu, Jan 10 2013 12:23 AM

    • StephenH
    • Top 25 Contributor
    • Joined on Tue, Sep 2 2008
    • Bristol, Avon
    • Posts 278
    • Points 4,450
    Re: ncsim: *E,UNKMOD: unrecognized modifier for the coverage -code command (-database) Reply

    Your problem is that you're using Tcl commands that rely on a very old version of the simulator.

    Starting from version 5.8 the entire coverage system was replaced. Since then you must set the coverage scoring options at elaboration time. There are only a limited number of things which you may now change at simulation time, mainly you can turn coverage off completely and you can set the test name.

    Put the following commands into a file named (for example) cov.options:

    select_coverage -be -instance top.tb_top.my_design...

    Then use the ncverilog or irun option "-covfile cov.options" at elaboration time. You should then get rid of all your Tcl coverage commands from ict.tcl.

    By the way, 5.7 through to 9.2 are all old and unsupported versions now. Please consider upgrading to the latest, 12.2, since that has many improvements in terms of coverage performance and better analysis features. In addition you will actually get support for version 12.2! :-) 

    Steve Hobbs / Applications Engineer / Cadence Functional Verification
    • Post Points: 20
  • Thu, Jan 10 2013 12:37 AM

    • czh32689
    • Not Ranked
    • Joined on Thu, Jan 10 2013
    • Posts 4
    • Points 65
    Re: ncsim: *E,UNKMOD: unrecognized modifier for the coverage -code command (-database) Reply

    Thank you very much for your kind reply. I will adopt your advice and use the new commands during simulation. Thanks again!

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by czh32689 at 09 Jan 2013 10:51 PM. Topic has 3 replies.