Home > Community > Forums > PCB Design > Footprint shapes not showing solid copper

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Footprint shapes not showing solid copper 

Last post Mon, Dec 3 2012 2:58 AM by steve. 3 replies.
Started by TH Designs 29 Nov 2012 01:04 PM. Topic has 3 replies and 850 views
Page 1 of 1 (4 items)
Sort Posts:
  • Thu, Nov 29 2012 1:04 PM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Footprint shapes not showing solid copper Reply

    I made this connector footprint which requires solder pads around the perimeter to hold the connector to the board. They are on shapes on the etch layer with solid fill, but they always show as outlines with dots inside. Even when doing the artwork preview.

    Will they come out as solid copper pads in the gerbers?

    Tom

    • Post Points: 20
  • Thu, Nov 29 2012 1:12 PM

    • oldmouldy
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Woking, Surrey
    • Posts 1,382
    • Points 23,540
    Re: Footprint shapes not showing solid copper Reply
    They are static shapes. 16.5 and later reverts to the "pre-16.0" display for static shapes, the shapes are also static in the Artwork Import but the Gerber data is "pen or no-pen" shapes will be filled correctly. You can restore the "post-16.0 (to 16.3)" behaviour through Setup>User Preferences, Display, Opengl, static_shapes_fill_solid. Remember that "Transparency" will also be on so tweak this to 100% for the Global and Shapes in OpenGL settings in Display>Color/Visibility, Display folder, if you wish.
    • Post Points: 20
  • Fri, Nov 30 2012 5:46 AM

    • TH Designs
    • Top 25 Contributor
    • Joined on Fri, Apr 13 2012
    • Warminster, PA
    • Posts 269
    • Points 4,370
    Re: Footprint shapes not showing solid copper Reply

    Works. Thanks.

    I have to ask, how the heck do you know how to navigate of these option selections?

    There are so many settings / options in this program I expect to find a selection one day that says:

    "don't_click_ or_do_click_to_set_all_options_or_settings_or_classes_on_or_off".

    Tom

    • Post Points: 20
  • Mon, Dec 3 2012 2:58 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,172
    • Points 18,990
    Re: Footprint shapes not showing solid copper Reply

    Tom - In Setup - User Preferences click on the Info button and you get a list of the settings plus a description to what they do. Whenever you set one it gets written to the %HOME%\pcbenv\env file so you can see what you have set.

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by TH Designs at 29 Nov 2012 01:04 PM. Topic has 3 replies.