Home > Community > Forums > Custom IC Design > Unbound pin error from Assura LVS after P&R

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Unbound pin error from Assura LVS after P&R 

Last post Wed, May 14 2014 2:16 PM by alperro. 4 replies.
Started by bjbit 25 Oct 2012 02:38 PM. Topic has 4 replies and 1852 views
Page 1 of 1 (5 items)
Sort Posts:
  • Thu, Oct 25 2012 2:38 PM

    • bjbit
    • Top 100 Contributor
    • Joined on Tue, Mar 6 2012
    • Posts 65
    • Points 1,120
    Unbound pin error from Assura LVS after P&R Reply

    Hi,

    When I do Assura LVS on the layout I got from P&R Encounter, the "unbound pins" error appears in the report. As the attached picture shows, the net marked as green color in both schematic and layout looks matching well. But it seems LVS cannot specify the pin ports from the instance of the standard cell layout? Can I ignore this error and trust that schematic and layout actually match? Thanks in advance.

    Best regard, 


    • Post Points: 20
  • Tue, Nov 20 2012 3:24 AM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,060
    • Points 16,110
    Re: Unbound pin error from Assura LVS after P&R Reply

    Hi bjbit

    I think it is better to troubleshoot the error so that you can get lvs match. The error looks strange. Assura seems to be reporting. You should check the sdb and ldb netlists in the run directory to see why Assura is reporting pin errors.

    terminal>vldbToCdl design.sdb > design.sdb.ascii

    The above cmd will convert the binary netlist to ascii format.

    Best regards
    Quek

    • Post Points: 20
  • Tue, Nov 20 2012 6:56 AM

    • berndfi
    • Top 100 Contributor
    • Joined on Tue, Sep 11 2012
    • Neubiberg, Bavaria
    • Posts 67
    • Points 1,255
    Re: Unbound pin error from Assura LVS after P&R Reply

    Check if your layout pins are in the correct format
    to get properly recognized by your Assura LVS.
    If you exchange the data from Encounter to Virtuoso in GDSII
    format your pins are most likely only defined as labels over the
    interconnects. This may work for a LVS run on GSDII layout basis,
    but probably not for a LVS on the Virtuoso layout database.

    If this is the case you can try the utility ‘Create Pins From Labels’,
    to get the pins in the proper form.
    From the layout window ‘Tools -> Create Pins From Labels’.

    Bernd

    • Post Points: 20
  • Tue, Nov 20 2012 9:19 AM

    • bjbit
    • Top 100 Contributor
    • Joined on Tue, Mar 6 2012
    • Posts 65
    • Points 1,120
    Re: Unbound pin error from Assura LVS after P&R Reply
    Sorry guys I should have posted a update that I already figured this out. The encounter automatically adds net names on label layers, and Assura LVS treats them as pins, which caused pin mismatch. Thanks all the same. Best regards,
    • Post Points: 20
  • Wed, May 14 2014 2:16 PM

    • alperro
    • Not Ranked
    • Joined on Wed, Jun 12 2013
    • Istanbul, 00-TR
    • Posts 3
    • Points 30
    Re: Unbound pin error from Assura LVS after P&R Reply
    Hi bjbit, 

    I have encountered the same problem. How could you solve this back then? 

    Regards. 
    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by bjbit at 25 Oct 2012 02:38 PM. Topic has 4 replies.