Home > Community > Forums > PCB Design > mechanical alignment hole not showing properly in 16.5 PCB Editor (look ok in 3D view)

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 mechanical alignment hole not showing properly in 16.5 PCB Editor (look ok in 3D view) 

Last post Mon, Oct 22 2012 10:37 AM by mfris. 3 replies.
Started by mfris 19 Oct 2012 09:19 AM. Topic has 3 replies and 1117 views
Page 1 of 1 (4 items)
Sort Posts:
  • Fri, Oct 19 2012 9:19 AM

    • mfris
    • Top 500 Contributor
    • Joined on Tue, Sep 18 2012
    • Durham, NC
    • Posts 20
    • Points 440
    mechanical alignment hole not showing properly in 16.5 PCB Editor (look ok in 3D view) Reply

    Hi everyone,

    Amateur user here.

    I created a couple of footprints with mechanical alignment holes that go through the PCB (I also created the padstack that defines the holes).  As far as I can tell, everything looks fine for the various holes while in the footprint editing mode.  When I bring the parts into PCB Editor to place the part, I can see a shape in the area where the holes should be, but none of the shapes are the right size and I'm able to route in the area without a DRC.  When I switch to the 3D view, the hole shapes appear to be the right dimensions.

     Any thoughts on what I need to do differently to get the holes to show up in PCB edit mode?  Thanks in advance for any help.

     Best regards.

    • Post Points: 35
  • Mon, Oct 22 2012 1:42 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,054
    • Points 16,990
    Re: mechanical alignment hole not showing properly in 16.5 PCB Editor (look ok in 3D view) Reply

    It sounds like they are defined a mechancial holes without a pad. The color is defined under Display - Color Visibility Display folder, set something other than black as the color for drill holes. To get the DRC modes to work you need to enable it. Got to Setup - Constraints - Modes - Spacing Modes and make sure all the Hole to items are checked. Ideally everything in that list should have a tick. Then you should see the DRC's when routing. Make sure your drill hole size is set correctly in Pad Designer.

    • Post Points: 5
  • Mon, Oct 22 2012 8:07 AM

    • Ron Scott
    • Top 500 Contributor
    • Joined on Tue, Sep 4 2012
    • Posts 17
    • Points 220
    Re: mechanical alignment hole not showing properly in 16.5 PCB Editor (look ok in 3D view) Reply
    Try this out. It sometimes slips peoples mind. Go to Setup-->Design Parameters Editor and see if you have "Display Non-Plated Holes" selected HTH Ron Scott
    • Post Points: 20
  • Mon, Oct 22 2012 10:37 AM

    • mfris
    • Top 500 Contributor
    • Joined on Tue, Sep 18 2012
    • Durham, NC
    • Posts 20
    • Points 440
    Re: mechanical alignment hole not showing properly in 16.5 PCB Editor (look ok in 3D view) Reply

    Ron and Steve,

     Thank you both for the quick reply.  In my case, going to Setup->Design Parameters and slecting "Display Non-Plated Holes" resolved the issue of not seeing the hole.  Setup -> Constraints -> Modes gave me the view to turn on the DRCs. 

    Thanks again for the help!!

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by mfris at 19 Oct 2012 09:19 AM. Topic has 3 replies.