Home > Community > Forums > Cadence Academic Network > PSPICE Library problem

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 PSPICE Library problem 

Last post Sat, Dec 1 2012 8:34 AM by alokt. 1 replies.
Started by Szabolcs88 05 Oct 2012 03:32 AM. Topic has 1 replies and 2948 views
Page 1 of 1 (2 items)
Sort Posts:
  • Fri, Oct 5 2012 3:32 AM

    • Szabolcs88
    • Not Ranked
    • Joined on Thu, Sep 13 2012
    • Romania, Romania
    • Posts 11
    • Points 335
    PSPICE Library problem Reply

     I have ran into a problem while I was generating a buck regulator pspice model. AP8803 (from Diodes) spice model I've downloaded from the 'Diodes' site and made a new pspice model. This is the method:

    Model Editor -> New

    Model -> Import (here I have entered the text file here)

    Save the design

    Export it to Cadence.

    When I use the part I include it and it still says "ERROR(ORPSIM-15108): Subcircuit AL8803_SIMETRIX used by X_X1 is undefined"  Why is this? Is there something wrong with the model? When I added the txt file in model editor with import these were the last two lines

    ".model Dzener D Is=1e-8 N=10 bv=1.245 ibv=1e-12 Cjo=.1e-12 Rs=.1 TBV1=4e-5 nbv=.01
    .model Dclamp  D Is=2.682n N=1.836 Rs=.5664 Ikf=44.17m Cjo=4p M=.3333 Vj=.5"

    and there are still some data after this as well...

    Can you give me any suggestions what is happening here? Why isn't it working?

    Thank you.

    • Post Points: 20
  • Sat, Dec 1 2012 8:34 AM

    • alokt
    • Top 25 Contributor
    • Joined on Fri, Aug 22 2008
    • Noida, Uttar Pradesh
    • Posts 241
    • Points 3,470
    Re: PSPICE Library problem Reply

    This specific error is due to missing model. You need to include this library in simulation profile. You can do so by

    Edit Simulation Profile

    Configuration TAB- Library Files

    Browse the .Lib file (the one you created using import method)

    Select "Add to design"

    Now this error should go away. However you may not be able to successfully simulate this model. This model is meant for Simetrix and uses device, which are not supported in PSpice (for example "B")

     

     

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by Szabolcs88 at 05 Oct 2012 03:32 AM. Topic has 1 replies.