Home > Community > Forums > PCB Design > Infinite Cursor

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Infinite Cursor 

Last post Thu, Apr 4 2013 7:44 AM by dolphin82153. 9 replies.
Started by budnoel 04 Oct 2012 11:54 AM. Topic has 9 replies and 2782 views
Page 1 of 1 (10 items)
Sort Posts:
  • Thu, Oct 4 2012 11:54 AM

    • budnoel
    • Top 50 Contributor
    • Joined on Tue, Aug 12 2008
    • Rochester, NY
    • Posts 129
    • Points 2,100
    Infinite Cursor Reply

    Hello all - I use PCB Editor on 3 different machines at various times of the week.  I have my user preference for the display of my cursor set to "infinite".  On two of the three machines I experience a "ghosting" of the cursor as I move it across the screen.  A remnant of the cursor display is left until I pan or zoom.  Any ideas what might be causing this?  I'm guessing my graphics card.  Thanks in advance.

    • Post Points: 35
  • Thu, Oct 4 2012 12:43 PM

    • Roger BFS
    • Top 100 Contributor
    • Joined on Fri, Mar 4 2011
    • Morrison, CO
    • Posts 67
    • Points 965
    Re: Infinite Cursor Reply

    Yes - I too have this issue with my new Win7 i7 screaming workstation that I just built. It actually makes the infinite cursor option useless on my system.

    In working a related issue with the 3D viewer with tech support I learned that there is an incompatibility (PCB editor) with the Win 7/Microsoft "Aero Themes" for desktop display!  Perhaps this only applies to some graphics cards, but it certainly does to mine.  The "fix" is to turn off any "aero theme" desktop and go back to Windows basic desktop or something.  Alternatively, you can disable OpenGL in your PCB editor preferences, but unfortunately this also disables the 3D viewer function.

    Cadence has an enhancement request to fix this bug sometime - -

    Roger Green

    Roger Green - B F Systems, LLC
    Filed under: ,
    • Post Points: 5
  • Thu, Oct 4 2012 5:48 PM

    • ScottCad
    • Top 50 Contributor
    • Joined on Fri, May 25 2012
    • Roswell, GA
    • Posts 176
    • Points 2,775
    Re: Infinite Cursor Reply

    Yep on win7 the cursor looks lovely with all the ghosting. There is a fix that has worked for me. Try this.

    Right click on your PCB editor Icon and select properities.

    Click on the Compatibility tab.

    Check the following boxes. "'Disable Visual Themes", "Disable Desktop Composition"  "Run this program as an administrator"

    No need to disable Aero on a win7 machine for this to work, just change the properities that launch the PCB editor. No need to disable Open GL either in the PCB Editor though disabling Open Gl will fix that issue but then you will loose a pretty looking board on the screen due to the benifits of open gl

    Hope it works for you at that end.

    Thanks Scott

    • Post Points: 35
  • Thu, Oct 4 2012 6:18 PM

    • Roger BFS
    • Top 100 Contributor
    • Joined on Fri, Mar 4 2011
    • Morrison, CO
    • Posts 67
    • Points 965
    Re: Infinite Cursor Reply

    Thanks Scott,

    I was unaware of the compatibility run options to get the same fix as turning off the Aero themes.  Cadence tech support told me to turn off the Win theme.  BTW - the 3D viewer issue I was fighting at the time was in trying to export a picture (jpg or png) snapshot of the 3D board view.  The file created was "all black" due to the aero theme incompatibility.

    Roger

    Roger Green - B F Systems, LLC
    • Post Points: 20
  • Thu, Oct 4 2012 8:21 PM

    • ScottCad
    • Top 50 Contributor
    • Joined on Fri, May 25 2012
    • Roswell, GA
    • Posts 176
    • Points 2,775
    Re: Infinite Cursor Reply

    Hi Roger, that fix I described works like a champ for me. I have a potent win7 box with a nice radeon graphics card and the infinate cursor was a got to have so I did a bit of research on gaming forums of all places. Many games use open gl still, anyway as I recall there was a post I read about this game that had ghosting problems on vista so the fix was what I wrote earlier. Needless to say I was delighted when it worked with allegro.

    I think the 3D engine in Allegro is very much a work in progress, I recall one of the service packs causing issues for us here. It couldnt display the shapes on the board.. got to love that, BTW another way to get a jpg of the 3d view of the board is to just hit the print screen key and paste the buffer into your favorite picture viewer... that works kind of good for me at this end.

    Today I found another wierdo with the 3d engine. Suppose you have a rectangle and another smaller rectangle on top of it with a 1 mil gap between them so you get a good rendition of a SOIC package, well it displays and looks great but in the 3d viewer if you set the Z-Scale to say 10 to expose the inner layers of your board your shape that is sitting on the larger shape gets exploded in the Z plane too so it is like part of your package is floating in air.. Dont believe this was the intent of the deigners of the 3d engine... LOL

    Thanks Scott 

    • Post Points: 20
  • Fri, Oct 5 2012 2:00 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,215
    • Points 19,775
    Re: Infinite Cursor Reply

    There is a user variabel you can add which will correct the "ghosting effect" of the inifinite cursor which is normally down to incompatabilies with your graphics driver.

    Locate %HOME\pcbenv. In here is the env file which you can edit with a text editor. Add set infinite_cursor_bug_nt. Restart Allegro and you should be good to go.

    • Post Points: 35
  • Fri, Oct 5 2012 9:35 AM

    • ScottCad
    • Top 50 Contributor
    • Joined on Fri, May 25 2012
    • Roswell, GA
    • Posts 176
    • Points 2,775
    Re: Infinite Cursor Reply

    Hi Steve, I edited the env and added infinite_cursor_bug_nt to it,

    Did a re-start etc, Cursor still Ghosts on a win7 OS.

    Thanks Scott

    • Post Points: 20
  • Fri, Oct 12 2012 2:37 PM

    • Matija G
    • Not Ranked
    • Joined on Fri, Nov 25 2011
    • Ljubljana, Slovenia
    • Posts 1
    • Points 5
    Re: Infinite Cursor Reply

    set infinite_cursor_bug_nt
    resolved ghosting problem in 16.2 and 16.3 for sure

     

    • Post Points: 5
  • Tue, Oct 16 2012 9:04 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,215
    • Points 19,775
    Re: Infinite Cursor Reply

    Hi Scott

     Make sure in the env it says:-

    set infinite_cursor_bug_nt

    • Post Points: 5
  • Thu, Apr 4 2013 7:44 AM

    Re: Infinite Cursor Reply

    Amen to your fix, it finally works.

    Thanks Scott

    Al Gonzalez

    • Post Points: 5
Page 1 of 1 (10 items)
Sort Posts:
Started by budnoel at 04 Oct 2012 11:54 AM. Topic has 9 replies.