Home > Community > Forums > RF Design > *WARNING* QRC_HOME environmental variable is set but UI can't locate correct QRC installation

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 *WARNING* QRC_HOME environmental variable is set but UI can't locate correct QRC installation 

Last post Tue, Sep 4 2012 2:25 AM by Andrew Beckett. 3 replies.
Started by Aldo2 21 Aug 2012 02:43 AM. Topic has 3 replies and 1444 views
Page 1 of 1 (4 items)
Sort Posts:
  • Tue, Aug 21 2012 2:43 AM

    • Aldo2
    • Top 200 Contributor
    • Joined on Mon, Aug 29 2011
    • Catania, Catania
    • Posts 43
    • Points 650
    *WARNING* QRC_HOME environmental variable is set but UI can't locate correct QRC installation Reply

     Hello,

    I get the following warning with QRC:

     *WARNING* QRC_HOME environmental variable is set but UI can't locate correct QRC installation.
              In order to run UI in QRC compatibility mode you need to have QRC executables in your $PATH and QRC version should be 8.1 or greater.
              Check your QRC installation and environmental settings.

    I am using:

    ic 615isr20120513 and pve 1111isr20120629

    Thank you very much

    Best Regards

    Aldo

    • Post Points: 20
  • Mon, Sep 3 2012 9:51 PM

    Re: *WARNING* QRC_HOME environmental variable is set but UI can't locate correct QRC installation Reply

    Aldo,

    The only way I can get this to happen is if I have QRC_HOME set to <PVEinstallationDir> but not having <PVEinstallationDir>/bin in my PATH. So can you check $QRC_HOME and $PATH to ensure they are correct?

    Andrew.

    • Post Points: 20
  • Tue, Sep 4 2012 1:16 AM

    • Aldo2
    • Top 200 Contributor
    • Joined on Mon, Aug 29 2011
    • Catania, Catania
    • Posts 43
    • Points 650
    Re: *WARNING* QRC_HOME environmental variable is set but UI can't locate correct QRC installation Reply

    Hi Andrew,

    I have found the error! It is not explained on CIW (only the message I wrote previously is shown on CIW), but in the pvsUI_ipvs.log file, created in the directory on which I run virtuoso.

    The error was caused by a missing library (GLIB_2.4) in the server I was using for my simulations.

    I'm wondering why the same message is not shown on CIW or why is not shown a message telling the user to open this file.

    Thank you

    Best Regards,

    Aldo

     

    • Post Points: 20
  • Tue, Sep 4 2012 2:25 AM

    Re: *WARNING* QRC_HOME environmental variable is set but UI can't locate correct QRC installation Reply

    Aldo,

    I agree, reporting every possible error in a way that is clear to the user is important - but sometimes it's hard to anticipate every possible error - and some things get missed when designing the software and testing it.

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by Aldo2 at 21 Aug 2012 02:43 AM. Topic has 3 replies.