Home > Community > Forums > Custom IC Design > almSetPropMappingList Usage Issue

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 almSetPropMappingList Usage Issue 

Last post Wed, Jun 27 2012 5:42 PM by gavinc. 3 replies.
Started by gavinc 27 Jun 2012 03:20 AM. Topic has 3 replies and 1236 views
Page 1 of 1 (4 items)
Sort Posts:
  • Wed, Jun 27 2012 3:20 AM

    • gavinc
    • Not Ranked
    • Joined on Wed, Mar 23 2011
    • Posts 2
    • Points 40
    almSetPropMappingList Usage Issue Reply

    Hi,

    I create my own simulation view and use ADE skill command almSetPropMappingList to setup its CDF property mapping field.

    I list my command as below.

    almSetPropMappingList(lib cell almGetPropMappingList(lib cell ?tool "hspiceD") ?view "hspiceD_subckt")

    This command works fine in IC615 and I can correctly change my instance parameter with above setting.

    However, the same command can't work in IC5141. Is this the limitation of IC5141?

     Gavin

    Filed under:
    • Post Points: 35
  • Wed, Jun 27 2012 4:47 AM

    Re: almSetPropMappingList Usage Issue Reply

    Gavin,

    I filed a CCR on this a while back, and it was fixed in IC614 - in all releases prior to that, the view-specific CDF settings for propMapping (as set by almSetPropMapping) were ignored during netlisting. So It's a limitation of IC5141, yes.

    Regards,

    Andrew.

    • Post Points: 5
  • Wed, Jun 27 2012 4:54 AM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,013
    • Points 15,455
    Re: almSetPropMappingList Usage Issue Reply

    Hi Gavin

    There was a bug with almSetPropMappingList and it was fixed in IC614. So unfortunately, it will not work with IC5141.


    Best regards
    Quek

    • Post Points: 5
  • Wed, Jun 27 2012 5:42 PM

    • gavinc
    • Not Ranked
    • Joined on Wed, Mar 23 2011
    • Posts 2
    • Points 40
    Re: almSetPropMappingList Usage Issue Reply

    Hi Andrew & Quek,

    Now I know it clearly. Thank you for your help.

    Gavin

     

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by gavinc at 27 Jun 2012 03:20 AM. Topic has 3 replies.