Home > Community > Forums > Custom IC SKILL > How to run Pnoise simulation with ocean

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 How to run Pnoise simulation with ocean 

Last post Tue, Dec 27 2011 4:42 AM by Andrew Beckett. 1 replies.
Started by yayla 26 Dec 2011 12:37 PM. Topic has 1 replies and 1602 views
Page 1 of 1 (2 items)
Sort Posts:
  • Mon, Dec 26 2011 12:37 PM

    • yayla
    • Top 150 Contributor
    • Joined on Tue, Jun 28 2011
    • Posts 48
    • Points 720
    How to run Pnoise simulation with ocean Reply

    Hi everyone,

    I have written an oceanscript to run pnoise. I am loading into CIW but I am getting "cannot handle (nil-0)" error in CIW window. After trying lots of things, I have directly saved the Spectre Oceanscript from ADE and tried to load it also but I have got same problem. Then, I have commented just the pnoise part which is below and everything is ok suspecting from pnoise since pnoise uses pss data to run. So do you know how to run pnoise using SKILL(Oceanscript)? Should I need to run first pss and then run pnoise in the same script after deleting analysis which is PSS by delete('analysis). BTW, I have checked forum but couldn't find how to run pnoise with ocean just found some threads like how to save pnoise summay like http://www.cadence.com/Community/forums/p/20842/1305382.aspx

    ;analysis('pnoise ?sweeptype "relative"  ?relharmnum "3"  ?start "1K" 
    ;        ?stop "1G"  ?dec "100"  ?maxsideband "24"  ?p "/I176/DIV2P" 
    ;        ?n "/I176/DIV2N"  ?annotate "status"  )

     

    Thanks,

    yayla

    Filed under: ,
    • Post Points: 20
  • Tue, Dec 27 2011 4:42 AM

    Re: How to run Pnoise simulation with ocean Reply

    Yayla,

    There's nothing particularly special you should need to do. You would need to have the pss and pnoise analyses enabled at the same time, because the pnoise analysis must run after the pss in the same invocation of the simulator.

    What subversion are you using (of both virtuoso/ocean and spectre?). In virtuoso/ocean you can type getVersion(t) to retrieve this; for spectre it will be in the output log.

    Maybe you can share the entire OCEAN script? Maybe you can show the corresponding analysis statements from the bottom of the input.scs? Where exactly does the error occur (i.e. what is it doing at the time)? (some context would help here). 

    There was a problem in the past with using hierarchical (i.e. not top level) nodes for the positive/negative outputs from pnoise, but I think that was solved quite some time ago.

    Best Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (2 items)
Sort Posts:
Started by yayla at 26 Dec 2011 12:37 PM. Topic has 1 replies.