Home > Community > Forums > PCB Design > Capture CIS_Show Footprint

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Capture CIS_Show Footprint 

Last post Tue, Nov 26 2013 1:32 AM by steve. 19 replies.
Started by engineer123 31 Oct 2011 07:25 PM. Topic has 19 replies and 8397 views
Page 1 of 2 (20 items) 1 2 Next >
Sort Posts:
  • Mon, Oct 31 2011 7:25 PM

    • engineer123
    • Not Ranked
    • Joined on Thu, Nov 11 2010
    • Kingsport, TN
    • Posts 5
    • Points 100
    Capture CIS_Show Footprint Reply
    Can someone explain how I can set the correct paths for my symbol library so that I can view footprints inside capture. I have set the psmpath to the folder where my .psm and .dra files are located in the environment editor. However, when I select my part and choose show footprint I get an error stating allegro footprint not found in search path or something to that nature. However, if I use a symbol from the discrete capture library like a resistor and then select a footprint located in the cadence/..../share/pcb/pcb_lib/symbols folder it works. Are my libraries not set correctly even though I can place parts manually in pcb editor or is their something else I am missing. Thank you
    • Post Points: 50
  • Tue, Nov 1 2011 12:37 AM

    • girish
    • Top 25 Contributor
    • Joined on Wed, Jul 16 2008
    • Bangalore, Karnataka
    • Posts 241
    • Points 4,920
    Re: Capture CIS_Show Footprint Reply

     *Keep all footprints in one folder (.dra .psm .pad ..etc)

    *Give the folder path in in padpath & psmpath 

    Regards,

    Girish 


    • Post Points: 20
  • Tue, Nov 1 2011 5:19 AM

    • DawnC
    • Top 200 Contributor
    • Joined on Wed, Oct 27 2010
    • Posts 38
    • Points 655
    RE: Capture CIS_Show Footprint Answer Reply
    You can set your paths inside your CAPTURE.INI file, you can multiple paths.  Here is an example:

     

    [Part Management]

    Configuration File=C:\CADENCE\SPB_16.3\TOOLS\CAPTURE\MAVRK.DBC

    [Footprint Viewer Type]

    Type=Allegro

    [Allegro Footprints]

    Dir0=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\CONNECTOR

    Dir1=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\CRYSTALS

    Dir2=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\DISCRETE

    Dir3=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\FAB&SILK

    Dir4=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\HEADER

    Dir5=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\IC

    Dir6=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\MECHANICAL

    Dir7=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\RF

    Dir8=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\SOCKET

    Dir9=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\SPECIALTY

    Dir10=C:\PCB_LIBRARY\CADENCE\CADENCE_LIBRARY_GOLDEN\FOOTPRINT\SWITCH
    • Post Points: 50
  • Tue, Nov 1 2011 1:48 PM

    • engineer123
    • Not Ranked
    • Joined on Thu, Nov 11 2010
    • Kingsport, TN
    • Posts 5
    • Points 100
    Re: RE: Capture CIS_Show Footprint Reply
    Yes, changing the .ini file works. Is this a workaround or is this how it is supposed to be done. Just curious.
    • Post Points: 5
  • Wed, Nov 2 2011 5:01 AM

    • DawnC
    • Top 200 Contributor
    • Joined on Wed, Oct 27 2010
    • Posts 38
    • Points 655
    RE: RE: Capture CIS_Show Footprint Reply
    As far as I know, this is how you set it up.  I found out how to set up multiple directories digging through support.
    • Post Points: 5
  • Thu, Jan 17 2013 5:24 AM

    • NicoDD
    • Top 500 Contributor
    • Joined on Mon, Oct 3 2011
    • Posts 17
    • Points 235
    Re: RE: Capture CIS_Show Footprint Reply

    I've set my Capture.ini file as follow:

    [Part Management]
    Configuration File=$CDSROOT\tools\Capture\Samples\BENCHACC.DBC
    DemoConfiguration File=$CDSROOT\tools\Capture\Samples\DemoBENCHACC.DBC
    [Footprint Viewer Type]
    Type=Allegro
    [Allegro Footprints]
    Dir0=C:\Cadence\SPB_16.6\share\pcb\pcb_lib\symbols
    Dir1=C:\SincronieGroove\Hardware_2\_DDLibrary\symbols
    [Symbol Selector Configured Libraries]
    Library0=C:\Cadence\SPB_16.6\tools\Capture\Library\PSpice\source.olb
    Number of Configured Libraries=1

    but I can see only the footprint present in the first path (directory number zero, as default) and I coulden't see the footèprint in my own directory.

    Can someone help me? Thanks

    • Post Points: 5
  • Thu, Jan 17 2013 5:24 AM

    • NicoDD
    • Top 500 Contributor
    • Joined on Mon, Oct 3 2011
    • Posts 17
    • Points 235
    Re: RE: Capture CIS_Show Footprint Reply

    I've set my Capture.ini file as follow:

    [Part Management]
    Configuration File=$CDSROOT\tools\Capture\Samples\BENCHACC.DBC
    DemoConfiguration File=$CDSROOT\tools\Capture\Samples\DemoBENCHACC.DBC
    [Footprint Viewer Type]
    Type=Allegro
    [Allegro Footprints]
    Dir0=C:\Cadence\SPB_16.6\share\pcb\pcb_lib\symbols
    Dir1=C:\SincronieGroove\Hardware_2\_DDLibrary\symbols
    [Symbol Selector Configured Libraries]
    Library0=C:\Cadence\SPB_16.6\tools\Capture\Library\PSpice\source.olb
    Number of Configured Libraries=1

    but I can see only the footprint present in the first path (directory number zero, as default) and I coulden't see the footèprint in my own directory.

    Can someone help me? Thanks

    • Post Points: 20
  • Thu, Jan 17 2013 7:05 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,173
    • Points 19,025
    Re: RE: Capture CIS_Show Footprint Reply

    Is the path a valid directory ? What happens if you swap them round ? Also check the session log in Capture, it normally has a log of if there are any issues with paths or footprints.

    • Post Points: 20
  • Thu, Jan 17 2013 8:03 AM

    • NicoDD
    • Top 500 Contributor
    • Joined on Mon, Oct 3 2011
    • Posts 17
    • Points 235
    Re: RE: Capture CIS_Show Footprint Reply

    Hello Steve,

    the path is valid and the footprint is ok. I try also to put temporarily a copy of a footprint from the DIR 0 in the DIR 1 path and it works.

    When I select "Show Footprint" command I recived this message in the Session Log:

    ERROR(ORCAP-1733): Allegro footprint SW_DPDT_1 was not found in the search path

    where "SW_DPDT_1" is the name of my footprint.

    thanks for your help

    • Post Points: 20
  • Thu, Jan 17 2013 8:12 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,173
    • Points 19,025
    Re: RE: Capture CIS_Show Footprint Reply

    The ini file settings are for Capture CIS so you can see the footprint. If you want to use RMB - Show Footprint then this takes the settings defined in the %HOME%\pcbenv folder. Start PCB Editor, go to Setup - User Preferences - Paths - Library and define the psmpath so that it points to your Dir1 location (as well as the defaults). Then you should be able to see the footprints.

    • Post Points: 20
  • Thu, Jan 17 2013 8:34 AM

    • NicoDD
    • Top 500 Contributor
    • Joined on Mon, Oct 3 2011
    • Posts 17
    • Points 235
    Re: RE: Capture CIS_Show Footprint Reply

    I had already defined this property, but still don't work... I'm don't know why...

    I've in the psmpath Items also:

    C:/SincronieGroove/Hardware_2/_DDLibrary/symbols

    • Post Points: 5
  • Sat, Jan 19 2013 1:37 AM

    • NicoDD
    • Top 500 Contributor
    • Joined on Mon, Oct 3 2011
    • Posts 17
    • Points 235
    Re: RE: Capture CIS_Show Footprint Reply

    nobody have other ideas?

    Thanks

    • Post Points: 5
  • Mon, Jan 21 2013 8:39 AM

    • NicoDD
    • Top 500 Contributor
    • Joined on Mon, Oct 3 2011
    • Posts 17
    • Points 235
    Re: RE: Capture CIS_Show Footprint Reply
    ok, I found how to do: I have two "capture.ini" file, which is loaded at startup qeullo Capture is in the position:

    C: \ SPB_Data \ cdssetup \ OrCAD_Capture \ 16.6.0

    just enter in place in the correct path
    • Post Points: 5
  • Thu, Nov 21 2013 12:27 AM

    • PHMISTRY
    • Not Ranked
    • Joined on Thu, Nov 21 2013
    • Posts 8
    • Points 115
    Re: Capture CIS_Show Footprint Reply
     
    Hello...........
    Dear sir In my cadence 16.5 ,I can't seen a footprint ..........
    Given Error is ERROR(ORCAP-1732): Could not retrieve PCB Footprint property. Unable to show footprint in viewer.........

    Please Send us Its solution.........We are looking a forward from your side.......... 
     
    I am already upload the  deatail from the envoirment all the things..........
    • Post Points: 20
  • Thu, Nov 21 2013 1:18 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,173
    • Points 19,025
    Re: Capture CIS_Show Footprint Reply

    This error indicates that you do not have a part defined for the PCB Footprint property. Select the part and use rmb - edit properties (or double click). You'll see the properties for the part. Locate the PCB Footprint property and add a name for a footprint that matches the pcb footprint in the paths specified like 0603, soic8 etc.

    • Post Points: 35
Page 1 of 2 (20 items) 1 2 Next >
Sort Posts:
Started by engineer123 at 31 Oct 2011 07:25 PM. Topic has 19 replies.