Home > Community > Forums > PCB Design > Extra component on board

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Extra component on board 

Last post Wed, Apr 27 2011 8:34 AM by Randy R. 3 replies.
Started by comet 25 Apr 2011 11:21 PM. Topic has 3 replies and 1534 views
Page 1 of 1 (4 items)
Sort Posts:
  • Mon, Apr 25 2011 11:21 PM

    • comet
    • Top 500 Contributor
    • Joined on Tue, Apr 26 2011
    • Paranaque, Philippines
    • Posts 17
    • Points 205
    Extra component on board Reply

    Hey guys, is there any basic or special way of spotting (checking) extra component/s on board?... (meaning those parts that don't really included on the design...maybe accidentally copied or placed)

    Filed under: ,
    • Post Points: 20
  • Tue, Apr 26 2011 8:03 AM

    • Randy R
    • Top 50 Contributor
    • Joined on Wed, Jul 16 2008
    • Dupont, WA
    • Posts 193
    • Points 3,060
    Re: Extra component on board Reply

    Using Allegro's definitions; there shouldn't be extra components, but there may be extra symbols.

    To find extra symbols:

    Zoom out so you can see the whole board then turn on pins for all layers.  Using the highlight (assign color) command with the find filter set only to "Symbols", window around the board to highlight all symbols(with pins) in the design.  Then using the dehighlight command with the find filter set only to "Comps", window around the board to dehilight all components in the design.  The remaining highlighted symbols aren't in the schematic (although they could be symbols you want to keep like tooling holes, fiducials, etc.).

    Hope this helps.

    Good Day, R².
    • Post Points: 20
  • Tue, Apr 26 2011 8:39 PM

    • comet
    • Top 500 Contributor
    • Joined on Tue, Apr 26 2011
    • Paranaque, Philippines
    • Posts 17
    • Points 205
    Re: Extra component on board Reply

    Thanks for the reply. But I couldn't perform the latter part for the Comps in Find Filter is inactive during the Dehilight command. Any idea why...or how ?

    • Post Points: 20
  • Wed, Apr 27 2011 8:34 AM

    • Randy R
    • Top 50 Contributor
    • Joined on Wed, Jul 16 2008
    • Dupont, WA
    • Posts 193
    • Points 3,060
    Re: Extra component on board Reply

    Whoops, my mistake.  When dehighlighting; set the Find Filter to symbols then in the Find By Name section select "Symbol (or Pin)" , "Name", and enter "*" in the text box.

    Good Day, R².
    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by comet at 25 Apr 2011 11:21 PM. Topic has 3 replies.