Home > Community > Forums > Custom IC Design > Bad Java version for installscape updating

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Bad Java version for installscape updating 

Last post Thu, Oct 13 2011 3:33 PM by rwoods. 5 replies.
Started by Sindy 14 Apr 2011 08:15 AM. Topic has 5 replies and 2967 views
Page 1 of 1 (6 items)
Sort Posts:
  • Thu, Apr 14 2011 8:15 AM

    • Sindy
    • Not Ranked
    • Joined on Thu, Apr 7 2011
    • Posts 11
    • Points 205
    Bad Java version for installscape updating Reply

    Hi Everyone,

     I just updated installscape from version 3.xxx to the latest one (4. xxx) sucessfully. But when I run it, error coming out complaining my Java version. Have any of you been there before? The error information is:

    [cdsmgr@ee207 iscape]$ iscape/bin/iscape.sh
    Initializing InstallScape using JVM at /home/cdsmgr/Desktop/iscape/iscape/runtime/LNX86/bin/java. This might take some time...Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
            at java.lang.ClassLoader.defineClass1(Native Method)
            at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
            at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
            at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
            at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
            at java.security.AccessController.doPrivileged(Native Method)
            at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
            at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
            at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)
     

     Thanks

    • Post Points: 50
  • Thu, Apr 14 2011 10:04 AM

    Re: Bad Java version for installscape updating Reply

    There are no reports of this error either. It seems extremely odd, because InstallScape should be using (and appears to be using) the Java installation that comes with InstallScape. So since the java and the classes are from the same installation, it seems very odd that it should fail in this way.

    I'm wondering whether you are getting strange problems due to (say) using ftp to transfer files across from Windows to Linux (and doing so in ASCII mode) so that files are getting corrupted? Or maybe you have some odd file system that is being used. The symptoms you keep hitting seem rather unique - so it's hard to see what is unusual about your scenario. As I said before, contacting customer support is definitely the wisest thing to do here.

    Regards,

    Andrew.

    • Post Points: 5
  • Tue, Jun 21 2011 7:09 AM

    • ebecheto
    • Top 200 Contributor
    • Joined on Fri, Oct 10 2008
    • Villeurbanne, Rhone
    • Posts 39
    • Points 705
    Re: Bad Java version for installscape updating Reply

     I got the same trouble.

    Did you find any clues ?

     Remark :  MMSIM7.2 Hotfix forces to update iscape, but iscape then failed with the same error message you gave ...

     

    Regards

    • Post Points: 35
  • Tue, Jun 21 2011 7:15 AM

    • Tawna
    • Top 25 Contributor
    • Joined on Fri, Jul 11 2008
    • Snohomish, WA
    • Posts 208
    • Points 5,500
    Re: Bad Java version for installscape updating Reply

     Hi ebechto,

     

    Have you tried calling Cadence Customer Support?  That is the appropriate course of action.

     

    best regards,

    Tawna

    Best regards, Tawna Wilsey Staff Support AE, Global Customer Support Cadence Design Systems, Inc.
    Filed under:
    • Post Points: 5
  • Tue, Jun 21 2011 2:24 PM

    • Sindy
    • Not Ranked
    • Joined on Thu, Apr 7 2011
    • Posts 11
    • Points 205
    Re: Bad Java version for installscape updating Reply
    What we did last time was updating the Java, using the newest version of iscape, and re-installing the IC6.15. Hope this can help you.
    • Post Points: 5
  • Thu, Oct 13 2011 3:33 PM

    • rwoods
    • Not Ranked
    • Joined on Sat, Jan 16 2010
    • Posts 1
    • Points 5
    Re: Bad Java version for installscape updating Reply
    This is a known issue as mentioned in the following solution. 11694620: http://support.cadence.com/wps/mypoc/cos?uri=deeplinkmin:ViewSolution;solutionNumber=11694620 To resolve the issue, download and install the InstallScape 4.x tarkit from http://downloads.cadence.com
    • Post Points: 5
Page 1 of 1 (6 items)
Sort Posts:
Started by Sindy at 14 Apr 2011 08:15 AM. Topic has 5 replies.