Home > Community > Forums > Custom IC Design > Abstract Generator Crash!!

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Abstract Generator Crash!! 

Last post Tue, Mar 15 2011 9:47 AM by Andrew Beckett. 3 replies.
Started by eklikeroomys 11 Mar 2011 04:13 AM. Topic has 3 replies and 2707 views
Page 1 of 1 (4 items)
Sort Posts:
  • Fri, Mar 11 2011 4:13 AM

    • eklikeroomys
    • Top 150 Contributor
    • Joined on Fri, Mar 11 2011
    • Pretoria, South Africa
    • Posts 55
    • Points 815
    Abstract Generator Crash!! Reply
    Halo, I'm using Cadence Abstract Editor to create an abstract view of a standard digital cell. The power rails of the cell consists of Metal 1 layer. When I add the Metal 1 layer to the Extract Power Nets Table and tick the create pins box in the Running Step Extract Form, I click on Run and the Extract Step executes successfully. However, when I run the Abstract Step after completing the Extract Step as explained, the tool crashes and exits. I then decided to disable the Extract Power Net option in the Running Step Extract Form, but this causes the tool to crash an exit when I Run the Abstract Step as well. Has anyone had similar problems or found a fix for this problem?
    • Post Points: 5
  • Mon, Mar 14 2011 6:13 AM

    • eklikeroomys
    • Top 150 Contributor
    • Joined on Fri, Mar 11 2011
    • Pretoria, South Africa
    • Posts 55
    • Points 815
    Power Net Extraction Problem in Abstract Generator Reply
    Halo, I am creating abstract cell views for a digital standard cell library using Cadence Abstract Generator.I have the following problem: In the Extract Step, I set the tool up to extract signal and power nets and to create pins on metal 1 so that my abstract view will keep its connectivity. The extract step executes with no problems. When I execute the Abstract Step thereafter, the tool crashes and exits. I have found that when I disable the create pins button on Metal 1 in the Extract power nets table (From Extract Step), the Abstract Step works fine. This is cool, but it means that my power nets have no connectivity, and causes overlap errors in the Verify Step because of the power rails from adjacent cells overlapping, which shouldn't be an issue. (The power rails of the standard cell library slightly overlaps the place-and-route boundary.) Another thing that I noticed is that Metal 1 is the only layer that causes this tool crash. Can anyone please help me I have no idea how to fix this?
    • Post Points: 5
  • Mon, Mar 14 2011 6:32 AM

    • eklikeroomys
    • Top 150 Contributor
    • Joined on Fri, Mar 11 2011
    • Pretoria, South Africa
    • Posts 55
    • Points 815
    Power Net Extraction Problem in Abstract Generator Reply
    Halo, I am creating abstract cell views for a digital standard cell library using Cadence Abstract Generator.I have the following problem: In the Extract Step, I set the tool up to extract signal and power nets and to create pins on metal 1 so that my abstract view will keep its connectivity. The extract step executes with no problems. When I execute the Abstract Step thereafter, the tool crashes and exits. I have found that when I disable the create pins button on Metal 1 in the Extract power nets table (From Extract Step), the Abstract Step works fine. This is cool, but it means that my power nets have no connectivity, and causes overlap errors in the Verify Step because of the power rails from adjacent cells overlapping, which shouldn't be an issue. (The power rails of the standard cell library slightly overlaps the place-and-route boundary.) Another thing that I noticed is that Metal 1 is the only layer that causes this tool crash. Can anyone please help me I have no idea how to fix this?
    • Post Points: 20
  • Tue, Mar 15 2011 9:47 AM

    Re: Power Net Extraction Problem in Abstract Generator Reply

    I have merged all three duplicate questions together into a single thread. Please don't cross-post on multiple forums as it causes confusion and duplication of effort from what is a volunteer base in the community.

    I think you will need to contact customer support on http://support.cadence.com for more assistance. Maybe if you gave the version of the Abstract generator that you're using, somebody might be able to find if this is a known issue; maybe trying the latest version of the Abstract Generator might be wise too.

    Regards,

    Andrew.

    • Post Points: 5
Page 1 of 1 (4 items)
Sort Posts:
Started by eklikeroomys at 11 Mar 2011 04:13 AM. Topic has 3 replies.