Home > Community > Forums > PCB Design > OrCAD Capture 16.3 hangs on load

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 OrCAD Capture 16.3 hangs on load 

Last post Sun, Jul 27 2014 10:29 AM by IceCube. 10 replies.
Started by DrLightning 20 Oct 2010 07:26 AM. Topic has 10 replies and 13480 views
Page 1 of 1 (11 items)
Sort Posts:
  • Wed, Oct 20 2010 7:26 AM

    OrCAD Capture 16.3 hangs on load Reply
    My OrCAD Capture 16.3 just quit working. When I load the program, I first see the version and copyright splash screen in the center of my primary monitor. Less than one second later, The main window begins to appear on my secondary monitor. With no delay, and perhaps before the main window appears, one of my dual core processor cores goes to 100% CPU usage (overall 50% CPU usage) and stays there. Meanwhile, the main window, which was only title bar and frame with old graphics still in the middle, repaints with all white and stays all white. A small "Footprint Viewer" window also appears with all white body.

    During all of this, if I move the task manager around on the two white windows, they do repaint. At least, their frames do. One couldn't tell if the white repaints. However, the splash screen on the other monitor is still up, and it does NOT repaint as I move the task manager across the face of it.

    *Immediately* prior to this problem, I was running OrCAD Capture CIS, which I had run many times since it was installed over a month ago. I tried to generate a netlist, and got an error about invalid characters in the path. I closed the current project, and tried to rename the folder tree containing the project. Windows Explorer couldn't rename because some file in the tree was locked by some program. I believe OrCAD PCB Editor was also running. I closed both OrCAD programs and tried to rename again. I still couldn't rename. I decided to leave the folder names as they were, and created a new folder with a short name and no special chars. Then, I loaded OrCAD Capture again and had this problem.

    OrCAD Capture should NOT be automatically opening my project or anything, and I did NOT in the end rename anything. Therefore, my actions shouldn't have led to a condition causing this hang. The closest connection at all is the MRU (most recently used list). But since I didn't actually rename anything, that shouldn't be a cause, either.

    I have no clue why the program suddenly started doing this.

    Note that when I cancel it by either clicking on the red X in the top right corner, or cancelling it with the task manager, it does take a few seconds but otherwise cancels willingly. It's not like some other programs when they hang, where you get the question about the task not ending and cancelling it now.

    Also, two line items appear in the Applications tab of the task manager, both for OrCAD Capture with status "Not Responding".

    Any and all reasonable advice on this is greatly appreciated. Note that I have tried rebooting and loading with no other programs working. I have not yet tried to reinstall.

    • Post Points: 20
  • Wed, Oct 20 2010 9:31 AM

    • oldmouldy
    • Top 10 Contributor
    • Joined on Tue, Jul 15 2008
    • Woking, Surrey
    • Posts 1,415
    • Points 24,185
    Re: OrCAD Capture 16.3 hangs on load Answer Reply

    Make sure that you have any Capture related processes closed, a reboot should get you there. Find the active Capture.ini file, usually in the installation in tools\Capture and rename it. Start Regedit.exe, find the HKEY_CURRENT_USER\Software\OrCAD\CaptureWorkspace key and delete it and the subkeys that belong to it, then close regedit and see if that fixes things. Get the latest hotfix.

    • Post Points: 65
  • Wed, Oct 20 2010 12:24 PM

    Re: OrCAD Capture 16.3 hangs on load Reply
    Thanks. Fixed it. Did ini rename and regedit delete. Hadn't gotten to hotfixes yet, but tested and problem fixed.
    • Post Points: 20
  • Wed, Dec 1 2010 8:43 AM

    • bmccarty12
    • Not Ranked
    • Joined on Wed, Dec 1 2010
    • Posts 1
    • Points 20
    Re: OrCAD Capture 16.3 hangs on load Reply

    We had an XP machine running 16.2 fine. Installed 16.3 into a new directory and it wouldn't load. Removed everything, 16.2 and 16.3 then reinstalled 16.3. Still has the same problem, when I launch orcad cis the first time it never loads. I can see the capture.exe process running in taskmgr, it grabs 50% of the CPU and will hold that for at least several hours without ever fully loading.

    I tried renaming the capture.ini file and deleting that registry key also, but still no luck.

     

     Any other options to try on this ?

    • Post Points: 20
  • Fri, Apr 6 2012 6:21 AM

    Re: OrCAD Capture 16.3 hangs on load Reply

    Me too.  OrCAD Capture 16.3-p008 was working fine.  All of a sudden, when I loaded it again, I would get the splash screen.  A moment later the splash screen would go away, but the program window never came up.  On Windows 7 when I mouse over OrCAD Capture on the task bar, I would get a short window with the program name in it, rather than a thumbnail of the main window -- I think this means the main window wasn't created yet, much less displayed.  Task Manager showed the program, but not as "Not Responding".  The program easily exited from task bar close window option on popup.

    I renamed Capture.ini and the program began working again.

    Yep, very buggy... 

    • Post Points: 5
  • Fri, Dec 28 2012 2:59 AM

    • Ponjovi
    • Not Ranked
    • Joined on Fri, Dec 28 2012
    • Posts 1
    • Points 20
    Re: OrCAD Capture 16.3 hangs on load Reply

    Hello,

    I fell and was also needed for the same situation. 

    However, your reply was seen and the problem was solved. 

    I only exported and performed the contents of registry from another personal computer with which OrCAD16.3 operates normally. 

    Thank you. 

    • Post Points: 20
  • Fri, Jan 4 2013 7:51 AM

    • Wild
    • Top 200 Contributor
    • Joined on Tue, Sep 9 2008
    • Reading, PA
    • Posts 43
    • Points 500
    Re: OrCAD Capture 16.3 hangs on load Reply

     I have a ticket in on this since 8/24/2011

    Ticket number: 42991072

    It happens in 16.3, and 16.5 but have not seen it 16.6, yet.

    Here's how I fix it (Instructions from cadence support):

    Normal 0 false false false EN-US X-NONE X-NONE MicrosoftInternetExplorer4

    a. Go to task manager and see if any cadence process (capture.exe, cdsMsgServer.exe, cdsNameServer.exe) is running. If so please kill it manually.

    b. Go to Start > Type regedit. This opens registry editor

                   c. Now locate and delete 16.3 key located at HKEY_CURRENT_USER\Software\OrCAD\CaptureWorkSpace

     

    Once this is done the problem will only come back after I do a hotfix.

    Hopely Cadence will figure this out.

     

    • Post Points: 20
  • Wed, Jan 9 2013 1:55 PM

    • Wild
    • Top 200 Contributor
    • Joined on Tue, Sep 9 2008
    • Reading, PA
    • Posts 43
    • Points 500
    Re: OrCAD Capture 16.3 hangs on load Reply

     Recieved an update from the cadence support team:

    CCR#1050230 associated with SR# 42991072 is still in Planned state, means it was not fixed in current ISR.

    Normal 0 false false false EN-US X-NONE X-NONE MicrosoftInternetExplorer4

    • Post Points: 5
  • Wed, Jan 9 2013 6:44 PM

    • redwire
    • Top 10 Contributor
    • Joined on Wed, Jul 16 2008
    • Allen, TX
    • Posts 878
    • Points 13,525
    Re: OrCAD Capture 16.3 hangs on load Reply

     I have a simpler method (since this has happened in 16.2 as well)

    1.  Buy new hard drive

    2.  Reinstall XP

    3.  Wait 4-6 hours for XP & updates to finish

    4. Reinstall all old programs (2-3 days)

    5. Reinstall Cadence libraries, custom ones, not the ones that come with Allegro that we all throw away

    6. Reinstall Cadence (2-3 hrs)

    7. Run

     

    Your method might work but mine is guaranteed!

    (This is just smart alec joke but it does document how I had to fix mine)

    • Post Points: 5
  • Fri, Jun 21 2013 1:51 AM

    • Bhoja
    • Not Ranked
    • Joined on Thu, Apr 4 2013
    • Bangalore, Karnataka
    • Posts 9
    • Points 235
    Re: OrCAD Capture 16.3 hangs on load Reply

    Wow............Wonderful..............This works Greats

     

     Thank you very much oldmouldy :-)

    Bhojaraj Gangolli.
    • Post Points: 5
  • Sun, Jul 27 2014 10:29 AM

    • IceCube
    • Not Ranked
    • Joined on Sun, Jul 27 2014
    • Posts 6
    • Points 60
    Re: OrCAD Capture 16.3 hangs on load Reply
    Thanks, I just followed oldmouldy's instruction and my problem solved. I don't know if it is important, but I renamed the "Capture.ini" back to its original name, after my problem solved.
    • Post Points: 5
Page 1 of 1 (11 items)
Sort Posts:
Started by DrLightning at 20 Oct 2010 07:26 AM. Topic has 10 replies.