Home > Community > Forums > Custom IC Design > Spectre simulation error

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Spectre simulation error 

Last post Thu, Oct 4 2012 5:17 AM by KD353. 8 replies.
Started by CCH01 22 Jun 2010 04:10 AM. Topic has 8 replies and 6856 views
Page 1 of 1 (9 items)
Sort Posts:
  • Tue, Jun 22 2010 4:10 AM

    • CCH01
    • Not Ranked
    • Joined on Tue, Jun 22 2010
    • Posts 6
    • Points 105
    Spectre simulation error Reply

    Hello everyone~
    I just install MMSIM7.1 with IC5141_USR6 and try to simulation a simple circuit, but when I finish all settings
    go "netlist and run". It stopped at CIW and showed the following message
    "errors encountered during simulation. the simulator run log has not been generated. Possible
    cause could be an invalid command line option for the version of the simulator you are
    running. choose setup ->environment and verify that the command line option specified in
    the userCmdLineOption field are supported for the simulator.
    Alternatively run the simulator standalone using the runSimulation file in the netlist
    directory to know the exact cause of the error."

    and then I run the runsimulation and get a message
    "/usr/cad/cadence/MMSIM/cur/tools.lnx86/spectre/bin/32bit/spectre: error while loading shared libraries: libelf.so.1: cannot open shared object file: No such file or directory"
    I don't know how to fix this problem. I probably made some mistakes at somewhere.
    Please give me some advise !!

    • Post Points: 20
  • Tue, Jun 22 2010 5:41 AM

    • tkhan
    • Top 50 Contributor
    • Joined on Sat, Aug 16 2008
    • Toronto, Ontario
    • Posts 159
    • Points 2,220
    Re: Spectre simulation error Reply

    # rpm -qa | grep elfutils

    If elfutils is installed, add it to your library path, otherwise refer to this post: http://www.cadence.com/Community/forums/p/14360/24264.aspx#24264 (except search for the shared object you need)

    • Post Points: 50
  • Tue, Jun 22 2010 8:24 PM

    • CCH01
    • Not Ranked
    • Joined on Tue, Jun 22 2010
    • Posts 6
    • Points 105
    Re: Spectre simulation error Reply

    Hi tkhan~thank you for your help!!

    I have fixed the libelf.so.1 problem!!

    But, there is another problem when I Exit CIW my terminal windows will show " libgcc_s.so.1 must be installed for pthread_cancel to work", is it ignorable ?

    How can I fix this problem?

    Best Regards

    • Post Points: 20
  • Tue, Jun 22 2010 10:57 PM

    Re: Spectre simulation error Reply
    The pthread_cancel error is one I have usually seen from people running the Mentor Calibre integration.

    We have an internal solution which says:

    The workaround suggested by Mentor is to add "/lib/i686" into $LD_LIBRARY_PATH.

    If indeed you are using the calibre integration and this does not solve it, you should contact Mentor for support to resolve this.

    Best regards,

    Andrew
    • Post Points: 20
  • Wed, Jun 23 2010 5:06 AM

    • CCH01
    • Not Ranked
    • Joined on Tue, Jun 22 2010
    • Posts 6
    • Points 105
    Re: Spectre simulation error Reply

    Hi Andrew~~thank you for your advice.

    Your experience is very useful~~~ 

    I can use the program normally now!!!

    Best Regards

    • Post Points: 5
  • Tue, Sep 21 2010 7:14 AM

    • pecola
    • Not Ranked
    • Joined on Tue, Sep 21 2010
    • Posts 3
    • Points 45
    Re: Spectre simulation error Reply

    Hi,

    I'm trying to run Cadence 5.1.41 Analog environment on CentOS 5.5. I have got the following message error running spectre

    /home/User/Cadence5.1.41/MMSIM7.11/tools.lnx86/spectre/bin/32bit/spectre: error while loading shared libraries: libelf.so.1: wrong ELF class: ELFCLASS64

    Please, could you explain how to fix it?

    • Post Points: 20
  • Tue, Sep 21 2010 6:12 PM

    Re: Spectre simulation error Reply

     It's probably just picking up the 64 bit version of libelf.so.1 (which is in /usr/lib64) (maybe you have $LD_LIBRARY_PATH including that directory) but you'll need the 32 bit version of this library. On my machine:

    UNIX> rpm -q -f /usr/lib/libelf.so.1
    elfutils-libelf-0.125-3.el5.i386

    Note that CentOS 5.5 is not a supported distribution and so no testing has been done on it, and no patch data files are provided for it either.

    Regards,

    Andrew.

    • Post Points: 20
  • Wed, Sep 22 2010 1:04 AM

    • pecola
    • Not Ranked
    • Joined on Tue, Sep 21 2010
    • Posts 3
    • Points 45
    Re: Spectre simulation error Reply

     Yes, you're right.

    I fixed it!

    Thank you

    • Post Points: 5
  • Thu, Oct 4 2012 5:17 AM

    • KD353
    • Not Ranked
    • Joined on Wed, Oct 3 2012
    • Posts 1
    • Points 5
    Re: Spectre simulation error Reply

    Hi tkhan,

    I also have issue with "libelf.so.1"

    "error while loading shared libraries: libelf.so.1: cannot open shared object file: No such file or directory" 

    I dont have "libelf.so.1 inside /usr/lib. Then I did what you have said: 

         # ~> rpm -qa | grep elfutils

         elfutils-0.137-8.22.58

    Does this result means that I have it on my system. How should I add it on my library path? (I'm using SUSE by the way)

    Kindly help me..

    Thanks!!! 

    • Post Points: 5
Page 1 of 1 (9 items)
Sort Posts:
Started by CCH01 at 22 Jun 2010 04:10 AM. Topic has 8 replies.