Home > Community > Forums > PCB Design > Database Error while Generating Artwork

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Database Error while Generating Artwork 

Last post Tue, Jun 1 2010 11:37 AM by melview1. 4 replies.
Started by melview1 28 May 2010 02:42 PM. Topic has 4 replies and 3446 views
Page 1 of 1 (5 items)
Sort Posts:
  • Fri, May 28 2010 2:42 PM

    • melview1
    • Top 200 Contributor
    • Joined on Wed, May 20 2009
    • Shakopee, MN
    • Posts 44
    • Points 815
    Database Error while Generating Artwork Reply

    I'll start from the beginning:

    - I was working in a design and OrCAD PCB Designer crashed saying "Orcad has encountered an error and needs to close."  or something to that effect.  Then I clicked ok and the program shut down.

    - I opened it back up and continued to work.  Everything seemed ok.

    - I went to generate my artwork only to find out I can't because there is a database error.

    - I check dbdoctor.log and it says "Error in Attribute     Pointer to Void Invalid", 1 error could be fixed

    - I do a database check (including regenerating DRC errors) and it reports that 2 errors were fixed, both referencing the same error message above.

    - Sounds like I should be good to go, but when I try to generate the artwork again, I get the same error message and the cycle continues

    I've tried deleting all files in the directory except the brd file with no help.  I've tried moving directories and deleting all files, no help.

    Anyone have any suggestions?

     

    --Mark

    • Post Points: 20
  • Sat, May 29 2010 3:51 AM

    • girish
    • Top 25 Contributor
    • Joined on Wed, Jul 16 2008
    • Bangalore, Karnataka
    • Posts 241
    • Points 4,920
    Re: Database Error while Generating Artwork Reply

     Hi,

    when you run the database check you will get a  view log file ,get the xy cordinate of the error which is fixed .& then try to do some manual void in that area .

    Regards 

    Girish Kumar

    • Post Points: 20
  • Sat, May 29 2010 5:45 PM

    • melview1
    • Top 200 Contributor
    • Joined on Wed, May 20 2009
    • Shakopee, MN
    • Posts 44
    • Points 815
    Re: Database Error while Generating Artwork Reply
    I thought that as well, but there are no coordinates in the log file, just the two sentences in my original post. Any other thoughts?
    • Post Points: 20
  • Tue, Jun 1 2010 11:30 AM

    • kanonfodder
    • Top 500 Contributor
    • Joined on Mon, Oct 20 2008
    • New Haven, CT
    • Posts 35
    • Points 550
    Re: Database Error while Generating Artwork Reply

     I've had similar things happen like that.  I run DB Doctor, but that doesn't show anything.  I still won't be able to generate my artwork, but if I do each layer individually one at a time it will work, and then from that point on I can generate multiple films at once.

    • Post Points: 20
  • Tue, Jun 1 2010 11:37 AM

    • melview1
    • Top 200 Contributor
    • Joined on Wed, May 20 2009
    • Shakopee, MN
    • Posts 44
    • Points 815
    Re: Database Error while Generating Artwork Reply

    Update:

    I moved on to another design and got to the point of generating the artwork and got the same error.  I then tried the artwork generation on another computer and it worked.  It seems to be a problem with the OrCAD installation on my PC.

    At the advise of EMA Design Automation, I am updating to the latest ISR and their tech support is looking at the design file.  However, I don't expect them to be able to replicate the issue based on my 'other PC' experiment.  Hopefully they can see something based on the dbdoctor.log file I provided them.  All else fails, I'll try and uninstall/reinstall OrCAD v16.3.

     

    --Mark

     

    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by melview1 at 28 May 2010 02:42 PM. Topic has 4 replies.