Home > Community > Forums > PCB Design > Shape to Route Keepin Spacing

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Shape to Route Keepin Spacing 

Last post Tue, Jun 12 2012 8:38 AM by Boma. 7 replies.
Started by melview1 23 Feb 2010 03:21 AM. Topic has 7 replies and 5609 views
Page 1 of 1 (8 items)
Sort Posts:
  • Tue, Feb 23 2010 3:21 AM

    • melview1
    • Top 150 Contributor
    • Joined on Wed, May 20 2009
    • Shakopee, MN
    • Posts 44
    • Points 815
    Shape to Route Keepin Spacing Reply
    OrCAD PCB Designer v16.2
     
    I am getting the following DRC error, regarding an auto-generated shape (ground or power pours).  I get it on multiple layers with multiple pours:
     
    Constraint Name = Shape to Route Keepin Spacing

    Required Value = 0 MIL

    Actual Value = 0 MIL

    Constraint Source = DEFAULT

    Constraint Source Type = NET SPACING CONSTRAINTS

    Element 1 = Shape(auto-generated) "Gnd, Etch/Inner Signal 2"

    Element 2 = Shape "Route Keepin/All"
     
    It looks as if my pours go right up to the keepin without any clearance.  This is fine for me since my keepin is pulled back by 25 mils from my board edge.  Reading the DRC error, it looks as if it is adhering to the constraint since the required value is 0 mils and the actual value is 0 mils and there shouldn’t be a DRC error.
     
    Does anyone know why this DRC is showing up and/or any settings I can change to make it not appear anymore?  I know I can waive the DRC, but that’s kind of annoying since it happens on multiple designs.  It appears that I can ignore it, but I want to be sure that OrCAD isn’t pointing something out that I am missing.
     
    Thanks,

    Mark
    • Post Points: 20
  • Tue, Feb 23 2010 4:30 PM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,182
    • Points 19,265
    Re: Shape to Route Keepin Spacing Reply

    You sometimes get these kind of DRC's if you have been changing units (mm to mils etc) or changing board accuracry (number of decimal places). It also happens sometimes on translated designs. You could try reducing the number of decimal places to see if that helps. If it not too much pain you could also try re-creating the route keepin area using the z-copy command and also the planes shape (again using the z-copy command). This command allows you to copy the board outline contracting or expanding it by a specific amount to create another shape (keepin / keepout and etch planes).

    • Post Points: 20
  • Mon, Jun 11 2012 3:19 PM

    • melview1
    • Top 150 Contributor
    • Joined on Wed, May 20 2009
    • Shakopee, MN
    • Posts 44
    • Points 815
    Re: Shape to Route Keepin Spacing Reply

    Bump.

    This issue continues to plague me.  Waiving the DRC is becoming not an option.  So frequently I waive the DRC, but then it comes back as a different DRC if I smooth the shape.  Very annoying. 

    I use zcopy to create my route keepin by contracting the PCB Outline by 20 mils.  I then create ground and power pours using zcopy by copying the PCB Outline, again contracted by 20 mils, or copying the new route keepin without any contraction.  It doesn't matter which method I use.

    I did notice that if the shape is not smoothed, I don't get the DRCs, they only show up when I smooth the shape.

    I create all of my designs in mils.  Some of my footprints might have mm as its units, but the issue never surrounds parts.  It's always the dynamic shape pours that touch my route keepin boundary.

    I have a design accuracy of 2 decimal places.  If I change it to an accuracy of only 1 decimal place, I don't get the DRC errors anymore.  I don't switch design units or accuracy once I've started a design.  Can anyone think of how I can get rid of the DRCs without decreasing the design accuracy?

    Thanks in advance.

     

    --Mark

    • Post Points: 20
  • Mon, Jun 11 2012 3:36 PM

    • Randy R
    • Top 50 Contributor
    • Joined on Wed, Jul 16 2008
    • Dupont, WA
    • Posts 192
    • Points 3,025
    Re: Shape to Route Keepin Spacing Reply

    I have a similar issue if my z-copied shapes have arcs.  As a workaround, I z-copy my route keepin (contract 25 mils) then z-copy my plane shapes (contract 25.1 mils).  This 0.1 mil difference eliminates the DRCs for what I assume is a rounding issue.

     Hope this helps,

    -Randy

    Good Day, R².
    • Post Points: 20
  • Mon, Jun 11 2012 5:01 PM

    • melview1
    • Top 150 Contributor
    • Joined on Wed, May 20 2009
    • Shakopee, MN
    • Posts 44
    • Points 815
    Re: Shape to Route Keepin Spacing Reply

     Brilliant idea.  Thanks Randy.

     

    --Mark

    • Post Points: 20
  • Tue, Jun 12 2012 1:05 AM

    • steve
    • Top 10 Contributor
    • Joined on Fri, Jul 18 2008
    • Woking, Surrey
    • Posts 1,182
    • Points 19,265
    Re: Shape to Route Keepin Spacing Reply

    If your shape is created before you add the route_keepin then you may occasionally get this. If it was created after the route_keepin the you won't see this because the default behaviour is for the route keepin to clip the shapes. There is a user preference that you can set (if you have added the keepin after the shapes) called shape_rki_autoclip that once the shapes are updated will clip them to the route keepin. This can affect performance though so won't make this a global setting for every board. Next time add the Route Keepin first.

    • Post Points: 20
  • Tue, Jun 12 2012 8:19 AM

    • melview1
    • Top 150 Contributor
    • Joined on Wed, May 20 2009
    • Shakopee, MN
    • Posts 44
    • Points 815
    Re: Shape to Route Keepin Spacing Reply

    @ Steve.  I always add my route_keepin first.  It's usually one of the first things I do.  The issue is still present.  I've deleted shapes and recreated them, using the already present route_keepin and the issue persists.  It looks to be a tolerance/accuracy/rounding thing that OrCAD does incorrectly for some shape angles/arcs.

    I'm open for any, more permanant fixes, but for now, I will use Randy's workaround.

     

    --Mark

    • Post Points: 20
  • Tue, Jun 12 2012 8:38 AM

    • Boma
    • Top 200 Contributor
    • Joined on Mon, Aug 4 2008
    • Posts 37
    • Points 515
    Re: Shape to Route Keepin Spacing Reply

    One method we use, instead of chaseing the drc's around the board outline, is to add an oversize clearance value to the shape on the layer that is giviing us problems.  This can also be done globally from the Global Dynamic Shapes Parameters form.  In MM we use a small value like .002 or .004 mm which usually eliminates this issue.

    Boma 

    • Post Points: 5
Page 1 of 1 (8 items)
Sort Posts:
Started by melview1 at 23 Feb 2010 03:21 AM. Topic has 7 replies.