Home > Community > Forums > Custom IC Design > ASSURA RCX | capgen error

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 ASSURA RCX | capgen error 

Last post Wed, Nov 4 2009 7:07 AM by pitter. 4 replies.
Started by pitter 03 Nov 2009 02:59 AM. Topic has 4 replies and 5757 views
Page 1 of 1 (5 items)
Sort Posts:
  • Tue, Nov 3 2009 2:59 AM

    • pitter
    • Top 500 Contributor
    • Joined on Tue, Nov 3 2009
    • Warsaw, Poland
    • Posts 29
    • Points 485
    ASSURA RCX | capgen error Reply

     Hi,

     After successful DRC and LVS verification RCX (C extraxtion) fails with the following error:

    *ERROR* at "capgen": -res_blocking mask layer 'rblock_poly1' not defined in LVS file
    quitting.

    I have set the correct technology, the variable netlisting_mode is set to Analog. I also tried another extraction type, and always end up with the above error.

     Might be helpful (comes after error line in the logfile):

    Forking:  /home/piter/Cadence/DiskExt/Assura/tools/assura/bin/32bit/capgen -substrate_stamping_off -techdir /home/piter/Cadence/HitKit/assura/c35b4/c35b4c3/RCX-typical -lvs /home/piter/Cadence/DiskExt/CadenceDesigns/LC_Test/ASSURA_LVS/INV_LayTest/LVS_A.xcn -p2lvs /home/piter/Cadence/HitKit/assura/c35b4/c35b4c3/RCX-typical/p2lvsfile -length_units meters -cap_unit 1.0 -selected_paths_proper -p poly1,capgen_gate,diffusion -no_cap_correction -cap_ground_layer net_psub -dsub net_nwell,net_psub -lexclude poly2,poly1 -blocking CPOLY_PSUB_device:1.8,poly2,poly1 -blocking CPOLY_NTUB_device:1.8,poly2,poly1 -blocking CPOLYRF_device,met1,poly2,poly1,diffusion,fox -blocking CMIM_device:1,met2cap,met2 -blocking RPOLY2RF_device,met1,poly2,poly1,diffusion,fox -blocking NMOSRF_device,met1,poly1,diffusion,fox -blocking PMOSRF_device,met1,poly1,diffusion,fox -res_blocking rblock_poly1,net_poly1 -res_blocking rblock_poly2,net_poly2 -res_blocking rblock_met1,net_met1 -res_blocking rblock_met2,net_met2 -res_blocking rblock_met3,net_met3 -res_blocking rblock_met4,net_met4 -sw3d /home/piter/Cadence/DiskExt/CadenceDesigns/LC_Test/ASSURA_LVS/INV_LayTest/LVS_A
    *WARNING* Bad return status from RCX script generator. 0x100

     Any suggestions how to tacke the problem... thanks in advance!

     Kind Regards.

     

    • Post Points: 50
  • Tue, Nov 3 2009 3:42 AM

    • tkhan
    • Top 50 Contributor
    • Joined on Sat, Aug 16 2008
    • Toronto, Ontario
    • Posts 159
    • Points 2,220
    Re: ASSURA RCX | capgen error Reply

     Check that your ASSURA version is compatible with your PDK. You can get the version by typing 'assura -W' in terminal. Try upgrading to ASSURA32 (w/ hotfix) if you're not already using it.

    • Post Points: 5
  • Tue, Nov 3 2009 8:03 AM

    • oojah
    • Top 500 Contributor
    • Joined on Thu, Feb 26 2009
    • Posts 17
    • Points 210
    Re: ASSURA RCX | capgen error Answer Reply

     Assuming you're using a recent version of the AMS design kit, you need to run LVS as normal to verify connectivity and then rerun LVS with the "resimulate_extracted" switch set prior to running RCX.

     This is covered in the AMS documentation at  http://asic.austriamicrosystems.com/hitkit/hk400/assura/assura_rcx.html

     Cheers,

     Roger

    • Post Points: 20
  • Tue, Nov 3 2009 8:14 AM

    • Quek
    • Top 10 Contributor
    • Joined on Wed, Oct 14 2009
    • Singapore, 00-SG
    • Posts 1,051
    • Points 15,990
    Re: ASSURA RCX | capgen error Reply

     Hi Pitter

    This problem usually occurs when the layer names in the rcx techfile run script RCXspiceINIT goes out of sync with the layers used in the lvs extract.rul file. During compilation of the techfile to generate the runscripts, commands such as "-res_blocking" requires layer names that are used in the extract.rul file. Sometimes the extract.rul file might be updated with some changes in layer names (e.g. rblock_poly1 might have now become rb_poly1). When this happens, you get the above errors.

    Here is what you can do to resolve the problem:
    a. Examine the Assura extract.rul file and make an intelligent guess on the new name for layer "rblock_poly1"
    b. Copy the entire rcx technology directory to your home directory. The is the directory with the files caps2d, capsw3d, etc.
    c. Copy the design.xcn file in the Assura lvs run dir to the rcx tech dir and rename it as "lvsfile"
    d. Redo capgen compilation using the following cmd and the new layer names:

    unix>capgen -C -length_units meters -cap_unit 1.0 -selected_paths_proper -p poly1,capgen_gate,diffusion -no_cap_correction -cap_ground_layer net_psub -dsub net_nwell,net_psub -lexclude poly2,poly1 -blocking CPOLY_PSUB_device:1.8,poly2,poly1 -blocking CPOLY_NTUB_device:1.8,poly2,poly1 -blocking CPOLYRF_device,met1,poly2,poly1,diffusion,fox -blocking CMIM_device:1,met2cap,met2 -blocking RPOLY2RF_device,met1,poly2,poly1,diffusion,fox -blocking NMOSRF_device,met1,poly1,diffusion,fox -blocking PMOSRF_device,met1,poly1,diffusion,fox -res_blocking rblock_poly1,net_poly1 -res_blocking NEW_NAME,net_poly2 -res_blocking rblock_met1,net_met1 -res_blocking rblock_met2,net_met2 -res_blocking rblock_met3,net_met3 -res_blocking rblock_met4,net_met4 -sw3d -p2lvs p2lvsfile -lvs lvsfile .

    Please also note the following:
    a. With the introduction of the EXT package (latest version EXT815), it is no longer advisable to use the very out-dated Assura rcx to do parasitic extraction. Extraction should now be done using the unified extractor "qrc".

    b. The corresponding replacement for "capgen" is "Techgen" from EXT package

    c. The above error should be reported to the foundry so that they can updated their qrc/rcx packages.

    d. I am not sure  of the Assura version which you are using but it is advisable to use the latest Assura41HF4.

    Best regards
    Quek

    • Post Points: 5
  • Wed, Nov 4 2009 7:07 AM

    • pitter
    • Top 500 Contributor
    • Joined on Tue, Nov 3 2009
    • Warsaw, Poland
    • Posts 29
    • Points 485
    Re: ASSURA RCX | capgen error Reply

    Assura update did not solve the problem, but oojah's suggestion was very helpful and tackled the problem. I have not tried out Quek's solution, but thanks for the explicit description.

     

    Best wishes,

    Pitter

    • Post Points: 5
Page 1 of 1 (5 items)
Sort Posts:
Started by pitter at 03 Nov 2009 02:59 AM. Topic has 4 replies.