Home > Community > Forums > Custom IC Design > Problem with Simulating Design using Spectre

Email

* Required Fields

Recipients email * (separate multiple addresses with commas)

Your name *

Your email *

Message *

Contact Us

* Required Fields
First Name *

Last Name *

Email *

Company / Institution *

Comments: *

 Problem with Simulating Design using Spectre 

Last post Tue, Jun 9 2009 5:02 PM by govilv. 13 replies.
Started by govilv 04 Jun 2009 01:22 PM. Topic has 13 replies and 9273 views
Page 1 of 1 (14 items)
Sort Posts:
  • Thu, Jun 4 2009 1:22 PM

    • govilv
    • Not Ranked
    • Joined on Thu, Jun 4 2009
    • Posts 9
    • Points 165
    Problem with Simulating Design using Spectre Reply

     I have created a schematic using Virtuoso 6. When I open the ADE, it says "(deLicense-7) Could not get a license for ADE L. Would you like to try to get a higher-tiered license to run this product?"

    When I click on Yes, it starts the ADE, but when I set up the analysis and click on "Netlist and Run", it comes out with an error -

    "Error Unable to locate 'spectre' executable in the specified path. To set the correct path, use setShellEnvVar() in CIW."

    I am new to this kind of problem and when I try to check my spectre version and type "spectre -W" in the CIW, it gives me errors. Am I missing a piece of software or it can be fixed without installing anything else?

    Please help. Thank you.

     Raj.

    • Post Points: 20
  • Thu, Jun 4 2009 6:40 PM

    • tkhan
    • Top 50 Contributor
    • Joined on Sat, Aug 16 2008
    • Toronto, Ontario
    • Posts 159
    • Points 2,220
    Re: Problem with Simulating Design using Spectre Reply

    How is your license server configured? Type "lmstat -a | grep Analog" and make sure you have a valid license for Analog_Design_Environment_XL. 

    what error do you get when typing "spectre -W"? does it just say "command not found: spectre"? do you have $CDS_INST_DIR/MMSIM/tools/bin (or $CDS_INST_DIR/IC/tools/bin if you're using the old spectre) in your PATH? try "cds_root spectre"

    • Post Points: 20
  • Thu, Jun 4 2009 11:57 PM

    Re: Problem with Simulating Design using Spectre Reply
    My guess is that you're using IC61 which doesn't have spectre included. You need to install MMSIM (e.g. MMSIM71) to get spectre.

    You need type "spectre -W" from a terminal window, not the CIW.

    Regards,

    Andrew
    • Post Points: 20
  • Fri, Jun 5 2009 1:47 PM

    • govilv
    • Not Ranked
    • Joined on Thu, Jun 4 2009
    • Posts 9
    • Points 165
    Re: Problem with Simulating Design using Spectre Reply

    Thanks for the reply.

    I guess I do not have MMSIM installed. Couldn't find it in my cadence installation directory. How do I install it? 

    And if I want to use the old spectre with Cadence 6, is it possible? How should I add the path? There's no specific path variable for spectre and path for Cadence is set to the new one.

    Please help.

    Thank you.

    • Post Points: 35
  • Fri, Jun 5 2009 2:01 PM

    • tkhan
    • Top 50 Contributor
    • Joined on Sat, Aug 16 2008
    • Toronto, Ontario
    • Posts 159
    • Points 2,220
    Re: Problem with Simulating Design using Spectre Reply

     As Andrew pointed out, IC6 doesn't come bundled with spectre. I'm not a tool expert but I think spectre from the IC stream is quite old and most (if not all) users have moved to the MMSIM stream. So you're gonna have to install MMSIM in order to simulate...

     As far as adding it to the path, your source script should have a line such as

    PATH=$PATH:$CDS_INST_DIR/MMSIM/tools/bin

    .. (other tools)

    EXPORT PATH

    If you need MMSIM, connect to Cadence Sourcelink and obtain it, or get it from your technology provider. Your network admin should be able to install all the tools, set up a license server and write the proper source scripts for the tools... Or perhaps you can contact your local cadence support rep? See what I'm alluding to here...
    • Post Points: 5
  • Fri, Jun 5 2009 2:01 PM

    • skillUser
    • Top 10 Contributor
    • Joined on Fri, Sep 19 2008
    • Austin, TX
    • Posts 2,586
    • Points 15,895
    Re: Problem with Simulating Design using Spectre Reply

     Hi,

    You can download/install the MMSIM releases from the downloads site, using InstallScape (you might need to download and install this first, the details are also on the downloads site - it is available alone or as part of the Lic+Config Utils package).

    Yes it is possible to use a newer (e.g. MMSIM7.1) version of spectre with the IC61x release (or IC5141 for that matter).

    Once installed, you will want to have spectre in your path in addition to the IC release tools; if you are using the IC61x tools then I don't think it will matter if MMSIM is in the path first or after the IC tools, but as you noted, if using IC5141, spectre is included in that release, so if you wanted to use a newer version of spectre, MMSIM would need to be in your search path earlier than the IC tools.

    The path to add is <mmsim_installation_dir>/tools/bin, this should be sufficient to pick up spectre.

    Hopefully this answers all your questions.

    Regards,

    Lawrence.

    • Post Points: 20
  • Mon, Jun 8 2009 1:24 PM

    • govilv
    • Not Ranked
    • Joined on Thu, Jun 4 2009
    • Posts 9
    • Points 165
    Re: Problem with Simulating Design using Spectre Reply

    Thanks for the reply. My question is - can I use the old Spectre with new Cadence? 

    Thanks again.

     Raj.

     

    • Post Points: 20
  • Mon, Jun 8 2009 1:40 PM

    Re: Problem with Simulating Design using Spectre Reply

    Two questions:

    1. Which version do you mean by "old spectre"?
    2. And why on earth would you want to do this?

    If using IC613, it only really makes sense to use a simulator version which is recent - for example, MMSIM70 or MMSIM71. SImulators get updated quite frequently, so I cannot see why you'd want to use an "old" simulator...

    Regards,

    Andrew.

    • Post Points: 20
  • Mon, Jun 8 2009 1:45 PM

    • govilv
    • Not Ranked
    • Joined on Thu, Jun 4 2009
    • Posts 9
    • Points 165
    Re: Problem with Simulating Design using Spectre Reply

     I don't want to do this, but I do not have MMSIM, so this seems to be the only option if it is possible at all.

    How can I download MMSIM? I went to the download page and logged in and it did not show me anything but 'Profile Update' link!

    Thanks for the help.

    • Post Points: 5
  • Mon, Jun 8 2009 1:46 PM

    • govilv
    • Not Ranked
    • Joined on Thu, Jun 4 2009
    • Posts 9
    • Points 165
    Re: Problem with Simulating Design using Spectre Reply

    spectre v5.10.41. I was using it with my Cadence 5.

    • Post Points: 20
  • Mon, Jun 8 2009 1:54 PM

    Re: Problem with Simulating Design using Spectre Reply

    Using spectre from IC5141 with IC61 would be a seriously bad idea. It's not tested, and there are a bunch of dependencies which won't be met if you try to do this.

    Did you try downloading from http://downloads.cadence.com - or were you looking elsewhere?

    Or contact your Cadence support. They can help you.

    Regards,

    Andrew.

    • Post Points: 20
  • Mon, Jun 8 2009 2:01 PM

    • govilv
    • Not Ranked
    • Joined on Thu, Jun 4 2009
    • Posts 9
    • Points 165
    Re: Problem with Simulating Design using Spectre Reply

    Thanks Andrew, I appreciate your support and patience. I'll ask my system administrator for this installation. 

    Regards,

    Raj.

    • Post Points: 20
  • Tue, Jun 9 2009 2:38 PM

    • sediyahoo
    • Not Ranked
    • Joined on Tue, Jul 8 2008
    • Posts 1
    • Points 20
    Re: Problem with Simulating Design using Spectre Reply
    Any luck on this?
    • Post Points: 20
  • Tue, Jun 9 2009 5:02 PM

    • govilv
    • Not Ranked
    • Joined on Thu, Jun 4 2009
    • Posts 9
    • Points 165
    Re: Problem with Simulating Design using Spectre Reply

    I did not try running old spectre with new virtuoso. Instead, I installed MMSIM to do the job.

    Thanks everyone for the valuable suggestions.

    Cheers,

    Raj.

    • Post Points: 5
Page 1 of 1 (14 items)
Sort Posts:
Started by govilv at 04 Jun 2009 01:22 PM. Topic has 13 replies.